Simulating two cloth layers


Am I going crazy?
I have a character wearing a long robe - no probs with the sim; buuuut, when I try to sim his small waistcoat on top of it, it all goes to pieces :eek:
Basically, the waistcoat cloth won’t recognise the duplicated robe (connected ‘InMesh’ - ‘outMesh’ to original robe; duplicate being a collision object for the waistcoat)
Real world cms. scaling etc.

help :cry:




You only want the waist coat to react to the robe, right?


You only want the waist coat to react to the robe, right?

Yep, that’s right; trouble is that the simulation of the waistcoat won’t recognise the collision object properly, unlike the robe which collides as expected…
Maybe there’s a simpler solution to this problem:shrug:



its pretty hard to answer a question like that without seening the scene… that sould be easy enough…

can you post the scene?
or if you dont want to post publically, send me a pm and I can have a look at it if you like.


I have come across the same type of problem with my project. You probably have already tried my fix, but I found that if I:

  1. Delete all the cloth attributes and keep only the polygon shape
  2. Re-create the cloth attributes from the polygon shape
  3. Simulate and spend “forever” monkey-ing with the collision settings

It has worked out well for me so far… For some reason I can spend a long time messing with the collision settings and get nothing but garbage. Even when I know that it should work. Then, upon deleting everything but the cloth polygons, and starting over it seems to always simulate correctly.


can you replicate the problem with a simple scene?

Sorry to say, but I haven’t had that type of problem…

maybe it’s something with your collider attr’s?

or resolution? or some connection order thing…

what does the cloth do when you disable the collider?


Thanks for your useful advise and time, John; all works great now with the added ‘damp’ node as you suggested :slight_smile:

Yeah, recreating ‘clean’ cloth attributes (or at least a clean ‘frame-of-mind’!) seems to have helped, also… :wink:

Cheers! it was originally a ‘collider/connection’ thing, but all’s OK now; thanks :wink:



This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.