[Simple problem]Realflow + Cinema 4D Particle Importer


#1

Hello people!

I’m currently digging myself deep into the liquid world of RealFlow but I’ve stumbled upon an issue.

When I create a Sphere emitter with different daemons attached then import it with the Particle importer non of the particles appear in Cinema 4D.

If I just change the Sphere Emitter into a basic Circle simulate it then everything works fine, but not with the Sphere Emitter.

Could anyone else just quickly try importing a tiny simulation of particle with the sphere emitter into Cinema 4D and see if it works for them, I can’t find anything online about this.

Extra info: The Sphere emitter is animated in the X and Y axis.

Thank you!


#2

Yepp, works. I have just tested it with RF6.0.2 (2012) and C4DR14. I guess it is a workflow problem such as using the correct file sequence for import or something like that.


#3

Thank you so much for your response Christian!
Ok just to make sure I’ve not done something outrageously stupid I’ll summarize the short.

[ol]
[li]Simulate the animated Shpere Emitter.
[/li][li]Save the project, open Cinema 4D.
[/li][li]Put the “Realflow particle importer” in the object window
[/li][li]Import the list of .BIN files from the Particles folder from my Project.
[/li][li]Then VOILA!
[/li][/ol]

Have I missed something!?

I use the same version of Realflow only Cinema 4D R13…


#4

works here fine with R13 and R14, too.
maybe check the settings in the ParticleSettings: Max Particles, View Type (None?).
or upload the reduced scene file (bin loader only with no geometry, models, materials, cameras etc) plus a few of the particle-bin-files (10 should be enough) and i can have a look if you want.
cheers
fuat


#5

Thanks mate, but I solved it.

But it doesnt make any sense for me but here I go might be a person out there that might’ve be in my situation.

The Geometry Scale was correctly set at 0.01 in RF and this works perfectly with particle from 2D emitters (Circular, rectangular and so forth.) but the 3D ones not so much.

Instead I kept the 0.01 geometry scale in RF and when I imported the particles into Cinema 4D I changed the “Scale” from 1 to 0.01 too. And that worked great.

TL;DR In the Real Flow Particles Importer, change the scale to 0.01 in Cinema 4D and the Geometry scale to 0.01 in Real Flow.


#6

glad you solved it.
yes, the unit-scale issue is old and well known but still annoying (cinema units 100 x bigger than RF units), you are right indeed.
but didnt you (in your initial post) say the particles didnt show up at all?


#7

Yes, I was incorrect and this is also how I figured it out actually.
When I imported the particles my computer became bit sluggish, and I assumed by that I had particles loaded and I rendered then out some simple hair particles to get vision of them in the view port. Dussin frames in I see one single particle on the far edge of the screen. Scroll for an eternity back to further zoom my view port out and I notice another on the other side of the screen.

Then I changed the scale, saw the result and smacked my face repeatedly into the closest concrete wall.

I should also say that I had 0.01 in Geometry Scale all along in RealFlow just not in C4D.

Thank you Fuat and Christian for your time and help!


#8

this is actually the most crucial setting in rf when working with cinema.
glad you solved it.
ciao


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.