Simple Life: rigging


#121

Hey M.E.L. sorry to bug ya man. But it happens in my other scene as well. It loads the orange geo…it’s just not attached to the rig. Is there a special way I should be loading this guy? I’m a little concerned, but i’m sure it’s an easy fix for you guys that know the code a bit more than me. I’m sure i’m doing something wrong. IF you want a detailed description of how i’m setting up my scenes and such, ask away and i’ll let you know. I’ve never had this happen before so I don’t know where to begin to fix it. Any help is appreciated man…thanks for your time:)


#122

The setup for the scenes should be:

Reference in the orange scene file into your animation scene.

Animate.

I’m gonna be MIA for about the next 10 days as I have over 1400 assets to build ingame and conveniently half the team is on vacation for the next week so I’ll only be briefly browsing through here when i get the chance. Sorry guys, just toally knackered right now with work.

-s


#123

Also I am moving back to Finland after next week so I am not sure yet when I´ll be OFFline, during next week for sure, but I am still reading these forums avarage ones a day during next week from work! and I should be back ONline after two weeks, so you are quite much on your own next half month!


#124

ok…not sure if I did it correctly…damn…is there a way for me to fix what I have or do I need to redo?

What I did was I loaded the orange_rig and then imported the room and made duplicates of orange for the greys and then animated. the greys are fine though. Bit strange.

Let me get this straight. I load the room obj…position blah blah…and then I import orange rig? Or how do I exactly reference the file into the scene? Sorry for the stupid questions?

Here’s what my SE says when I load the ASCII file:

pv_performAction “D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma” “Best Guess”;
// D:/CGT_SimpleLife/A_Simple_Life_Story/geo/orange_charGeo.ma
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 6: A preference for the file reference D:/CGT_SimpleLife/A_Simple_Life_Story/geo/orange_charGeo.ma was not found; using default load behaviour. //
// D:/CGT_SimpleLife/A_Simple_Life_Story/geo/orange_charGeo.ma
optionVar -stringValue preloadRefEdTopLevelFile “D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma”;
PreloadReferenceEditor;
// Result: 1 //
// File read in 0 seconds.
// File read in 0 seconds.
// Warning: The node ‘orange_charGeo_topNodeN_1’ still clashed with a node in the main scene. Renaming to ‘orange_charGeo_topNodeN_2’. //
// Warning: The node ‘orange_charGeo_lightLinker1’ still clashed with a node in the main scene. Renaming to ‘orange_charGeo_lightLinker2’. //
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 41251: No object matches the parent name: ASLS_Orange_Rig:orange_charGeo_Orange //
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 41259: No object matches the parent name: ASLS_Orange_Rig:orange_charGeo_geometryN_1 //
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 47299: No object matches the parent name: ASLS_Orange_Rig:orange_charGeo_geometryN_1 //
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 53362: No object matches the parent name: ASLS_Orange_Rig:orange_charGeo_geometryN_1 //
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 59208: No object matches the parent name: ASLS_Orange_Rig:orange_charGeo_geometryN_1 //
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 65110: No object matches the parent name: ASLS_Orange_Rig:orange_charGeo_geometryN_1 //
// Warning: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 71012: No object matches the parent name: ASLS_Orange_Rig:orange_charGeo_geometryN_1 //
// Error: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 779830: No object matches name: ASLS_Orange_Rig:orange_charGeo_topNodeN_1 //
// Error: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 779832: No object matches name: |orange_charGeo_topNodeN_1|orange_charGeo_geometryN_1|orange_charGeo_Orange|orange_charGeo_OrangeShape //
// Error: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 779835: No object matches name: |orange_charGeo_topNodeN_1|orange_charGeo_geometryN_1|orange_charGeo_Orange|orange_charGeo_OrangeShape1Orig //
// Error: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 779843: The destination attribute ‘ASLS_Orange_Rig:orange_charGeo_Orange.do’ cannot be found. //
// Error: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 779845: The destination attribute ‘ASLS_Orange_Rig:orange_charGeo_OrangeShape.do’ cannot be found. //
// Error: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 779847: The destination attribute ‘ASLS_Orange_Rig:orange_charGeo_OrangeShape1Orig.do’ cannot be found. //
// Error: file: D:/CGT_SimpleLife/000-015/shot000_015Blocktest_0001.ma line 788014: The source attribute ‘ASLS_Orange_Rig:orange_charGeo_OrangeShape.w’ cannot be found. //
// File read in 25 seconds.
// Warning: Errors have occurred while reading this scene that may result in data loss.
Please check the Script Editor for details. //
// Error: Object not found: dynPaintScriptedPanelType //


#125

I still dont know what has happend to your file its a one big mess! and I am too tired to find solution at the moment

but there is way to transfer that animation from that animated rig to one which works!

1.so what you need to do is to first clean up the file delete everything you dont need…
2.and then select all of the controls from animated rig
3.make character set from it
4.make clip from your animation
5.dupe new orange
6.deleta animation from it
7.select all the controls from it
8.make character set again
9.then open character mapper and load source and target CS
10.map everything what is needed
11.after you have done it you can copy and paste your clip to new CS

I dont have now time to qive indepth tutorial to do it so you need to find your way around it!

but if you have questions, just ask!

there might be also easier ways to do that, but this is quite straightforward!

Good Night!


#126

Hey corn…exactly how do I go about loading a reference file into the room scene. BTW i’ll try your solution as soon as this weekend is over. Got family here:) Happy 4th


#127

actually I dont know what needs to be referenced where, but you propably should do it with Renference Editor or just Create Reference (those both are under File dropdown menu)


#128

For the love of pete…I figured it out. uhhhgg:) thanks


#129

Ay Ryan, I can’t seem to get a hold of you, what is yuor number again??? I am the guy you met at the Venetian the kid sitting at the charicature booth…holla!


#130

Hey Beelow…yea I remember you. Drawing your medievil type of guy. How is that going? moved on or still tackling it? You should show it here. I’ll PM you with my info. I’m not in Vegas anymore…but I may be coming back to see some of the people I worked with. Talk to you soon.:slight_smile:


#131

Yeah I finished it! It looks ok looking now that I look back at it. Yeah, eventually I will show that guy here. It is hanging at School in one of the cases as of now. But, maybe I will see you around in Vegas, holla!!!:thumbsup:


#132

I’ve heard some mention in other threads that there is an issue with the rig. What’s the latest problems? And how soon can we expect the issues to be resolved?


#133

AFAIK all of the issues were corrected and dealt with… no other issues were brought to my attention in regards to the rig in this thread other than the most recent issue with Remi.

:curious:


#134

Yo dudes, hows it hanging? The rigging all done on this one? :smiley:


#135

I opened up the scene files and the Orange rig doesn’t
have any blendshapes added. I tried doing it myself but
the command line says the main object isn’t deformable.

I also encountered some weighting issues, if you try to
translate or scale the main control, some clusters get 
left behind.

I have Maya 6.5 here and I was wondering maybe that’s
why I’m having these problems. Someone enlighten me
please? =)


#136

Re: Tessa.

You have downloaded the wrong zip file. And before you start doubting - I did exactly the same thing! :cry:

The weight problem has defintely been solved, and the blendshapes are avaliable by selecting the big “BS” above the rig. You can adjust them using the Channel box.

Go to the FAQ section and download the latest rig there. If all else fails I can send you the zip file myself. :beer:


#137

Ooops, my fault. I sent Tessa the wrong rig file. :blush:
Tessa - PM or e-mail me again so I have your correct e-mail address (didn’t save last one), and I’ll try it again. :smiley:


#138

ok… whew… i just PM’d Kirt.
sorry for not following up… i’m trying to get wifi access at home
so i can work from there as well.

thanks, Boone. i’ll PM you if i have trouble finding my way
around the rig. :smiley:


#139

wow have I been absent…

my apologies on that one to Kirt and anyone who has been using the rig. I’ve been stuck with a beautiful mix of airplanes, airline food, jet lag and redbull the past month and some.

So how are things rigging wise here? Is Orange still holding up ok? Are we in need of anymore shapes added to him? Talk to me here people! :stuck_out_tongue:

I’m inbetween jobs at the mo so if there is anything wrong, you guys know where to reach me. And Kurt, where do we stand as far as % of completion on the project?

-s


#140

Re: MEL.

Its a damn good rig. The only snag I’ve had is having to create my own character sets, but they would vary shot-to-shot anyway.

I’m currently on Animation duty, but I desperately want back on the rigging dept for the next gig we do! :cool: