Silo 2.5.6 won't launch on Mac OS X



Both my older version 2.5.1 and the newer version I just downloaded are not booting on Mac osx 10.13.6. The app installed no problem. I double click the app and it appears to start loading, “Silo” app name appears top left on display and then it quits.

Any help is appreciated.




Same exact thing happening here on windows 10.


Sorry to hear that. Maybe now that is more than one, and cross platform the developer can chime in with a suggestion?



I think you will be better off contacting nevercenter support directly; they are usually pretty quick to reply:


Thanks. I have emailed them twice since November and still no reply.


Hi Cadmodeler and rusteberg,

Sorry about the crashing! (Cadmodeler, we just got your email from 2 hours ago and have replied with a few more questions which we’ve emailed back to you.)

We’ve tried to recreate this issue but unfortunately/fortunately Silo 2.5.6 is running fine for us on 10.13 and Windows 10–can you two give us any more information about the crash to help us figure out what might be happening?

  • Have you previously run Silo successfully on your system? (if so, what version)
  • When did the program start crashing? (was it working until you did an update? was this the first time you have installed the software on your computer? did it crash in a work session and then not open properly again after that?)
  • When it crashes, do you get any error message? (if so, please send us the

Thanks! Hope to get it up and running for you soon. :slight_smile:


For whatever reason it is working now… Not sure if it was a windows update, a security issue or driver issue of some kind. Who knows. If I remember correctly, PCmatic was trying to block it back when I was having trouble opening silo. Pretty sure there’s been a windows update since then and I recently updated a graphics driver. Anyways it’s running fine now for me here on the windows machine that was having trouble before, so all good. If it starts acting funny again I’ll post here or contact yall through the support link above - thanks!


I am running on a Mac Pro 5.1 with a flashed NVIDIA GeForce GTX 770. A while ago I became no longer able to load Nvidia drivers on my machine. I have been running the built in Mac OS X driver. If Nevercenter is reading this— is there anything happening at launch of Silo that is vide driver related?