Silo 2.3


#27

I’m in contact with the EIAS guys about this already. I don’t have a resolution on it yet, though.


#28

I’ve tried to repro the MMB zoom issue, but so far it hasn’t had any errant zooming. It could be something with the new Qt 5 event handling, but it sounds like your scroll wheel is super sensitive or the drivers are a bit flaky. Are you able to pan around with alt+MMB and also zoom in and out with the scroll wheel at the same time? (I was.)


#29

Heh, you guys are funny. I’ve been posting fairly regularly over the last couple of months, so that’s at least slightly better than no word at all. :wink: Silo 2.3 is not rumor, we’re in process of releasing each platform and release channel (download, steam, mac app store). There will be more formal announcements coming soon, I believe. Again, this is not a ground-breaking release feature-wise, it’s a bug fixer and internal modernization for the most part. There are a few new features, though.

We’ve been beta testing with a number of you guys (those who PM’d me from the other thread, thanks guys!) but we expect a few small bugs/hiccups to crop up. If there are any issues, especially show stoppers (crashes, freezes, unfixable corruption of geometry, that sort of thing), please let us know (email support@nevercenter.com). Those issues will land on my plate and I’ll hit them as quickly as I can. We already squashed a good handful of bugs in the beta testing cycle.


#30

I e-mailed Nevercenter about the OSX Professional version 2.3. I talked about the alt+c not created a cube, it does nothing. And the same with Alt+Y.

And another annoying thing is saving a scene in V2.3, and opening it up later, all the changes made to an object are gone? But when I open the same file in V2.2 the changes are there?

I hope these and other bugs I reported are fixed. By the way, is it O.K to make suggestions on what I like to see enhanced in Silo?


#31

When the issue happened i didn’t have any dedicated drivers installed using the ones that come with win7 install. Then i installed Logitech’s setpoint drivers and the autoscrolling is gone… but when i click the wheel to pan it zooms once a little bit.


#32

hey mikefarny, what about linux version ?


#33

If there is a save issue on OS X, that’s no good at all. I haven’t run into that in particular, but I’ll try to repro it. The OS X version is now sandboxed, so it’s possible that is tripping it up somehow. I tested alt+c and alt+y in linux just now and it works there, but I’ll try in OS X soon.

As for making suggestions, go for it. We evaluate what gets added on a case-by-case basis, but knowing what helps you guys out of course helps us to decide.


#34

It’s coming. :wink: What distro are you on?


#35

Can you try a different mouse? Maybe if you have a Microsoft mouse sitting around or something you can swap in? I’ve had issues before with certain mice where when I press the scroll-wheel as a button it will occasionally register a bit of scroll. It seems to me that the mouse may be causing a scroll-up to be registered every time it is pressed, and the logitech drivers are doing you a favor and actually blocking the scroll-up when the button is pressed (making the issue better, but not fixed). Using a different mouse would hopefully confirm that.


#36

Thanx :slight_smile:

My distro is Gentoo :smiley: But it doesn’t matter for minimalistic programs like Silo, especially with Qt base.

Ok. What about 64 bit ? :wink:


#37

The linux build is only x86-64, and is built on a base of RHEL/CentOS 6. It’s distributed with DSOs such that it should be compatible with a fairly wide range of distros and releases, as long as they have a reasonably modern Xorg and glibc (same or newer as what ships with RHEL 6).

So far, it’s confirmed to work on RHEL/CentOS 6 (obviously), recent Ubuntus, recent Fedoras. It didn’t work right on Lubuntu (corrupted/black window display, which is surprising, given that the distro is based on Ubuntu).

Gentoo, slackware, debian, suse, and others haven’t been tested yet. I of course would be interested to know how it fails if any of those distros; sometimes it’s just a matter of grabbing a DSO from CentOS and including it in the installer.


#38

So, I tried linux version.
First of all silo folder has no SDCopy.zip file. I get it from windows version (works well with wine) and it get me black screen as you noticed about lubuntu. My window manager is fluxbox


#39

There’s an updated installer coming. I’ll see if I can play with fluxbox (or just install gentoo in general). It’s hard to create a GUI app that will run out of the box on all distros, so bear with us as we try to make it as compatible as possible.

In the interim, silo runs fine in VMs, so you could throw it in a vmware player + centos 6 setup if you just can’t wait. :wink:


#40

I can wait :wink:

Thanx for development of my favourite minimalistic modeller.


#41

The linux download is fixed, and the installer is corrected. It doesn’t fix the fluxbox/gentoo issues, though.


#42

Thanks for the reply Mike. All the mice i have around here are the same Logitech model, since they have worked well for us. I have Silo 22 still installed (keeping it for now, until the dust settles) and this issue is not there. Could it be the data folder conflict you guys talked about? Can i still have the 2 versions of silo installed without problems?
Im sure its something minor… i’ll play around with the logitech drivers and experiment.


#43

I’m using a logitech MX1000 and do get a slight judder occasionally when zooming with MMB - I thinks its because the MMB is poorly designed, it’s easy to rock it left or right when pressing down. Left and Right on the wheel zooms in/out.

That should be OK for now, but down the road there may be issues with the prefs data as features are added etc.


#44

I use a Microsoft Comfort Optical Mouse 1000 it works with
everthing I have including Silo 1.42 - 2.3


#45

Some time ago i bought the Logitech Performance Mouse MX™ , but i couldnt get comfortable with it, too many buttons, too big for me. then we settled with this one. I keep bringing up this issue, because i use the mouse almost 10 hours a day in Unity, Flash, Photoshop, Silo 22, 3DCoat and so on… and i never had this issue. Even now i open silo 22, 23 and Unity side by side… and the jump only occurs in 23. There must be some difference in the code that handles MMB.


#46

I don’t know if there is a setting to change this or maybe it is a common issue, or maybe just with osx? But when I select one vertex, I want to frame the selection (Ctrl+F), it only works if 2 or more vertices are selected. Can it be done with just one vertex selected?