Silo 2.3 officially released


#21

Which ubuntu version? Any other changes from the usual besides just using the binary nvidia drivers?


#22

Hello dear Mike, I use Ubuntu 14.04 64bit, the newest version. Black screens I have also with the free opensource driver. I did have the same also with Lubuntu and Kubuntu …

I changed nothing after the installation. But maybe there are some fragements from Kubuntu in Ubuntu? Because I used the same partitions / and I didn’t have made a format of these. But ubuntu runs fine, only not with silo …

End the gear test (glxgears) was also fine, with fast rotations.

In Windows runs the new silo 2.3 fine (I have a dual-boot-system).


#23

An update(!), great news, I’m back to Silo after a very long time! No problems so far on my MAC (OSX 10.9.4)


#24

I’m just wondering now how many of these posts from ‘users’ are from fake accounts. Here is a grab from nevercenter’s fb page where there is a comment from a ‘user’ but NC have forgotten to switch accounts. That’s pretty unprofessional and embarrassing. Unless there is a simple explanation of course…


#25

Who cares, they are just a small team of developers. You are just being petty. :curious:
But it is funny! :smiley:


#26

I’m in facobook too, but why I should use in facebook my realname? So I’m a facebookfake too … but it means nothing, because I’m a Silo-User since some years :wink:


#27

Can any of you who experienced the black-screen issue on Ubuntu (or derivatives thereof) who haven’t yet been in contact with Nevercenter support PM me or email support@nevercenter.com? We have an Ubuntu 14.04 LTS specific build that we’re testing to see if it fixes the issue.

I tried for the life of me to reproduce the issue, but I couldn’t ever get it to trigger. So the build is a tiny bit of a shot in the dark, but we’d like to not force people to run Silo in a CentOS or Fedora VM if their primary is Ubuntu. :wink:


#28

I installed Fedora on a extern USB-HDD, but I did have there also black-window issues. Is this maybe also an issue with my hardware also/only?

Okay, today I did get a mail from Stephanie from your company, I will try that build :slight_smile:
But I couldn’t dowload it from google, I will try it tomorrow - its a google problem …

ps. Maybe it will run okay, if I will spend next weeks a new GPU - I will replace my weak Geforce GTX 550Ti with a new GTX970 … (not for silo, because silo don’t need a powerfull GPU, but for other grafic tools I need more power & vram).


#29

You also got it on Fedora (20 I assume)? :curious: I’m beginning to wonder if Silo is doing something odd with OpenGL that is tripping up on certain hardware. I’ll keep investigating, although it’s hard because I simply haven’t been able to trigger the black screen issue at all on any of my setups.


#30

I’ll ask Stephanie what happened with that comment, because that does look pretty bizarre. I don’t have any access to the Silo3D facebook account (heck, I don’t even have a facebook login for myself), but it’s probably just a comment from a user that came in via email that she was quoting and didn’t properly attribute. She’s definitely not one to pull shenanigans. :wink:


#31

First reports back regarding the custom Ubuntu build are that it doesn’t solve it, so back to the drawing board for me on that issue.


#32

I’m running on Fedora 21 and don’t have the black screen problem. I’m using the 343.36 version of the Nvidia driver on a GTX460, if that helps.

I have another issue, when I rotate, pan and zoom (also when using the manipulators) the program is really slow. It takes it a while to catch up with my mouse movements and makes it difficult to use.


#33

The black-screen issue seems to be a locale thing, so if you had by default a US-based locale (or at least a numeric locale where numbers are written as 123,456.78 instead of 123.456,78) then you wouldn’t see the issue.

I’ve seen the slowness in response; usually this happens with models that have been highly subdivided and thus have lots of polygons to display through OpenGL. I’m looking into possible solutions, but it’ll take a while as it’s a general optimization issue in how Silo displays it geometry. As we improve our usage of OpenGL the lag issue will be mitigated to a large extent (as well as allow you to model with higher poly counts).


#34

In testing on Windows 7 64 bit, I can’t open and .stl file. It either hangs and never opens or crashes.

I tested each file by opening in other software before trying. They open just fine, but not in Silo.


#35

Confirmed. I downloaded an stl file to test and it does crash silo. It was a binary stl file.

Checked Silo’s stl export opts, and Export Binary is checked, but the output is certainly ascii so seems there’s an issue with binary stl in silo.


#36

Thanks for responding Mike. :slight_smile: Unfortunately the lag issue happens irregardless of the poly count. Even a cube is slow to manipulate, or using the lasso select, etc.


#37

I tested it too under OSX but here it’s working fine. binary stl import and binary stl export.

Regards
Stefan


#38

Thanks for confirming that for me. I’m just converting them to .obj’s so no biggie, but it would be nice if it worked.