Silo 2.3.1 - Bugs


#1

Be constructive and helpful:
Highlight your issues (one per post) with a step by step guide for replication.
Dev’s will hopefully be watching!


#2

…and there in lies the rub. :wink:

I had a post about this in a completely unrelated thread a month or two ago about this. I was/am new to Silo. Very impressed. Never got the whole “it’s buggy” thing…until I started to learn how to use it more and more and my models got more and more complex. Then I started to get odd…“happenings”.

My main complaint was that the bugs seemed to be random and unpredictable. I’d do three steps to get some shape, no problem. I’d do it again…bug. I’d open a new file and start a new model to test this. Do three steps…different bug. Delete. Try it again…no problem. That was the thing that made me have to put Silo in the background on the shelf next to Hexagon.

It wouldn’t be too bad if there were mostly “gotcha!” bugs. Ones that actually have reproducibility. You know, “If you do A, then B, then C…you will get Error D”. We could just work around those. Every program has those. Annoying, but you learn to live with it until the next update…

…speaking of which… :wink: I don’t think there will be another Silo update. :frowning:

With all that said, I’m keen on seeing actual reproducible bugs so I can at least avoid those. :slight_smile:


#3

I’ve just downloaded the latest trial.

It doesn’t look like a bug has been fixed with the Slide tool, which scrambles the values in the viewport.

I have written to the team often, praising the potential of this lovely modeller. I don’t know if Blender is too much of a threat, being free, but Silo is such a lovely and unique option in a barren sea of expensive 3D applications.


#4

Maybe we could include feature requests?

  1. Soften / Harden Edge to for controlling the appearance of edges in game assets.

#5

I have not seen this particular bug. Mostly all is the crash from trying to undo commands or instability when poly’s get near one million.

As much as those of us who use Silo often would love updates it is all but absolutely certain that Silo is full abandonware. :frowning:


#6

I had this problem just after Nevercenter released 2.3.1. I’ve just downloaded a trial and still get this bug when I create a simple cube and slide one of the edges.

What a shame about Silo. In these days of apps, Nevercenter have such a good product and just don’t know what to do with it.


#7

Hiya!

I just tried that Slide bug. Yup. My display also gets corrupted…but not even close to what yours is. It’s fine and crisp when I first start Silo. I can add a cube, rotate around it, pan, zoom. No worries. But as soon as I try and Slide an edge I get a ‘pixolated’ readout and viewport name (“Perspective”, “Top”, etc).

Odd. I never noticed it before. Guess I don’t use the numbers for determining where I want something.

Definitely annoying though…and now it’s going to bug the shite out of me from now on. Thanks alot! :wink:

:slight_smile:

Paul L. Ming


#8

Ha! Sorry Paul. Really.

Yes, it’s the same for me - the interface is fine and crisp when I open Silo but the names and read-outs corrupt as soon as I fire the Slide edge tool.


#9

Hiya!

It does on Bevel, Inset, Extrude, and a couple others. Oddly enough it doesn’t do it if you just move around faces, points, etc. (including just adding edges via the Cut tool).

Anyway, I still love Silo. But have been trying to force myself to learn MODO over Lightwave (I have an Indie license for MODO, but a full one for Lightwave 11.6.3…started with LW 8/9). Lightwave is…powerful, but freaking ANCIENT in terms of workflow. If anyone ever says “Working in LW is fast and easy once you get used to it”, ask them when they started using LW. Chances are it was sometime back in the dark ages (re: 1990’s), or at least 8 to 10 years. Almost no one who started learning LW within the last year or two says that. I find it’s lack of consistency most annoying. Some tasks you end with hitting the Space bar, some you have to hit Enter, some you have to Right Click. If you don’t memorize which is which, you can do a lot of “Multishifting” (combines Extrude, Move, Scale, Inset Scale and adds other cool stuff), and then hit the wrong “ending” button and BLAM! It’s all gone).

Anyway, Silo is SUPER fast to get a LOT of work done on a model. I find it faster than even Modo…and I thought that was fast! The only other modeler I found to be equal to Silo in terms of “quick modeling” was Mirai. I still have my copy…but it won’t install on Win7 x64 and I haven’t figured out how to do it yet. That said, I’m going to be reformatting my HD, moving stuff onto a removable drive that I don’t use anymore, and then I’m going to install a “multi-boot” program so I can install Win7 x64, Linux Mint (64), and probably Windows 2k (32). That way I can install any old programs I need/want on my Win2k side, and Linux is there just as a breath of fresh air from the Windows side of the pond (and to keep on testing until I find I can work in it exclusively…which, with some of my hardware and software, I can’t).

Wow…did that meander all over the place! Sorry!


#10

I started with Lightwave, version 7 or 8 I think, with a free upgrade to 9?

It was a STEEP learning curve, especially on a Mac. I soon realised that it had fallen behind the other main applications. I eventually jumped to an early version of Modo, 302, and had a really great time until newer versions were not compatible with my system spec.

I bought an upgrade to Modo last year. Didn’t get to use it much before version 10 was released. I’m quite disappointed as there are problems with 902 that will never get fixed. So I’m always hoping Silo will come back to life, or I will start learning Blender.


#11

Try Cheetah3D you will love it.
BTW Silo is on sales on the Mac App Store, in case anyone need it


#12

You weren’t kidding were are you. I’ve just read a few posts from people using Cheater 3D with Unity.


#13

I discovered this when I started having more than one object in a scene. Whenever I play with the features in the Scene Editor it affects the other object instead of the one I’m working on. For example if I wish to lock one object it locks the other one instead of all of the objects in the scene. When I try to make something invisible it hides the wrong object. So I end up saving the file then reopening to see the proper changes made afterwards.


#14

The Surface Tool crashes the program. I’ve found a similar complaint in another board but nothing has been done to fix it. I’m been resigned to point-by-point modelling for now but is there another way around this? I still haven’t tried the Topology Tool.


#15

Hiya!

Surface Tool works fine for me…tried it with faces, edges and vertices multiple times and all that (about 2 minutes of pushing/pulling stuff with the Surface Tool).

Maybe it’s a computer spec thing?

(Intel here; Win7 x64)


#16

I’m using Win10 x64. If there is a spec problem I wish somebody would tell me. So far the topology tool is working fine, which helps in my current project. Sometimes, if I stop and save after each polygon the program doesn’t crash from the Surface tool. I might also be using it wrong…I can’t find a decent online video to explain its use step-by-step.

Update: So far I can only go three polygons straight with the Surface Tool before it crashes. I’ve tried re-installing the program but it repeats the same error.


#17

It may very well be an OS problem. The last update was quite some time before win10 was released. The last full update was when Win7 was the most used software and Vista was being replaced by Win8. I could have the time-lines wrong but it’s accurate to state that Win10 is not an OS that Silo was designed for. I am using Win7 pro x64 without too many problems aside from a nagging crashing that occurs anytime I get close to the 600k + polygon mark. Maybe Win10 has a compatibility option similar to Win7?