Shift+Option/Alt with Mouse Click Does Not Deselect Individual Selected Faces


I have found a pretty blatant bug in Silo all 2.5.x Mac installs.Shift+Option/Alt with a mouse click does not deselect faces once selected.
It does seem to work with a selection drag out - but this is not my normal work flow and very hard to do in some instances.I’ve reproduced this on my April 2017 MBP 15" Running High Sierra (up to date)with the integrated intel GPU andwith the Radeon Pro 650with Anti-aliasing turned on & offI’ve also reproduced this on my early 2013 MBPRunning El Capitan

I need a solution - I’m using a 2.3 install because I over wrote my last good version of Silo that worked and 2.3 is the latest installer I could find on my machines.Thank you!


I would first check mouse settings have that combination set to ‘Select Visible Subtract’? You might have managed to change it somehow.
You can download all versions of Silo from 2.3.1 and newer here (at the bottom of the page)


Odd this happened on both machines. It might be a shared settings updated with new installs.
I never recall SHIFT+OPTION(ALT) and LMB == PAN VIEW before; I set it to ‘Select Visible Subtract’ like you stated and its working fine.
But now my SILO 2.3x doesn’t work much at all – the HD monitor causes the mouse pointer not to select what it’s over.

Groovy 2.5x works now thanks!


Interestingly this happened again to my install of SILO.
I set again to use the “Select Visible Subtract” with Ctrl+Shifty LMB and it wouldn’t work - it would unselect EVERYTHING - so I tried with Alt+Shift LMB and it wouldn’t work - it would also unselect EVERYTHING

So I set both the Ctrl and the Alt at the same time (see image) and NOW the Alt Works but the Control doesn’t - BUT guess what DOES WORK … COMMAND — seems Control/Command mappings in PC/Mac versions have their wires crossed