Shadow Pass Problem


#1

I’ve tracked some footage in Live and animated a character in the scene.

I’m trying to render the shadows cast by the character on a surface but not the surface itself.

I’ve tried creating a render layer, then selecting shadow pass in the attribrute layer. Also enable render passes is on in the globals.

When I render it just renders everything as normal.

Any ideas why?

Do you have to render multipass differently or something?


#2

Do not create render layer…in render globals check only “render passes”…set “off” to every channel…leave only shadows channel…it should work…

Just make a light scene and test it …

GL…:slight_smile:


#3

ok…Just tried that. It still renders the objects (in this case a sphere and a plane) lit by a spotlight with raytraced shadows.Any other ideas?


#4

When you render shadows separately they are rendered as alpha channels which you will use in your composer program. To make leha sokol’s instructions work, you should use the batch renderer. Just batch render one frame, open it with Fcheck and view the alpha channel.

Here’s another way in which you can render and view the shadows with the regular renderer.

Model a proxy of your background footage in a scene with your animated character. In the attribute editor uncheck casts shadows for all background objects and assign the ‘Use Background” material to them. Now render your scene and in the render view choose display> alpha channel.


#5

I know the useBackground technique but I’d rather have control over the shadows seperatly in After Effects.

I tried rendering with Batch render and it dosn’t seem to create the file - or its putting it in a strange directory. The render info at the bottom dosn’t give a file location :frowning:

heres my settings


#6

By the way…I render it without any Batch renderers…6.0…

First…set your extension to …tif format…and as i said…unchek Enable Render layers TAb…cause you checked both LAyers and Passes…in this case it doesnt have any sense…You can also check Output to subdirectiries…to make it esier to find and store your passes later…

At least in my case it works…

Try it on again…

GL:)


#7

ok I unchecked Enable Render layers and it still renders everything.

I am also using version 6. Is there any chance anyone could post a simple maya scene with a few primitives with the right render settings? I have no idea why it isn’t working for me

Cheers


#8

I’m using 6 too and just tried the regular renderer and nice surprise, yes it worked. So far I’ve been using passes only with the batch render since the regular one was always giving me warnings like: Rendering color pass only. Please use Batch Render to render all selected passes. In fact now I can render the shadows as expected regardless whether the Enable Renders Layers is checked or not. However after I’ve played with the options I notice some problems with the renderer being not able to update changes in the settings. For example after I unchecked all layer/pass controls it was still rendering the shadows only until I closed and opened the file.

I think the results from both methods on identical, you will end up with an alpha mask of the shadows.

the files are saved in the images folder of your current project. To check which is your current project go to file>project>edit current


#9

I thought rendering the shadow pass produced a RGB and an Alpha. What if you have coloured shadows? How does it handle them?


#10

Shadows only output does not produce RGB. The shadow color adds to the surface color of the object receiving the shadow. This should not be a big deal since in Photoshop or after effects you can fill in the Alpha mask with any color and transparency easily and also this will allow more control


#11

finally… I got it to work! You guy’s could have told me that Enable Global Passes needed to be enabled :)Thanks for the help though…you’re good people!


#12

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.