serious mental ray bug in maya 2011: ao+colorbleed stop FG bounces


#1

marla (alessandro prodan) found a seriuos bug in the mia_material_x bundled with maya 2011

the Ambient Occlusion with color bleed stop the Final Gather bounces, no matter what settings you use
this is a maya specific issue inside architectural.dll, i’ve the 3.8 standalone and the mia_material_x is working fine

FG 2 bounces, no AO

FG 2 bounces, AO with color bleed

this is how it should be (FG calculated without AO, freezed and with AO)

the problem is perfectly reproducible in any simple/complex scene
i don’t want to be rude here, but, how is possible to not see something like this? no one in the beta testing got this problem? i’m shocked, really


#2

Yes incredible
As marlas says, the bug is also with GI+fg, you confirm?


#3

Autodesk should consider the opportunity of elevating an institute for maya visual engineers…
The mentally ill… :eek:


#4

good find!

I was about to start a commercial visualisation project in maya 2011. On the back of this news, I think i will stick to 2009. Although we do have one seat of 3.8 standalone so could render fine with that but do not think we will.

cgbeige will have a field day with this news lol


#5

just a tip, if you have the 3.8 standalone copy the architectural.dll from there and overwrite the maya one… problem solved


#6

good point!

cheers,

Rich


#7

This is unbelievable!!! How many more bugs could one possibly introduce in a major release? Did they even beta test?

I am so glad that i have completely switched to Vray4Maya!

good luck guys!
Oli


#8

@dagon One question for you, why don’t you beta test maya, it would be probably great step for many of us that depends on mental ray in Maya? Any specific reason?


#9

ya, I was thinking the same thing. Dagon - get on the beta testers and maybe they’ll be able to catch these early enough to fix them.


#10

That’s sad…
Then should I ask someone who owns MR 3.8 standalone for the .dll file or waite months for ADSK to solve the problem, or should I ditch MR4Maya to get an easier life?


#11

Does the same bug persist with mia_material, or with mia_material_x_passes, or is it only mia_material_x?

Shane


#12

we don’t try with mia_material. Because in any render mia_material_X have the function we want. If the problem not appear with mia_material or with ao classic, not is important for me, i’m use ever AO+Colorbleeding, without it, i’m not productive.


#13

I know it’s off topic 'cause it’s a maya thread but it’s the same problem that was present in Softimage 2010 (solved in 2011 but not with the 2010 SP1…).


#14

just to be clear the bug was found by alessandro prodan (aka marla) i just reproduced it and reported here
btw i have a job, i like to do testing, but i can’t do it full time :wink:

the bug persist with mia_material_x and mia_material_x_passes enabling ao with color bleed
it’s related to the Final Gather, all the methods that involve FG are affected (FG multibounces, GI+FG, IP+FG)
the mia_material haven’t the “color bleed” option, so is not affected
the regular ao is not affected too

i have yet to investigate 3ds max 2011, if is not affected you can take the dll from there


#15

Gosh…ADSK should make the accurate architectural.dll (be it from the standalone or 3DS Max) free downloadable for Maya users…can’t believe this is happening…


#16

Did anyone check this with 3dsMax 2011 or XSI 2011, can we use that .dll instead?


#17

it seems that the dll in max 2011 is up to date and works well


#18

Have you tried copy/pate that .dll to Maya 2011 and see if it fixes the problem?


#19

not yet, but i’m going to do it in the next few days :wink:


#20

Looking forward to hearing how it turns out! Thanks. :slight_smile: