Segment Particle/Camera trouble


Hello Guys,
I started a simple grass system using strands and segments as a particle type.
Everything runs fine in “User Viewport”, but when I change the view to any camera pass a get this weird look on grass.

If I get box or cilinder in particle type in “Emit from Geometry” node everything goes fine again.
But I’d like to use “Segment” because I’ll need a lot of grass and a smarter render.

Does anybody know what is it and what I could do to fix it?



when I do grass in XSI I usually instance it using the hair generator. just model a couple strands of grass point them in a few different directions, group them (Ctrl + G), and then in the instancing tab under the hair options you can make more or less grass and can even add dynamics in it to make them blow in the wind and things like that.


Hey Brendan,
Thank you a lot for your tip.
I’ll use your suggestion.
I think the render in ICE would be faster,
but I really can’t deal with this mysterious camera issue anymore.

Thanks! :thumbsup:


Hi Brendan!

I tried the render with instances and normal hair. But even with some weight maps controls it got too slow.
Then I took another look in the guide an I got the point.
So… if anyone has experienced the same problem, here’s the solution:

In the topic: “Rendering the Absolute Size for the Segment and Point Shapes”

For some reason, Softimage doesn’t consider the absolute particle size in some camera angles.
Then, the node “Set Segment Size Mode” becomes very useful.




This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.