Saving Maya 6.0 models back into version 5.01


#1

Hello Fellow Forum Members,

I’m nearing the completion of my final year project ( virtual showroom) & beginning to render all my work. Lately, I encountered a serious problem with rendering & version compatibility.

I intend to use www.renderplanet.com as my online render farm service of choice because it’s totally free & I’m provided with about 64 AMD Athlon processors to render my Maya scenes. It’s the only way to get my renders done fast.

However, I’m hit with quite an impossible problem. Originally I started modeling my showroom using Maya 5.01 (in the beginning). Then Maya 6.0 came out & I upgraded to it. Now all my 3D models are saved under the version 6.0 format, which is unreadable if I were to open the same models using version 5.01.

Here lies the problem : I can’t revert back to version 5.01 b.c. I encountered an error message sayng that Maya version 5.01 can’t read my scene files because it does not recognise the file newer format. However, when I reinstalled version 6.0, I could open the scene. Moreover, renderplanet still supports only version 5.01 & not version 6.0. That was why I was unable to upload my scene files to renderplanet.

Do you know if there’re any special conversion s/w out there that can reconvert my version 6.0 models back into the format that version 5.01 can read? Or else I can’t use renderplanet for my rendering. I’ve also researched on other online renderfarms (www.hires.com). They also still support version 5.01, & they charge a fee for rendering. Renderplanet is free.

I hope this problem can be undone & solved. Thanks in advance for your help :slight_smile:

Warmest Regards,

Andrew


#2

You can use this tool:
http://www.highend3d.com/maya /plugins/?section=utilities#2936
It can convert to all versions. For me it worked, as I had a problem with opening scenesfiles in Maya 6 after reinstalling it.


#3

I needed this very badly as well!

thx!
o


#4

Hello TB2,

Wow! U really are a saviour!!! :slight_smile: I am really in a fix with the maya versions, but I’ll try out your suggestion & see if it gives the desired results. Thanks so very much. You really helped me out. :thumbsup: :slight_smile: :applause:

REgards,

Andrew


#5

Hello again TB2,

I visited the url you gave me. But I don’t know which link to click on to dowload this utility. Please let me know what’s the link called on this url kay? Thanks a ton !

Andrew


#6

just save as a .ma and edit the file header to say version 5 instead if 6.

BTW u can actually dothis 2 a .mb file as well if u have a decent text editor (textpad works). i’ve done it both ways in the past.


#7

andy, after going to the link provided, go to the second page and you’ll see fileConverter near the top.

now if anyone can tell me how you use it, that would be awesome!


#8

Hi TB2,

Dont worry, I’ve found the plug-in & downloaded it already… Now I just have2 follow the readme file to get things working. So appreciative of your help :slight_smile:

Bye,

Andrew


#9

Hi MacaroniKazoo,

Well, I don’t really understand how to edit the file header to version 5. I opened my scene in Maya, then went to the “Save Scene As” Option box. I chose my file type to be “Maya Binary”, but I don’t know what you mean when editing the file header to version 5.

Does Maya have to be open when I do this, or do I edit the filename in Windows Explorer? Please clarify for me yeah? Thanks.

Moreover, when I downloaded & unzipped the Maya version converter, I wasn’t able to execute it. Somehow my OS (Win XP) wasn’t able to recongise what kind of executable file it is.

MacaroniKazoo replied :

just save as a .ma and edit the file header to say version 5 instead if 6.

BTW u can actually dothis 2 a .mb file as well if u have a decent text editor (textpad works). i’ve done it both ways in the past.


-:macaroniKazoo:-


#10

Hi andy, save you stuff as .ma. Open you .ma file using notepad. You’ll see a couple of those ‘maya 6.0’ stuffs… and all you do is just change/alter them to ‘maya 5.0’. I’ve tried it before on my stuffs before and it worked. Well do keep a backup first… then you do that. It should work.

The advantage of .ma type files is you can do little naughty things to the ‘code’ written inside like in this case. :slight_smile:

As for .mb. I’ll need to try that out…


#11

I dont fully understand:

Andybiz, can’t you handle using the little converter of highend3D? That with the header is a very easy way to change the version, too. But I think the converter works pretty nice as well.
If you have problems converting your files with the converter ask me, i’ll try to explain the readme a bit better :slight_smile:

TB2


#12

Hello Every1,

1st & 4most, I want to extend many thanks to all of you who have contributed your time & suggestions in helping me out. Un4tunately, after trying for the whole night the suggestions that were reconmended, I still wasn’t able to open my scene file in version 5.01.

To shed some light on what I actually did, I’ve posted screenshots of the steps I’ve taken to rectify this problem. The link is @ http://www.photoaccess.com/share/guest.jsp?ID=AE2E723B1A3&cb=PA

Maybe I’ve done it wrongly as TB2, u mentioned that it was no problem for you. I’m really down to my last straw as it’s unlikely that www.renderplanet.com will consider upgrading to support version 6.0 based on my request & rendering all my work on just my notebook alone will take too long…may overshoot my project deadline. Now I’m relying on all your expertise to help me solve this problem. Thank you all once again for your help :slight_smile: :slight_smile:


#13

Well ok andibiz, I recommend you to use

C:\Maya

as the Folder where you put in the scenefile you want to convert and also the converter, so it is easier to locate the files.

For me it works like this, I copied the text out of CMD:


Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Dokumente und Einstellungen\Tomas Berger>cd…

C:\Dokumente und Einstellungen>cd…

C:>cd Maya

C:\Maya>mayaFileConverter.exe -v 4.5 “C:\Maya\Test MA.ma”

--------- mayaFileConverter 1.0 ---------
Developed by PROVIDE3D (www.provide3d.com)

Converting Maya ASCII file…
Creating file: C:\Maya\Test MA_4.5.ma
Done.

C:\Maya>mayaFileConverter.exe -v 4.0 “C:\Maya\Test MA.ma”

--------- mayaFileConverter 1.0 ---------
Developed by PROVIDE3D (www.provide3d.com)

Converting Maya ASCII file…
Creating file: C:\Maya\Test MA_4.0.ma
Done.

C:\Maya>mayaFileConverter.exe -v 5.0 “C:\Maya\Test MA.ma”

--------- mayaFileConverter 1.0 ---------
Developed by PROVIDE3D (www.provide3d.com)

Converting Maya ASCII file…
Creating file: C:\Maya\Test MA_5.0.ma
Done.

C:\Maya>mayaFileConverter.exe -v 7 “C:\Maya\Test MA.ma”
Wrong target version provided.

C:\Maya>mayaFileConverter.exe -v 5.01 “C:\Maya\Test MA.ma”
Wrong target version provided.

C:\Maya>mayaFileConverter.exe -v 6.0 “C:\Maya\Test MA.ma”

--------- mayaFileConverter 1.0 ---------
Developed by PROVIDE3D (www.provide3d.com)

Converting Maya ASCII file…
Creating file: C:\Maya\Test MA_6.0.ma
Done.

C:\Maya>


You see I can convert to all version, but not to 7 (oh wonder) or 5.01, so if you use the exact tag, and convert to 5.0 it should work. Although I see, that theoretically it should work the way you did it. Did you close your Test MA.ma before converting it?

You could also try to insert my, or a modified version of my Begin of the .ma-file. Mine looks like this:


//Maya ASCII 5.0 scene
//Name: Test MA.ma
//Last modified: Wed, Aug 04, 2004 03:18:47 PM
requires maya “5.0”;
currentUnit -l centimeter -a degree -t ntsc;
fileInfo “application” “maya”;
fileInfo “product” “Maya Unlimited 5.0”;
fileInfo “version” “5.0”;
fileInfo “cutIdentifier” “200304040010”;
fileInfo “osv” "Microsoft Windows XP Service Pack 1 (Build 2600)
"


Else I’m very sorry, that this doesn’t work. Don’t know something else. :sad:


#14

Hello TB2,

Wow! U’r really a helpful guy man :slight_smile: . Yeap, I did close Test MA.ma before I converted the file. OK, give me some time to work on your method & I’ll keep my fingers crossed that it works like a charm…hehehe :slight_smile: However, I still had Maya 6.0 installed when I ran the mayaFileConverter plug-in (& typed in the text). After that, I installed version 5.01. So actualy, I had 2 versions on my PC. 1st the already existing version 6.0, then the installed version 5.01.

I’ll keep working on a solution. I really appreciate your assitance.

Regards,

Andrew


#15

Hello everybody, esp to TB2,

Well, I’m so glad & relieve to in4m u all that I managed to successfully convert my Maya version 6.0 models back to version 5.01. TB2, u really are a good samaritan. Without your suggestions, I’ll still be cracking my head how to solve this problem. OK, postmortem time :

What went wrong?

Well, it’s strange, but true, a few characters can either make or break the deal.

Here’s the original readme text file that I downloaded from www.highend3d.com :

mayaFileConverter -v 4.5 C:/myFile.mb

And below is the sample that TB2 provided for me :

mayaFileConverter.exe -v 4.5 “C:/myFile.mb”

The only difference as u can see is the .exe & the 2 quotation marks (") enclosing the filename.

After following TB2’s sample, everything worked like a charm :slight_smile: :wise: So, I realise now what was the problem. Anyway, I’m so relieved that the problem’s now solved & I can use renderplanet to render my work finally.

Anyway, if u all are curious as to what I’m rendering, well…I’m working on a 3D virtual showroom for a condo in Malaysia. It’s a final year college project. Some of the screenshots can be viewed below:

http://www.photoaccess.com/share/guest.jsp?ID=A2AE5A39F57&cb=PA

[color=white]Now I’ve to go through the painstaking process of converting all my other scene files to version 5.01. [/color]

Btw, TB2, are you also a student like me, or are you a CG professional? Where do you reside? Thanks again alleviating my problem.


#16

Well I’m just a student at a highschool in Switzerland, and the CG-Thing is only my hobby. Unfortunately I’m far away of being a CG-pro… At modeling I’m doing pretty well, but all the rest… The best dynamic effekt I made was a little bit of water coming out of a tube, and then Maya crashed, cos the Graphiccard was too slow, cos I don’t have a workstation :wink:

Wellwell I’m glad that I at least knew that converter and that I could help you. :slight_smile:


#17

A student like me? Well, u seem to quite knowledable about CG stuff. For me, 6 months ago, I had no knowledge of 3D modeling, much less Maya, but I slowly picked it up within 3-5 months. Modeling’s OK, but I’m not very skilled @ rendering concepts like Final Gather, HRDI, GI, Caustics, etc. This area’s still totally new for me. Hopefully when I have more time to spare, I’ll explore this avenue…haha :slight_smile: Alright, enjoy the rest of the day, while I suffer in silence…hehe…converting all my scenes back into version 5. Take care yo!!! :thumbsup:


#18

Hey TB2,

In the meantime, u’d be interested to check out this world-class company that resides in Malaysia :

http://www.optidigit.com

Steven Stalhberg’s the founder of this company & they specialise in creating realistic virtual humans. He can be seen in & around cgtalk.com I’m sure u’ve come across his name on this forum somewhere. Impressive project he’s worked on, esp virtual women.

Optidigit also just finnished work on the latest EA game NFS Underground where they were responsible for create those virtual women in the game.


#19

Hm, looks very impressive the work on optidigit.com!
One day we’ll do as nice things as they do dreaminaround :rolleyes:

Well, have fun!

edit: Hey Andy do you have a homepage?


#20

@ andybiz_2004

What´s Your experience rendering with renderplanet ?
Really free ? :love:
What kind of software did You have to install ? Maybe a dialer :deal:

@tb2

Grüetzi Wohl,
Where do You come frome in Switzerland ? Maybe Basel ?