Running Maya on Ubuntu - Unable to find PySide or PyQt4


#1

Hello, so as the title suggests, I am running Maya on a Kubuntu (KDE Ubuntu) environment, so far I’ve gotten most things operational, such as the Viewport 2.0, Arnold, etc… the issue I am experiencing are Python related.

"No module named PyQt4.QtCore ", and importing PySide is giving me: “libpyside2.so.2.0: cannot open shared object file: No such file or directory”. I thought Maya came shipped with PySide and PyQt4?


#2

I finally fixed it! After much trial and error, I solved the riddle :smiley:

I am launching Maya from a custom shellscript with this code:

#!/bin/sh

export LD_LIBRARY_PATH=/usr/autodesk/maya2019/lib/

/usr/autodesk/maya2019/bin/maya.bin

And making sure the lib path is specified so it can load the correct libraries. Secondly, I pointed the _haslib.so file to the one in the linux install using these commands:

sudo mv /usr/autodesk/maya2019/lib/python2.7/lib-dynload/_hashlib.so /usr/autodesk/maya2019/lib/python2.7/lib-dynload/rhel_hashlib.so

sudo ln -s /usr/lib/python2.7/lib-dynload/_hashlib.x86_64-linux-gnu.so /usr/autodesk/maya2019/lib/python2.7/lib-dynload/_hashlib.so

And now the errors are gone and RenderMan loads!