Rigging: delete history unbinds skin


#1

I have a pen I have rigged, and almost everything works great. The problem is the eyebrows, both of which have three joints. The eyebrows and joints are part of a group that is parented to the main body. Now, without the rigging, the eyebrows move as the rest of the pen moves. However, when I bind skin, and then move the pen body, the eyebrows veer way out in space, not remaining attached to the body (the joints stay with the body, correctly). When I delete history, it solves the movement problem, but the joints are no longer connected to the eyebrows.

I would appreciate it if somebody could take a look; the file is attached.

Thank you.


#2

Sounds like the eyebrows are getting double transformations. The reason being that both the joints that now control the eyebrows and the eyebrow geometry are parented underneath the body and so when you move the body they are essentially moving twice. Try unparenting the eyebrow geometry from the body.

Also in future you can delete history without destroying skincluster information by using ‘Delete Non-Deformer History’.

Cheers Jake.


#3

Looks like you have skinned geo and the joints that they are skinned to under a transform. This is causing the double transformations. You can either turn off inherit transformations on the geo or don’t include them in the same group as the joints.


#4

Thank you, this did the trick. One more question, please. When I originally made this model, it worked in such a way that when rotated, the pen’s clicker at the bottom, when you tried to move it, had the move gizmo oriented with the rotation of the parent object. Now, though, the rotation of the gizmo no longer matches the parent object. I tried changing the tool settings to object mode but it doesn’t work.

Thanks again!


#5

I really appreciate the fast and accurate help. One more question, please. When I originally made this model, it worked in such a way that when rotated, the pen’s clicker at the bottom, when you tried to move it, had the move gizmo oriented with the rotation of the parent object. Now, though, the rotation of the gizmo no longer matches the parent object. I tried changing the tool settings to object mode but it doesn’t work. What I want is to move the clicker up and down in line with the body of the pen, as it bounces up and down.

Thank you again, I really appreciate it.


#6

Is the clicker object skinned? It’s usually not useful to try to move the transform of a skinned object. If the shape is not being deformed then it’d make more sense to just parent it or constrain it to a joint or whatever. If it needs to be skinned but also give the illusion of translating if it’s local space there are various ways to do it. Probably the easiest to explain is to take a copy of the object and make it a blendshape (put the blendshape at the front of the deformation chain) and then if you put a cluster ont he copy and translate it those translation will appear on the skinned object as if it was happening in it’s object space.


#7

The clicker is not skinned. It is just a simple cylinder that I would like to match the orientation of the pen body. It will move up down a small bit as the pen bounces. I have attached a screen capture showing what I mean. In the foreground is an example of what I want. The cylinder and the move tool follow the orientation of the rectangle, but, as you can see in the background, the tool does not. For the foreground I switched the tool to object mode, creating the desired outcome, but it doesn’t work with the pen.

Thanks again.


#8

I downloaded your file and it is skinned.

And actually because of the way the pen is deforming you’d want it to be skinned. But you won’t beable to animate it’s transform to do what you want. It’ll have to be another type of deformer placed before the skinCluster.


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.