Rigging a Cougar, problem with Jaw


#1

I am rigging a cougar model using MAX9. I have linked the lower jaw and teeth to a dummy and wired its rotation to the morph target controling the face. This is working, however I am unable to key the morph target slider for animation now. It seems you are unable to animate the morph target because of its wired state. All other non wired targets are keyable.
Images Attached.

Any suggestions?

-Matt


#2

Hi there. Don’t know if you have one way or two way wire going. But anyway, i’ve tried to avoid parameter wires for certain reasons. You can drive your object by changing morph target value with script controllers too.
This is of course assuming you don’t want to stick with parameter wires. I had some problems with wires when removing them and scripting connections so i changed to script controllers which seem to be more reliable - at least for my purposes.

It's relatively easy to replace that kind of wire with simple float script in rotation channel of jaw or teeth (or more likely, jaw parent point).

 Just add a float script controller into x rotation channel of jaw control point then edit  the script. Create a variable "jaw_morph" , and browse morph channel with "Assign Track". Then write a script "jaw_morph * 0.01" or something similar into expression field and evaluate. Channel might be different - depending on orientation of your nodes, and you have to adjust the value, which is just number to match rotation to morph amount.



Hope this helps!

#3

I am trying to go another route with the jaw. I added three bones and a skin modifer. I have the jaw working pretty close to what I want. Now if I want to animate other facial features with morph targets I am running into trouble. I am taking the intial pose with the jaw open, and making my adjustments, eye lids blinking for instance. The problem is the morph target is opening the jaw and canceling out my bone setup. Can I isolate what is effected by my morphing? Or is there a better path for this?


#4

I just needed to change the order of my stack. Problem solved. :slight_smile:


#5

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.