Rendering SU in Maya help


I am trying to render a floorplan in maya that was done in sketchup but the objects dont seem to b casting shadows like those in the image im trying to recreate. Please help


are your lights set to cast shadows? If so what type of shadows, depth mapped or raytraced?


Sorry kinda new to maya :banghead: I see thats what i didnt do, but which would be better to achieve that look?


They each have their advantages and disadvantages. Raytracing usually takes longer to render but is more accurate. On the other hand depth mapped shadows are not quite as physically correct but usually render faster. In this case I’d recommend using depth mapped shadows. But you may want to experiment with both to see which looks better and has a more appropriate render time.


ok thans any other ideas to try and get even closer to the model? or do you thin that the rest is the textures?


Try to turn on shadow casting in attribute editor. For more realistic lightning, perhaps will be usefull mentalray’s final gather.


Is the quality achievable with just lighting alone?


Well, One thing you should keep in mind that whenever u r using raytrace shadows with software renderer then not forget to switch on the the raytracing from the render globals attribute…otherwise objects will not cast their shadows…& not forget to use of ambient occlusion as it gives u realistic contact shadows & will give some weight to ur scene…


There are a couple of things to note between your render and the one you are looking at for inspiration - the lighting is using accurate decay rates e.g. quadratic decay and then using an indirect lighting solution to fill out the lighting in the scene - final gather as suggested would probably do. Currently your scene is being washed out by the amount of lighting in it which decay will control. I think you also have some problems with moire noise on one of your walls so you may look at increasing the sample rate of the renderer or looking at the filtering on your textures.

So you will probably have to investigate using mental ray over the standard maya software render, I can’t think of many good reasons to stick with maya software to be honest, I can’t think of any developments for it in recent maya releases.

I would say if you are rendering stills and time is not an issue, raytraced shadows give a great result, since you can specify the size of the light source affecting the resulting softness and falloff of the shadow


when i do raytrace and render the frame it comes out as a black screen…not sure what im doing wrong

 when i do raytrace and render the frame it comes out as a black screen....not sure what im doing wrong

Make sure your lights casting shadows aren’t inside of objects that are casting shadows. If that’s the case they won’t be visible. You shouldn’t need to enable raytracing in your render settings unless you’re using raytraced shadows, refractions or reflections.

To start with your scene I’d suggest hiding all but one light for the time being, until you get that light looking the way you want it too, then go onto the next light and hide all the others. Doing this makes it much easier to figure out which lights have issues and which look the exact way you would like them to.

For your main lights you’ll want to give either a custom decay rate or most likely a quadratic decay. This way the light falls off with distance. On top of that you’ll also want to give your lights intensities so your entire scene doesn’t get blown out and white.

You may want to think about moving over to the Mental Ray renderer for better results, but I don’t thinks it’s necessary for what you’re trying to achieve.


I suppose that picture black, becouse light sources in the lamps’ geometry on the bedside tables.


the actual light source that im using isnt in the lamp geometry that just for the effect. I have a 2 spot lights above one as the key light and the other as the fill


Can you put some point lights in the middle of a space with raytrace shadows and try that?


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.