rendering playback speed


hi everyone

I have a small problem here, I’ve tried searching for the answer here and so far no clue…

I have an animation

now, we know that every time a frame steps, the fluid emits, this 1+ second movie shows it… the object is moving across a VERY long distance in a short amount of time which is causing the fluid to do what you are seeing here…

now, when I go into my preferences, I set the playback speed to .1, the fluid will playback just fine… but if I go to render it it will still come out just like you see above… second thing I did was I adjusted the by frame in the render globals to .1… again, what you see above is what rendered but much slower…

so my question is, besides adjusting the animation to be longer (and the playback speed at 1) is there a way I can render those subframes like the playback speed is playing them so the fluids come out smooth? or am I just gonna have to extend that animation over 10x seconds and use compositing to speed it up?


Leave your playback settings at 1, but instead in Fluids menu, go to the Caching options,
and turn on Oversampling there ( to 5, 10, whatever ).
This way you’ll be able to render integer frames only instead of all the subframes once you simulate if with oversampling.


you the man…

that worked like a charm… honestly, it was right in front of my face, I knew the answer, and somehow I missed it… it took a second eye to knock me in the head LOL

now, is there a way I can do this without caching the fluids? >< this is probably another answer right in front of me too heh


Instead of emitting from a cube/sphere/point,
emit from a tube that is long enough that you don’t see the staggering :stuck_out_tongue:
If it looks awkward once it is far away, you can keyframe the emitter’s scale to touch up wherever needed.



This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.