Rendering particle instances crashes Maya 2014 on a Mac


#1

Hey guys,

I’m trying to use particle instances to instance a patch of grass over a garden lawn, but each time I try to render it in render view it crashes Maya. I’ve searched online, and haven’t been able to find a solution.

Does anybody else here have a similar problem? Is it a bug? And is there a possible solution or workaround?

I am using Maya 2014 on Mac OS 10.7.5

Thank you in advance,

Ian


#2

can you post a sample scene?


#3

Sure… So do you mean the .mb file?


#4

Was logged as a bug when 2014 shipped. ADSK support gave no indication on when it would be addressed.


#5

Thank you Kevin… So my only real option would be to bake/convert those instances into actual geometry? That would make my scene very heavy and really slow things down.

I’m assuming that you have discovered this problem during your own workflow too – what alternative options did you have available to you?


#6

I’m also having lots of instancing woes with 2014 so far, in Win7 here though. In fact, scenes with instancing no longer render in 2012 on this machine anymore, and I’m having other headaches. The same scenes render fine on my other machine, which doesn’t have 2014 installed yet… Hopefully they’ll get back to us on this issue, shortly!


#7

I agree…This is a real pain. It seems to work okay in Maya Software Renderer, and it only seems to crash with me in Mental Ray. I’ve tried rendering the same scene in Maya 2013 and so far it doesn’t seem to have any problems.

I’m wondering if anybody has tried this in Vray to see if the problem still occurs. I’ve never used Vray before so I’m curious about its performance.


#8

instances render fine in V-Ray under 2014. It’s a mental ray problem.™


#9

I’ve been in conversation with Autodesk about this because it breaks both MASH and SOuP.

I’m glad it’s not just me putting on the pressure though! Report it and hopefully it will get a higher priority for a fix.

We just render everything with Vray to get round the problem.
Ian


#10

I found the fix for now, folks. Just uninstall 2014 and walk away! Now my 2012 scenes render just fine. :slight_smile: Now to think of a way to tell the boss he just blew his load on garbage…


#11

Hey Sho Pi,

I’m glad that you have found a suitable workaround. I actually discovered the same workaround yesterday… :slight_smile: I gave up using Maya 2014 and went back to 2012. The only problem I had yesterday was that Maya doesn’t like to backtrack from 2013/2014 to previous versions as it adds some additional code which isn’t recognised by 2012 and earlier (mainly the -ch stuff). So I spent half of yesterday finally getting my scene to open in 2012 and it still needs quite a bit of reconnecting for me to get back to where I was, but I think I’ll stick with 2012 and wait to see if Autodesk can fix the bugs or even attempt to fix them. I’m also considering switching to Vray if this is going to be the future of Mental Ray.

I hope that your boss took the news well when he/she realised that his money had been wasted, and his employees time had been wasted too. People don’t get upset about stuff like that, do they? :slight_smile:

Ian


#12

Yeah, I am having a bit of trouble after all even having reverted to 2012. Not just with scenes that have instances, but even some really basic architectural projects are behaving funny. They’ll render fine from two or three angles, but then a certain angle just kills it. No idea.

But it’s definitely something left over from installing 2014, as my other workstation handle the same projects just fine, no crashes, even on the same problem angles. Annoying. Do I need to reinstall Windows outright and do this whole machine over, just to get 2012 to behave?

Nope, boss is not happy!


#13

Anybody found a solution yet for the problem? At first I didn’t have the problem but after upgrading to mountain lion I’ve into the same problem.


#14

It’s obviously not an OS problem. It’s an issue with mental ray. The only errors an OS update will introduce or fix are display glitches or networking things.


#15

Yeah I know it’s a Mental Ray problem but it’s weird the scene renders at my home computer just fine which has snow leopard installed. At work however it crashes. It’s both maya 2014, the only difference is at work we have mountain lion installed.

That aside. No fix yet right?


#16

So far, the fixes appear to be switch to Vray or rever to a prior version of MR. At this stage, I’m finally and honestly leaning towards the first fix. I have been humbled after all these years.

Hell, I’ll probably end up with a Mac this year too, the way things are going. Kill me.


#17

haha. anyway, you won’t regret the V-Ray decision. Support is fantastic and frequently my issues are fixed inside of a week or two and posted in the nightly builds.

I’ll be writing a full review of the next Mac Pro for Ars Technica if you’re serious about the Mac thing.


#18

Haha! Yes Sho Pi…Get saving up for that Mac! :slight_smile:


#19

WHAAAAAAAAT?!!??!

:slight_smile:

Sorry - I just had to get that out!


#20

was hard core MR PC once i got my mac pro back in 2008 never looked back an then switched to Vray again never looked back. would apple release this new pro already dam! been ichin for 24 cores for a while