Render Artifacts Problem


Hey guys,

I have been checking different forums on different sites but cant seem to find anything that explains the problems I have been getting with some scenes during the software render process. I have a 2 stills of the flickering I have been getting when I use raytracing for my final renders. The scene is textured using Maya shading networks and very basic lighting. I have the globals set to Contrast Sensitive Production with Multipixel set to gaussian and raytracing quality set to 10,10,10. As you will notice the black flickering artifacts in what appears to be the reflections. If I render with raytrace turned off I don’t get these back artifacts.

If anyone knows what could be causing this issue please let me know. I have been smashing my head trying to figure out this problem. It happens on several different scenes and I am beginning to wonder if something is wrong with raytracing for Maya 7. I have never seen anything like this before Maya 7. So if anyone has run into something similar and has an explanation of the problem and how to go about fixing it, that would be awesome. Thanks for any and all your help.



That’s kinda strange. Are you rendering with mental ray or Maya software renderer? For what it’s worth, I’ve not encountered any raytracing problems with Maya 7, but I only render using mental ray. You may want to experiment with different renderers to see if the problem is the renderer or corruption in your scene.


Only thing I can think to check for is to make sure normals are ok and if you’re using any special mental ray materials check to make sure you’re not using Dmap shadowing, that creates funny artificats, need to use raytracing shadows. If I can think of anything I’ll post. Also, I’d be more than happy to take a look at your scene to try to dig and find anything. Good luck!



Well, it sounds like he’s using Maya Software based on those settings, and while I have gotten somehting similar in the past, it was only with mental ray and custom shaders.


If it does happen with different scenes, maybe post an example scene file and see if it happens for others?


Thanks for the replies. I am not using MR just Software. I can turn off raytrace and it renders fine but I dont want that because most of my textures are a metal material and I would loss out on my reflections. I have a movie clip of the problem. Maybe this will shine more little on the problem I am having. I am going to try and render out render layers with the scene and see if that fixes anything. I do have a layered texture that I am using to give the dusty look of the machine. But…This same layered texture in other scenes renders fine. That is what I cant figure out I have 3 scenes that I am getting this render problem in and everything else renders fine. The only change in the scene from my other is the camera angle and camera animation. Take a look at the clip and let me know if anyone has a clue of the problem and a fix. Thanks for any help.



Ok if I render a single frame out in maya then it renders fine. It seems to be doing this artifact flicker when I batch render. Just thought I would toss this out there also…



I believe we have figured out the problem. I went back into the scene and deleted the 3d texture reference object I was using for the machine. And then created a new texture reference. The flickering is now gone…So far so good anyway. Now the problem is still unknown really. What caused the flickering and why??? Was it the 3d texture reference object node or what??? Please someone shine some light on this one. If in fact it was the 3d reference object why did it wig out on this scene and not the other scenes??? By importing the object into the scene did this screw up the 3d reference object…if so why did it work for one and not the other machine in the scene???

Thanks for any help.



Yeah - that flickering was intense, I have never seen anything that severe before. However if you fixed it, and it works fine now… I still have no idea what exactly caused the problem, nor why it was for this scene and not others. As long as it worked. Maybe just make a mental note to remember what caused these errors so in the future if this happens again you’ll have an idea where to start.

Either way - cool machine though!


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.