Relinking Maps/Maps not displaying when scene is loaded


Hi all,

I recently posted an issue with the Gigatexel Engine displaying low resolution textures. I have since stopped using Gigatexel in the scene I’m currently doing and everything has been fine since. However, since switching from Gigatexel: every time I re-open this scene parts of the mesh are blue where it can’t see my maps. Which means I have to import each map back into the scene every time I want to work on it - this can be a pain in this ass when you have a lot of maps.

My question is: Is there a quick way of relinking maps, like it 3DS Max? Or is there another way around making sure the file remembers which maps i’m using?

I notice the maps re-appear when I turn Gigatexel back on, so I know it can see them. I also tried recreating new materials for each object (with Gigatexel turned off still) and re-applied the maps and saved a new revision of the scene incase it was getting confused, but the same thing happens when I re-open. There also seems to be a lot of textures/materials in the folder for this file for some reason, most of them I can’t see what they are actually doing, plus some are duplicates of the same maps I’ve created with a slightly different name. Could Mudbox be getting confused somewhere?

Any help is appreciated. Cheers


all maps shoudl be loaded if you dont use the gigatexel engine…
is it possible you used the down arrow key to unload the maps…?
the up arrow key will load maps…

texture loading sould also work straight forward… just import the texture as layer…
if everything is named mudbx conform it should load all uv tilesm…

are you using uv tiles…?
multiple objects with the same shader…?


This happens every time I load the scene up, so don’t think it will be anything to do with the up/down key.I can import the channels back in, but I have quite a few layers going on for Diffuse/Spec/Norm etc so it can be a pain importing all the layers back in every time I open the file.
I unwrapped the UV’s in Max prior to texturing in Mudbox, so everything should fit within the UV tile boundary. If that’s what you mean by using UV tiles? I also created new materials all with the Mudbox shader for each part of the mesh prior to painting/re-importing the maps.

One thing i notice is: the only piece of the model in my scene which loads the textures in no problem as soon as I open the file, is the main body of the character. This was the only part of the model that was unwrapped in Mudbox automatically from the standard Mudbox body mesh, the rest of the model (the parts not loading textures from opening/showing as blue) were unwrapped in Max then imported into Mudbox, could it be something to do with that?


Another thing I noticed, is even when I’ve got my maps all loaded back into the scene: I try do a render of it but then the parts of the mesh turn blue in the viewport/render while it’s rendering.


may i see some screenshots…
and the uvs…


Yeah sure. I’ll post the screen shots/details in a few hours when i’m home with the file :slight_smile:


I’ve figured it out what it was: I thought i’d give it a try pressing the Up/down keys which you mentioned earlier, I pressed Up to turn on the display of the textures and it worked! Not sure why they don’t show when the file is loaded, but atleast I know I can just turn them on now. Thanks for your help man :thumbsup: