Release: wom_archlight 1.0 - physically accurate light shader


#21

I think that mechanism should work fine with my shader. As far as I know, the high/low samples is controlled by Maya/mental ray automatically. The setting then affects how many times the light shader gets called. My shader just casts one shadow ray each time it is called for direct light to check that the given point is not blocked by an occluding object. This is the same way that all the mental images shaders work as far as I know.

I do know that physical_light has a “threshold” parameter that does not bother to do the shadow ray check if the point is already very dark. It is possible that this could improve performance and may solve the problem.


#22

I suppose ‘threshold’ parameter will be very helpfull.


#23

Yes Matteo, i know that, but if is possible, why not? :slight_smile:
In this case, i’ve been many tests with wom_archlight and no more more more, shadow rays on FG computing, but only 1 more. :slight_smile: :scream:

Ciao


#24

Just from preliminary testing wom_archlight seems to work great. Thanks Wombat - looks very very useful.


#25

thank you wombat :buttrock:


#26

I’m not sure what you mean dagon.

Personally, I’ve noticed when using this shader with a few lights, my scene’s rendertime practically doubles per frame. This happens even when the lights are not in camera’s view and am rendering an entirely different part of the scene. however I hide the layer and rendertimes dramatically drop down again.

Is this what you mean by reducing the falloff in this situation?


#27

I spent some time last night optimizing, and I think I found what could be causing the behavior you describe. I will try to post a new version in the next day or so that hopefully should have much better performance with no quality loss.


#28

I heart your shader!


#29

Folks,

I have updated wom_archlight to version 1.1. I edited the link on the first post (I will always keep the first post current with the latest version).

The main focus of this version is performance improvements. You should see a substantial improvement in performance with no loss of image quality (e.g., they were pure code optimizations). I also have added several additional methods of tweaking performance including a Shadow Threshold setting and the ability to limit emission from light profiles using spotlight cones. There should also be a MUCH greater improvement now using the falloff settings.

As always, please let me know if you have any questions or comments. Thanks!


#30

Very nice thank you once again Wombat.

Have you looked at a site for hosting your shader? Highend3D.com might be useful:
http://www.highend3d.com/maya/downloads/
Links won’t expire like they do on Megaupload and there will be a wider audience because many Maya users visit there.

Cheers.


#31

Good idea…I just submitted it there. It is moderated, so it may take a while to show up. Thanks!


#32

No worries.

Just to let you know, this latest update has fixed the slow rendertimes I was seeing before.

Leaving the lights on or hiding them makes only a very slight difference to rendertime compared to before when it was almost doubling the rendertime. Thanks.


#33

Great wombat.

If you agree, i’m post a little test scene for test and after i’m set all light, i’m post the Bar scene for all users.

P.S. wombat, but you know that you are, for all we users, an angel benefactor? :buttrock:

Thank always


#34

Please do, I’m one of people that got lost and ashamed to say it here

Thanks for the shader btw.


#35

great improvements! :slight_smile:
now Autodesk need to take a look at your shader and GIVE US an integrated photometric system
maybe they can just buy it, isn’t what they do all the time?


#36

I’m not using any light profile and I’m having a few problems with area lights in Maya. If I use spotlight arealight with cone set to 180 degrees I get very different results (much brighter) than if I use standard arealight. All wom light shader settings are the same.
Should we be using standard Maya arealight and not ‘old school’ spot area lights?.

Also setting area light to visible, I get no visible area light or reflections of arealight on objects. Setting area light to not visible, I get visible area light in reflections but not still visible to camera.

Thanks.


#37

Hi Wizlon,

On the second part, you are certainly right. There is something messed up when using visible area lights and spotlights, and I will try to pin it down asap.

On the first part (intensity), what units of intensity are you using? If you are using either lumen or watts, bear in mind that those units define the total output of the light. If you use a 180 degree cone spotlight, the light is emitting in only one hemisphere whereas a non-spotlight will emit in a sphere. Thus, to get the same wattage/lumen, the intensity within the spotlight cone will much higher. Similarly, the smaller the cone angle, the brighter the light will become, given the same watts/lumen. If you are using any of the other units, however, the intensity should stay the same between spotlights and non-spotlights.

Also, I forgot to mention that this build takes into account the inner cone angle for purposes of calculating the lumen/watts. Basically, when the inner cone angle is set smaller than the outer cone angle, a certain amount of light energy is lost because of the dropoff towards the edges of the spotlight. Wom_archlight now calculates this dropoff and boosts the intensity of the light to compensate, so that the total watt/lumen output remains the same regardless of the inner cone angle setting. This means that a spotlight with an inner cone angle of 0 will be much brighter in the center of the beam than a spotlight with an inner cone angle that matches the outer cone angle. All of this ONLY applies, however, when using watts or lumens.


#38

Actually, after looking at it more closely, it seems that spotlights + visible area lights are working ok on my end. Is it possible that the visible intensity needs to be boosted to see it properly? If you are still having problems, any chance you could send me a scene to diagnose? Thanks!

EDIT: Ok, so I am probably coming across as flighty.:wip: I think I may have found a problem with visible area lights and reflections. Please let me know which version you use, and I will send you a test .dll that should solve the issue. Thanks, and my apologies.


#39

All this tests are on amd single dualcore

On the latest image, you notice the artifacts of fg, but seriously, i don’t wont optimize this for fg only, now i’m free…


#40

Thanks for the test ytsejam! Another one you might want to try. Try setting both the threshold and falloff to off. Then make all the ies lights into spotlights and turn on Use Cone Angles with Light Profiles. Looking at the lights, try setting both the inner and outer cone angles to 100. That would be a less “biased” approach, and might give you close to the same performance. Just an idea!