Reference file and Dynamics problems


Hi, i rigged a model that has multiple hair systems, lattices etc. Then i duplicated the original file several times, opened them individually and made some geometry/shader changes to break them up a bit, they still look the same, but some few subtle differences.

Now im on my main environment file, i started referencing the different files. The 1st one works fine, as soon as i reference the second “clone” the dynamics start behaving bad and the lattice deformes on translate.

As soon as i remove the 2nd reference, the 1st one behaves normally again.

Any ideas why this is happening?

I`m using maya2010.


Help i`m desperate! :< Trow anything, as ive tried everything i could think of…


I’m not sure what you have tried already , but I’d say it is clashing names.

Does every reference have a unique namespace? If you are not using namespaces , try them.

If unique namespace names doesn’t sort out your problem , go to each individual file and prefix the whole hierarchy with something , this will force every scene to have different names for all nodes in your rig.

I hope this helps.


Thanks for the idea Derik, yes im using name spaces, and was about to try your suggestion using comet rename tool. Wish me luck


No luck, renamed all nodes of a reference file, referenced the file >hair system down the hole.

Seriously, i heard bad things about maya reference system, 1st time i try to use it, and it turns me down, bah…

Turned all the reference options on and off, resaved my files to .ma, made my files even more clean, dunno really, i have to send the file to the render farm tomorrow and im stuck ;(


Importing won’t work instead of referencing?
I know it’s more tedious to update later (well, you can always create a script that every time the scene launches, it imports the same files, so it’s like a reference…but more expensive :P) but maybe it will solve your problems…if you have to send the work to the farm, i think that should be a good brute force approach to make things working.
Let me know


Nope, tried to import and the same thing happens, no reference, flower is up and steady with the hair options i defined, as soon there is “another” hair system loaded the dynamics are still there but its like the flower is dieing with leafs flickering and stuff like that. ;|


Nuts! Sorry man , no more ideas on this side, personally , I’ve never tried referencing dynamic scenes together. I would be very interested to see the solution.
Good luck! I hope someone has some more ideas on this issue!.

I like your B-Movie entry btw… :thumbsup:


Could you post a screenshot of your outliner with multiple references in it?


Thank you Derik!

Sure mate, here you go…

At the moment im trying to maybe disconnect all the nucleus from the dynamics and plug everything into one, dunno if im capable to do that, but as i said, i`m trying everything ;(


YAY, phew, this one almost got me, so close it was.

Ok the problem was the nucleus node, it was running at default substeps (4),fine for calculating 1 flower but not enough for 2,3,etc, SO, as i reference files with nucleus dependent nodes i need to rise the substeps to keep up with the calculations

Hope someone find this info usefull!

Thank you all, back to work now :slight_smile:


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.