Redshift sometimes just stops


Not sure if anyone else has seen this but I’ll be working away and the redshift renderview will just stop working. Cinema is still functional but I can’t get Redshift to do anything. Completely closing out Cinema and relaunching fixes it. It’s pretty random and has happened twice in the last few weeks? Windows system with plenty of RAM and RTX 2080ti cards.


It’s a long standing bug.

No point posting here about it though, you’re best to post your report in the C4D bugs section. They’ll ask you for your log files for the session it stopped working.

There are instructions on where to find the log file on the redshit forums.


Check your feedback display, in this case it should state that Redshift has crashed and Cinema should be restarted.
It’s an annoyance that the feedback display pops all the time to remind you that there’s some bad polygon somewhere but omits to inform you that Redshift is kaput.


Bad polygons shouldn’t cause Redshift to crash and just using C4D modifiers and subD can create ‘bad polygons’. There’s nothing bad about the polygons as far as I could determine and render fine in Redshift and other renderers.

The renderview stopping working bug came into Redshift around the time they tried to improve Material Ball preview updates. Redshift used to be really bad at updating the Material previews and we were often left with Black balls until they randomly triggered into life. Anyway, they improved these previews but ever since there are times that the renderview simply stops responding. Redshift hasn’t crashed because you can do a render to picture viewer and it’ll render fine.

I tried to find a sequence of operations that caused the RV to stop responding but gave up., from the user’s point of view it appears random.


That’s what I wanted to know. If it’s a longstanding bug, I’m sure it’s already been reported. Thanks!


I’ll do that next time. Very random when it happens.


I have to say in my experience the preview updating still works like this. Lots of black balls and all of a sudden it updates.


It used to be a lot worse!

It’s a huge frustration for the ArchViz contingent, they have more materials than most in the scene and it can cause a lot of performance issues.


Lol, wow! I can’t imagine it being a “lot worse” than it is. I’m glad it’s better, at least :).


There was another seemingly linked issue where the RV would spontaneously restart rendering just by looking at your monitor in the wrong way. Making this less sensitive caused issues with the Material Previews and vice versa and I think somewhere along the line a bug has crept in that freezes the RV and it’s to do with how Redshift talks back and forth to C4D.

Now that Redshift is Maxon owned all of the C4D IP should be available to the Redshift dev coding the plugin and you may get a fix that clears up all the issues with the RV and material previews in a job lot.


Octane: “Hold my beer”


Same here, happened when I opened Photoshop. Silly me.


Use BodyPaint