Recompile script to run in 2012 - idiot help - The Onion


#1

With reference to this post:

http://forums.cgsociety.org/showthread.php?f=6&t=980443

The Onion isn’t working in Max 2012 - it has script errors.

Paul Hormis (Hyperrent) has been looking after the Onion of late, but hasn’t updated it for 2012 and hasn’t replied to my pathetic whinging begging emails.

I’m wondering if it’s just a simple case of chnaging a couple of lines of code that isn’t supported by Max 2012 any more…

Is this something anyone who’s on the case can look into?

I will give birth to your children if you do it. And I’m a man.

edit:

Fixed by Paul Hormis who I believe is now the official custodian of The Onion.

http://www.hyperent.com/Hyp-Maxscripts.php


#2

I think this comes from the 2012 paramStr rolloutCreator bug.
Basically what you need to do is open \Scripts heOnion heOnion_resource\OnionStructure.ms
and add a space at the end of all paramStr’s.
examples:
replace
paramStr:“state” with paramStr:"state "
replace
paramStr:LayActString with paramStr:(LayActString+" ")

Haven’t tested it but could work…


#3

Thx lo,
that worked for me :wink:


#4

Didn’t work for me! Though I’m sure I’m doign soemthing wrong… many thanks for looking into it though!

I noticed there are other paramstr’s floating around:

paramStr:LayWireString

paramStr:“col” codestr:

etc.

Perhaps lo/z buffer could assist by posting his correctly edited code…?

much love!


#5

yes, you need to change ALL instances of paramStr, not just the two examples I showed.
I’d feel bad posting the code, as it’s not my tool.


#6

Go on - post the code! :bowdown:

I don’t think Paul Hormis has time to sort it out, and I’m not even sure if it’s his tool either - he just picked up the batton like a hero.

PM me if you feel squeamish about publicly posting?


#7

I’m still getting script errors!


#8

Hey guys, i was able to solve this

Just ditch all modifications in your TheOnion source files and fix “rolloutCreator.ms” itself.
You just have to add two lines after Line 163 and 192 in this script for it to work:

in \stdscripts\baselib\rolloutCreator.ms goto line 163
after line 163 , insert the following NEW line, which i colored orange here


Line 163:    append str paramStr
Line 164:    [B]append str space   -- missing space bugfix[/B]

to the same after line 193 ( previously was Line 192, but we just inserted a line , capiche ? :wink:
again, the new line is colored in orange here


Line 193:    append str (paramStr as string)
Line 194:    [B]append str space   -- missing space bugfix[/B]

Of course make a backup of “rolloutCreator.ms” in some other folder (or this script might be run twice)
I would also insert that “bugfix” comment too, this makes it easier later on to find it again…

I quickly tested TheOnion after that, and it seemed to be working :wink:

PS:
credits for this fix go to Duncan Howdin and James Haywood which reported the problem and initially posted the fix on some secret Max board :twisted:


#9

@mynewcat : does spacefrog’s fix work for you? If not I’ll find the file I edited and PM it to you


#10

Your fix did work, I restarted a second time after making the second load of changes - after giving up I accidentally hit my O (for Onion key) and it popped up working.

If I get time tomorow I will edit and save that file based on spacefrog’s edits and make it available for anyone who searches for the fix so they can patch their Max 2012.

Once again, many thanks for your help - for me, on certain projects using the onion is like having running shoes versus wading through mud in boots.


#11

thanks spacefrog, your post was really helpful.

our office love onion, and was shocked to find out it wasn’t working (we assumed it should work as its a script, not a plugin). but anyway, after quick search, ran across your method.

spacefrog’s method works.

thanks again!


#12

my pleasure …
your positive response gives this grey day ( november fog all week and the week before ) and after only 6 hours sleep some more positive vibe - thanks for that :slight_smile:


#13

Hey guys Paul Hormis has posted an edited version on his website.

http://www.hyperent.com/Hyp-Maxscripts.php


#14

So what needs to happen to make this work in Max 2013?

They’ve changed everything again! - so if I previously installed The Onion 1.99 to the root directory of Max, where would I install it to now - I’ve tried both the root and the en-us, with no joy.

Would really appreciate some help. Cheers!

edit:

I got it to work - copy the installed ui\macroscripts heonion.mcr

to the macroscripts directory in max 2013, which seems to be straight off the root at this point, and not under UI


#15

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.