RayFire Tool


have you tried to put the objects into the sleeping list and wake them by velocity? OR deactivate static objects and activate them by geometry. use a big sphere and push it inside of the tower where you ant it to fall. OR cache the tower with rayfire cache and only activate what you want to break by light or gizmo.


Rayfire 1.62 is out as free upgrade for customers!

2 new killer features:
First one is Voxels modifier which allows to voxelize geometry and provides wide variety of properties to control them and animate.
Check out following promotional video to see it in action.

Second one is Clusters modifier which allows quickly and easily combine group of simple fragments to more complex clustered fragments.
And here is Promo.



“–Unknow system excpetion”

I get this a lot in my scene. I’m working on max 2014 sp1 and Rayfire 1.62.

The idea is pretty simple:

Black wired parts are static(dont move) and red colliders are animated and they hit the “ground” fragmented before. Fragmented parts are in green and i keep them in asleep list. Fragments I made using the modifier to preserve materialsThis is pretty simple.

This is what aprear in MaxScript Listener:

PhysX Warning: fail to create Rigidbody from node ‘FRAG660’!
PhysX Warning: fail to create Rigidbody from node ‘FRAG448’!
– Error occurred in s loop; filename: C:\Program Files\Autodesk\3ds Max 2014\PlugIns\RayFireTool\RayFireTool.mse; position: 268830; line: 7220
– Defined in encrypted script
– called in Sim(); filename: C:\Program Files\Autodesk\3ds Max 2014\PlugIns\RayFireTool\RayFireTool.mse; position: 270118; line: 7264
– Defined in encrypted script
– called in timerRf.tick(); filename: C:\Program Files\Autodesk\3ds Max 2014\PlugIns\RayFireTool\RayFireTool.mse; position: 355833; line: 9015
– Defined in encrypted script
>> MAXScript Rollout Handler Exception:
– Unknown system exception <<

Any ideas? I’m stuck with this for a couple of days now…


Hi, is there a way to extract the “rayfire Fragmenter” modifier Point Cloud into pointhelpers or particles?

What would be also good is to be able to to modify each point in the point cloud manually, or even add custom points…


I managed to make it work just by mistake. I noticed that other sim crashed when changed to “Use Selection Center”, but when changed back to “Use Pivot Point Center” it was running smooth, thats confusing…

However that didnt work for all sims. Cleaned-up the scene, got rid of unused materials and assigned one, refragmented and voila… it simulates properly :slight_smile:


i’ve a rotating drill linked to the base which is moving…now when i add the drill and base to kinematic objects, the drill falls apart…
how do i get both the drill and base working in the sim.?
file is attached
Hope i made myself clear…


Hi didnt check the file, dont have max here. But you say you have the drill linked. So the best way is to have them both keyed (copy the keys), delete the parenting you use. RF will ignore relationship between anyway and just sim as if they both were seperate objects


Thanks Juzwa…got it working…:wink:



I’m doing simple text collapse with Rayfire and everything is going wrong. Well almost everything. Video should look like this: Text is hanging in the air, suddenly text crumbles and fall to the ground. Like a freefall.

  1. If the gravity is set to the 1,0, why the text almost explodes to the air? Why it doesn’t fall straight to down as the same way as you drop something? If I set gravity to 10, it’s a little bit better, but still there is this little exploding effect. Does it explode like that because the fragmented parts of the letters are too close together?

  2. After I simulate the animation, many of the parts are little bit wobbly when they hit the ground and each other. There’s a tiny extra movement in them. How do I make simulation more accurate? What about substeps, now it’s 3. If I increase the substeps to 5-10, does that help?

  3. I noticed that if I render animation with Vray and Irradiance map + Light cache, there’s a lot of light flickering in the fragmented parts, even if the settings are high. Only way to avoid flickering is to render animation with brute force and that’s very slowly method. Do you have any suggestions how the Rayfire -simulations are suppose to render with Vray? What kind of settings should I use?

I have only this poor quality video which little bit opens the problem, I try to do new better one soon.


Thank you for your answers and sorry my nasty english. =D

  1. Make sure to use as low collision tolerance, best keep at ZERO.
  2. Thats just phisics, u can to much about it. You can try to simulate it 100 times but still some will “jump”. But what if you really like your sim you can just delete the keys when the object hit the ground. Use 3ds max particle system for collisions like that, you will get better results and much more control over it. Or even TP.


Thanks for your answer!

I tried to set Collision tolerance to zero and gravity was set to 10, but there’s still explosion effect. How do I get those parts just fall to the ground?

Yes, I can always delete keyframes, but if I rise Substeps to higher, does it help? I’m having houndreds of parts in the scene, so it’s very annoying to start delete all of thos keyframes at the right point.

I rendered this new sample video with settings:

Collision tolerance 0
Substeps 8
Vray irradiance map - High - animation
Vray light cache - subdivs 2000.
Other Vray settings was high quality too.

Still there’s some light flickering, is the Vray brute force only way to render Rayfire -animations?

Here’s the new video:



physX doesn’t work to simulate Rayfire fracture in my max design 2010 . I use ASUS VH162 (1360x768@60Hz)
512MB NVIDIA GeForce 8400 GS,Intel Core 2 Duo E7400 @ 2.80GHz . When I opened Max, I got 2 message, “Could’t find/ load library PhysX_2.X\PHYSX4DCC_PhysXcore.dll and Error: failure initializing the PhysX SDK. Error Code:0,ok.” When I tried to use it for Rayfire simulation, it didn’t work. What the problem, and how di I fix it? Thx


Do you have PhysX installed? I know older versions you had to install the PhysX library and plugins separately as they did not come with max.


Yes, I installed PhysX pluginfor 3 dsMax2010 and PhysX Sistem Software 9.13.0604. Is It right? Where can I download compatible PhysX library and where should I place it? Thx for your quick reply…



very verrry cool plugin indeed :slight_smile:

but I have a problem ( I’ve seen the video tutorials from their owner website that has this too!!).

small pieces, or thin pieces pass through the ground and fall down for ever.
I increased the substeps, from 3 to something 6 or more to avoid this , but It couldn’t help it and pieces start to jump around!!

what typically should I do?

thank u in advance


Yeah, I was almost going crazy because of that at the beggingng when I stated to learn any destruction techniques. I am no pro but I leared few things. That there is a “proper” way to manage with that.

You need to divide your sim into pieces, from the largest to the tiniest. So first goes the big chops, than the debris, than the smoke, etc etc. The way you do it this way is because its easy to control.

I’ve even seen the tutorial couple of days ago on Mir yt channel about that:



Hey there,

I have a scene where I have collapsed walls of a building. I have reduced the frames so frame 0 is the frame with all the building collapsed and debris. Now I want to run a sim on the scene where the room falls in on the building, already simm’d.

I have attached all the rayfire selections from the first sim together, but I am not sure how to start fresh with Rayfire to start a new sim. I have cleared all the boxes and added my new elements, but when I go to manager and select the pieces I get all the original pieces, if I delete the fist sim is deleted also.

How do I keep the results of a sim in place but be able to use Rayfire again in the same scene?




ok just to answer my own thread, I found it.

In case anyone else was stuck with this, under Tools -> Clean up scene…


Have anyone used rayfire with “birth group” particles from pFlow, i thought it would be a nice way to get a fragmented geometry and trigger it with particles and send it to rayfire. But a soon as i try to simulate i get an error message saying:
“-- Unknown property: “getMaterial” in $Birth_Group”
Does this mean rayfire cant recieve objects from pFlow if they are used with that birth type or am i doing something wrong?
Using max 2014 x64 and rayfire 1.62.04


Is anyone else experiencing this problem since updating Max 2014 to SP4 and Rayfire to 1.63 : Now every time I try to load any scene created with an older version of Rayfire, Max crashes to CER. Mainly, the scenes had MassFX Rigid Body Modifiers created by RF, but perhaps there is another RF plugin node or custom attribute that crashes Max.

I updated from RF 1.62 and SP3 within the same couple of days, so I do not know if SP4 broke Rayfire or RF isn’t working right with SP4.

[EDIT] It could also be an updated NVidia video driver too. There is a thread on the Area as well.

[ANOTHER EDIT] I’m thinking it is RayFire Fragmenter Modifier at this point. That seems to be the common thread in the problem I’m noticing.

[UPDATE] After various experiments and some feedback from Mir, I now feel like this is more of a SP4 issue than RF.