RayFire Tool



I’m new to Rayfire and just getting to grips with it. I’m having a few problems with what are (I hope) fairly simple problems.

I want to collapse a building that is made from metal beams and concrete (the concrete will break but the metal wont). I can’t seem to apply 2 different materials to the Dynamic objects. Is there a way to do this?

  • Garry


so you want the metal to stay where it is and the concrete to crumble? Or do you want it to bend with it? in that case rayfire might not be the tool for the bending, use cloth or so.


Hi Vadim,

I’m totally new to Max (have been “a Maya guy” for 10+ years), and am playing with RayFire (demo currently) and evaluating purchasing the package. I got PhysX installed [PhysX Plug-in Version 2.86.00811.20500, PhysX SDK Version 3.2.0] and am playing with both the native cloth solvers and yours.

It’s pretty clear that your stand-alone (modifier-based) fragmenter leverages multithreading – I can see all 12 cores on my system peak nicely when it’s running. However when running the PhsyX-based version in the RayFire Floater, simulations are only uses one core, and don’t seem to by pushing out to my GPU for accelleration (I’m running dual Quadro-5K’s, and one is tapped for PhysX in my 3DS Max config.)

I noticed that the PhsyX tool bar settings have options for “hardware acceleration” and “multithreading” as check boxes. Is your plug-in supposed to be grabbing those settings from PhysX? Or, is that something you enable in the paid version? A big draw for me to your system is the potential to leverage the horsepower I have in my GPUs, and it doesn’t seem to be happening at the moment.

Appreciate you guidance on this one.



Good evening.
I’m trying to use the fragmentation type : SLICE - BRICKS with RAYFIRE 1.59
It works but I’m not able to obtain a wall of sigle bricks, I Always have multiple bicks along the length axis.
I have also a question, in the fragment rollout at the length:Y property there are 2 numbers what they are ? what is the frist and the second ?

Thank a lot


I fragmented a box using Rayfire (I drew the fragments). For some points, I wanted to have extra detail, I tried cutting areas out of the Rayfired geo using ProCutter compund objects (basically cylinders).

In most cases, those ProCutter cylinders killed the underlying geometry, the geo I wanted to cut into was deleted. Sometimes, the edges remained as if there was some wrong boolean calculation going on. Does anybody have an idea how to avoid that?


Draw fragmentation is a little sensitive if you dont really know what is going on, and even then it’s a little hard to get stuff to work sometimes… but some things to try out is to draw lines that cross the entire object, if it starts or ends in the object it tends to fail, so just start well outside of your object and it should be fine.
Another thing to keep in mind is crossing lines, in my experience it doesn’t like when you cross lines in one sweep, so dont draw loops and stuff, but try to draw that as multiple cuts if you need to.
This should also be considered when using the noise function for the lines, if the noise gets too high (and creates internal line crossings) it tends to fail.
I’m not 100% about this, but these are my observations.


Hi, maybe anyone out there has had the same issue and knows what to do:

Rayfire 1.58.02/ Max2012

I fragment geometry using Rayfire, Voronoi - Irregular. Any scene containing this fractured geometry can be saved, but crashes max instantly when trying to load the scene.

Is there a known bug with that setup? Anything else that might help?


Hi my name is Bhavya…
I am experiencing a strange problem with rayfire fragmentation

I have curved geometry with a shell modifier and a xform as modifiers…
i add it into the dymaic objects go to fragmentation i choose Uniform voronoi…it does the job but often leads to missinng/deleted fragments…

.i figured it was because the the arrangement of the point clouds…so check with rayfire fragment modifier adjust my point cloud and my issue is resolved(in most cases)…

now the problem arises when i further try to fragment the existing pieces using a procutter continous…a lot of pices are getting deleted and i acant afford that…
Anybody has any clue as to what might be wrong…/



That could be because the fragments don’t have enough faces, anymore. You can set that in the Avanced Fragmentation options, looke here:

Face threshold: Defines fragments minimum face number. If a fragment has a lower face number than the Face threshold value it will be deleted.

And here, of course:



I tried that it helped quite lot but i am facing a similar problem with a new setup…here is what i do
create a box to be used as ground plane…add it into static objects …
create a box…add it into dynamic objects…fragment it into bricks
create a pf flow setup to interact with it and add it into simualtion

add the bricks into sleeping objects check dea objects option…
change the fragmentation back to voronoi uniform
all works fine…but when i bake my simulation…after it has completed doing so …i get missing pieces in areas where my pf flow geo comes in contact
(this setup is explained in mr mir vadim’s pf flow support video demonstaration)

i am using 3ds max 2011 64bit
rayfire 1.59.01


Hi, I have a question…is it possible to just crack an object in rayfire? I’m new to the program, these are my settings: a large ground plane is set to unyielding object, material is steel. An upright square, set as an inactive object, material is concrete. an identical square behind that square set to unyielding with material set to steel. And the last object is a sphere set to the impact object, with material steel. the sphere bounces off of the square and just completley destroys it…I only need a crack…I have v1.44 by the way.



no idea what i am doing wrong but it seems as if FBX and Alebmic-Files ( exocortex Crate plugin) are not recognized as kinematic-Objects inside Rayfire as you can see in the screenshot:

i use max 2013 and rayfire 1.60.02

thanks in advance and a happy new year! :slight_smile:

edit@ just for the record…this is the answer from the Developer:

this is PhysX limitation so far, it needs position and rotation controller which can be used by engine and it looks like Alembic objects has some special controllers which PhysX doesn’t recognize, the same problem happens with CAT bones, but I made a work around for this and looks like the probably the same trick may work for Alembic objects, I just have to test it


Hi to all, its my first post here.
Im using rayfire 1.59 on 3dsmax 2013 and…
I’d make an explosion of an object but I want make it in bullett time.
I have read here http://mirvadim.com/onlineHelp/rf_physx.html
that I need PhysX helper to make it but… I can’t find it.
Can’t find it because its a demo or do I need some external plugin for my video card? I’m trying using a nvidia gt330.
Thx and sorry for my english.


Nobody can help me?


Hi Vadim

Do you plan to implement the bullet feature in future releases? I remember in the beginning you had the option using afterburn at impact and all that cool stuff.
Take care!



wdr: check out Online help, you cna open it via About menu.

Also want to mention that
RayFire 1.61 plugin for 3ds Max 2009 - 2013 released. :slight_smile:


Sweet! :thumbsup:


Hi mirvadim, which is the best release of physx for this version of rayfire ? 2.86 ? 2.87 ?

Thank you !


I recently updated my RayFire to ver. 1.60.05 for 3ds max 2012, x64.

found a bug (for me) whenever I create the RayFire Helper , the RF Bomb, it will appear in the viewport, then 3 or 4 seconds after i create it, it will crash my max without a message. 

And if a max file is saved with the RF Bomb in it, whenever the file is re-opened, it immediately crashes max to desktop. thanks,


Thank You Vadim Mir :smiley: !