RayFire Tool


Do we have to go to the main Site for the update or will it update in 3ds max?



@ fireknght2 - you will want to priv. msg Mir, ask him to update your account page, then you can grab zip. :twisted:

@ philipho – On your RayFire Objects panel, be sure your static floor and any walls you add to the 'Static_Kinematic Objects' dialog, and any moving or keyframed objects should go into the top 'Dynamic /Impact Objects' dialog.  then go to the Physics tab and pick an engine you prefer, and use the second 'Bake' animation play button (second in) to have it sim.  To have objects fracture while in a demolition, be sure to check on the 'Demolish geometry' option, or the object(s) will not fracture (based on the Frag. tab settings).


Thanks PexElroy will do straight away.


Hi, guys, i’d like to ask you for help.I have problem with rayfire,every time i try to animate somthing i have note “unable to convert true to type integer” if someone knows how to fix that please tell me.


same problem as shared by pumbama… I m using rayfire 1.57.10 with physx 2.71. on max 2012… I fragmented the object and did simulation … but when I save the file and reopen the file it doesnot open and show some error like file got crashed… can somebody help with this thing… and @ mirvadim: Is that a bug of rayfire 1.57… and dont tell me to update rayfire coz I just updated recently and my company doesnot allow me to update again so soon… and r u sure this thing wont happen in rayfire 1.58…


I was having the same problem- i ended up doing a “clean” re-install of max- getting rid of all the folders in the max directory before re-installing. That was what fixed it for me- not sure why exactly. Also make sure you have the correct PhyX 3ds max drivers and PhysX system software. I’m on 1.58 now but I got 1.57 to work with this combination:
PhysX for Max version -2.61.0916.1330
PhysX System Software 9.12.0213

Although there are newer drivers that would probably work too.


[left]Now i have Physx 2.71 and rayfire 1.58 and everything is working good as soon as i try to make fragmentation for any object then this note shows up : “call needs function or class got inderfined”


Hey guys, maybe someone knows what’s causing my issue.

Basically, concave meshes behave exactly the same as convex.

So for example, If I have a bucket with an opening in the top and I go to drop an object into the bucket, it acts as if the bucket has a lid. So the object just floats in mid air above the bucket.

I am using rayfire 1.58 with the suggested physx SDK and Max plugin. (2.71 for plugin). And I have set my meshes to be concave. Tried various other versions of physx but still getting the same issue in max 2012.


when I fragment object using voronoi… its crashes… mainly while using plane… and also when I use box or other geometry and use voronoi it too get crash and after I save the file and reopen the file it doesnot reopen at all… it shows some error like file could not be open… but this thing doesnot happen while using proboolean and other… i m using rayfire 1.58 with 2.85 physx for max and 9.12 physx…



Rayfire’s been a bit iffy for me as well.

Getting a Maxscript “–Uknown property: “count” in OK” quite a few times, which also seems to break Rayfire until I restart Max.

I’m guessing something is going wrong with the fragmentation part.

Don’t think it’s PhysX related as it seems to happen with Bullet as well.

I did install the latest product updates for Max 2012/2013, not sure if that’s related - normally it only breaks PhysX if anything.

Anyone else getting this?




So I installed:

As required for RayFire. That all works fine on my machine. RF, PhysX, everything.

HOWEVER, if I take a file and open on another machine and then save it (or autobackup) it crashes to desktop. So basically every file my machine touches now turns to crap on other machines. Can anyone confirm?



I’m getting this error too. It happens every time I try to use “Secondary Fragmentation” in the fragmentation tab.

Also I noticed that when using the fragmenter modifier it isn’t using all my cores which I find odd since I have the latest build and multithreading support was listed in there. Not sure why it’s ignoring my other 7 cores.


Finding Rayfire pretty user friendly and having no trouble get around the UI but one thing I can’t figure out is why the fragmentation modifier isn’t run on all my cores. I have 8 logical cores but only one is in use. I see in demo video of the frag modifier he points out it’s firing on all cores significantly speed things up yet when I use it it just report 1/8 and the resource monitor confirms this. Do I have to enable multi-threading somewhere? Does anyone else have this issue? The increase in speed would be greatly appreciated. Thanks!


Is Glue currently supported in 1.58 + PhysX 2.71? It seems not currently.

edit: I have glue working normally on my Max2010 with 1.57 + PhysX 2.71. But not on the main setup listed above. :frowning:


Hi, I’m wondering how I should fragment a hollow object like for example a simple tube, because when I try using Voronoi then I get all these artifacts and I could use ProBoolean but then I don’t get the result I want to and also the objects just explodes booth with convex and concave simulation, I can get rid of the exploding by setting the collision tolerance to 10cm on a tube that are 70cm but then it look really bad with so much intersecting geometry.

3ds max 2012 64bit
Rayfire 1.58
PhysX 2.85

So does anyone have any tip on how to fracture a Tube?

thanks in advance (:



cebas VB modifier eat all geometry even very complex like tube :slight_smile:


Yeah, PhysX is unstable with non-convex geometry, as you say object explodes, sadly shell models generate always non-convex fragments when fracturing, PhysX cannot handle it you have to use a diferent solver , Pulldownit plugin shatter and computes fracture for shell models fast and stable. Her a demo( shell model demo start at 0.30 seg of the video)




Concave dynamic objects supported will be added back with next minor update.
Working on RayFire Shooting free script with all removed good old shooting features, but with PhysX support now.
Also, I recommend to use PhysX 2.71. Don’t know what kind of callback they added in 2.85, but sometimes it cause crash when scene saved and opened on another workstation.


Dare I ask what the latest combo of files is required for Max 2012 x64 :slight_smile: … first time going back to ray fire in a long time and have PhysX System Software 9.12.0613 and PhysX plugin 2.72.0601.1047.

Trying to get demo version working but keeps saying physx not supported then in the max script error saying its not installed. I had uninstalled the previous PhyX and updated max to latest hot fixes etc then re-applied the PhysX update. Funny thing is that PhysX actually works fine in max.

It seems that one month I can get it all working fine then when going back to newer versions its just a nightmare getting the right combinations of files :smiley:

*shall try get the version Mir mentions, but I dont hold up much hope :slight_smile:


Corridor Digital’s new YouTube video “Head Hunters” makes massive use of RayFire :slight_smile:


and the making of: