RayFire Tool


Woops- that was a typo. I meant:
But even when i re-install over SP2 it still get the error.
– Unable to convert: true to type: Integer <<
– Error occurred in Prep(); filename: C:\Program Files\Autodesk\3ds Max 2012\plugins\RayFireTool\RayFireTool.mse; position: 285866; line: 1065
– Defined in encrypted script
– called in start(); filename: C:\Program Files\Autodesk\3ds Max 2012\plugins\RayFireTool\RayFireTool.mse; position: 311465; line: 1161
– Defined in encrypted script
– called in PxRecord_btn.changed(); filename: C:\Program Files\Autodesk\3ds Max 2012\plugins\RayFireTool\RayFireTool.mse; position: 352358; line: 1303
– Defined in encrypted script
– Error occurred in anonymous codeblock; filename: C:\Program Files\Autodesk\3ds Max 2012\plugins\RayFireTool\RayFireTool.mse; position: 285866; line: 1065
Not sure if that helps. Probably something local.



Did you install PhysX System Software, the actual PhysX engine?


Yes- I did.



Aside from the installation work around, does Rayfire work better with Max 2012 than with 2012 Design?


sorry for bumping this, but can anyone shed some light into this?
(shooting feature - rayfire gone ?)


Yes, it’s gone for now.


Is any part of rayfire accessible via maxscript? It would be great if there were a way to network sim from a batch file.


Hey whats the skinny on rayfire and max 2013, nvidia drivers , mass fx, bla, bla bla…???:eek:


I started to enjoy with ray fire andthis is my first rendered test.
Play with deformable meshes is hard to do without the Mir tutorial.
where actually is “activation by texture”?

Mir, this is a great plugin for “solid” and fast demolition setups but I spend more time to delete objects from lists and get to the “play/stop animation” buttons.



does anyone know how to set the brick fragment setting so they give me nice english bricks?

ive been playing with the fragment length, width height etc and getting no joy…just lots of blocks in various sizes not off set as bricks would be…cheers


Hi everyone,
here is my first test of RayFire & FumeFx


When use Tesselation 1 in Secondary fragmentation, in order to add extra detail to those debris, all the thing look fine at that moment. But the max file is showed as corrupted when i open it again.
Any one facing same problem before ?
I use 1.57.10
Sorry for this dumb question:)


Nice setup with the golf club/ball! :slight_smile:



I have a point cached character in the scene which has to break through some walls. Its been selected in the kinematic objects rollout whereas the walls are in inactive rollout. The character has been assigned custom properties and deformable yielding is checked in the same.

Still it does not participate in any way in the collisions. The character runs to the last frame of its animation when the sim starts. can any1 help me out with the why???

I am running rayfire 1.57.10 on max2012 with the latest physx 2.7 version.



Rayfire 1.57.10 on max2012 Crashes for simulation…Only when i use rayfire procutter “wood” splinters…everth other fragment used has no effect…is it because of the number of pieces the box model breaks in to…my specs are i7 860 2.8ghz…8gb…its nuthin complex…just a simple box i fragmented…jus to test something…can any1 tel me why

Ok now rayfire is acting weird the framentation is completly wrong…and when it does fragment…and i run simulation…the box which has been fragmented and set to dynamic object just explored when i run it…

Now thers is another problem…this isn’t related to rayfire but still am hoping someone can help…physx is just messed up…everything looks weird…it looks like…this simple flag simulation
it looked like this yesterday…it was working fine but something changed as all cloth simulations look like above or it crashes when using dynamic rigid bodies etc…


RayFire 1.58 with some new features and fixes was just released.


Thank You Mir for the update news and keep up the great work Rayfire gets better everyday.



Hello guys, I was wondering if you could help me cause i have small problem . The thing is that i have 3ds max 2009 x64 and recently i’ve installed the rayfire, also i’ve downloaded Physx plug-in 2.01 and when i’m trying to make simulation of any kind it says that i need Physx 2.61 so i’m looking all over and can not find place where i could download that version. So please if anyone could help me i would be very thankful.


Hi All,

I’ve just got Rayfire 1.58 installed on my work machine but cant get it to work properly. I’ve got some bricks that get knocked over by a truck in my scene, the truck is animated to crash through this pile of bricks, but when i try to sim the bricks just fall through the ground static mesh and doesn’t interact with the truck or the ground/

Is there any documention out there on how to use this for sims?




This should be cool. :thumbsup: