RayFire Tool


Hi Mir,

Free updates for a year is pretty good. Not too bothered when the new version is released but I didn’t want to buy it and have to pay for an upgrade a few weeks later.

I’ll get a copy before xmas now, thanks.

  • Garry


Hi all,
I have max 2010 and 2012 installed, and about a month ago I installed the latest PhysX drivers from the NVIDIA dev. web site (with the login).

           After the install, 3ds Max's PhysX toolbar buttons say: "/*#&!@" now, what gives?
  RayFire does not work properly - it can only slice.  And I do a RF sim with RayFire 1.55 or 1.57 I get a script erorr with PhysX. In 3ds Max 2012, the RayFire stop and play buttons are greyed out - no interactive sim.
           Also , MassFX does not work in 3ds Max 2012 after i installed that newest PhysX installer -

it is now incredibly sluggish and has script errors when I try to hit Play - broken also.

           versions installed currently:
         NVIDIA PhysX Plug-in for 3ds Max 2012 64 bit, 2.61.0906.0900
         NVIDIA PhysX Plug-in for Autodesk 3ds Max 32 bit, 2.01.1222.0945
         NVIDIA PhysX System Software 9.10.0514
    What does one do to fix this PhysX mess ?


Everything you have right now is old.

First of all install latest PhysX SDK:

Then latest PhysX Plugin
And don’t forget to download it from their website too, they need this for some kind statistic.

After that, get 1.57.


Thanks mir - will try this out and see if it helps the problems :slight_smile:

          EDIT : ok, installed these new drivers and RF 1.57 seems to work again in 2012 64 bit, and the ON Play/Bake buttons are working for interactive sim and with frag :)  but my MassFX toolbar buttons are still broken, some of the MassFX buttons are labeled >>> @!&*# <<<   and do nothing when pressed, so maybe the PhysX drivers broke MassFX - guess I do not need it with RF 1.57.04.


but my MassFX toolbar buttons are still broken, some of the MassFX buttons are labeled >>> @!&*# <<< and do nothing when pressed, so maybe the PhysX drivers broke MassFX
The last I knew when you install PhysX then the MassFX is no longer available per Autodesk Community forum. When or if you decide to remove PhysX then it is supposed to restore MassFX. I had to manually install massX when PhysX was messed up but maybe they fixed that.
In conclusion I believe you have to choose between one or the other I recommend PhysX as it works well with Rayfire…:slight_smile:


Thanks fireknght2 :slight_smile: - yea, noticed MassFX was ok - right up to that PhysX install ,

            yea I prefer RayFire too ...


I just ran through all of this too :smiley: , if you are using Rayfire and PhysX in 2012 you no longer have the option to use massFX. The current build of the PhysX plugin for max (2.7.xx.x) is much more robust than the current iteration of massFX anyway.

Happily, everything is working as slick as an oil spill for me


yes I ran into all of this myself this week…to me this is all good, it took a bit but things are looking sweet…good riddens Massfx.


Here is my small Xmass present for all of you. :slight_smile:
I called this feature “Dead objects” and it works for objects in Sleeping list.
Shortly, when this feature is ON all Dynamic and Kinematik objects gently pushes Dead objects so they do not fall and do not explode, just moves a little bit.
Here is Demo\Tutorial how this feature works.

And the best news is that feature already available for you in latest released minor build 1.57.05.



fantastic! thanks Mir! :buttrock:


:bounce: cool… will check out…


Hi guys i really need some help for a work to my college.

I’ve installed Rayfire 1.55 demo but i’m having problems when i try to collapse buildings, they’re actualy exploding insted of demolition. I’ve searched for some tutorials but coudnt find where to change this, mostly of the tutorials i found are for the older versions and the layout seems to be different, i’m kind lost.

I’ve successfully been able to fragment the object but unfortunately no success on destroying them, because as i’ve said, they always explodes (fragments flying all over the scene :frowning: )

Anyway, just need to do something like this (it’s for a still image, not an animation).
Witch is the vallue on rayfire that i need to change for something like this happen?

Thank You.


New build 1.57.06 is out.

Now you can use Convex shape property for each element in geometry.
Each element will be simulated as convex, so whole geometry will be simulated as concave.


Mir do you ever take a Vacation? Happy New Year and thanks for the new update.



when i’m using rebars in a interactive demolision sim it works great, although, when i have a prefragged object and the frags in sleeping mode rayfire seems to disregard the rebars, is this true, or am i doing it wrong?


fcluk: Looks like you use ProBoolean fragmenttion types which cretes concave fragments and use PhysX convex shape for simulating them. This is why they explode. Try to use Voronou frag types.
Also get latest 1.57 which is more stable with latest PhysX 2.7

Tollman: Yes, rebars do not affect on Inactive objects atm, I already fixed this for next minor build.


thx mir, i’ll try :slight_smile:

see ya.


cool… looking forward to it.
awesome with these rapid fixes

any news on the bullet implementation, have you got a timeframe?


One thing I’ve never managed to get an answer to, is if there is a solution to the problem I’m having here, where geometry that consists of faces extruded into an object boolean badly.

Is there any way to get objects modeled this way to boolean correctly, or is it just the nature of the Proboolean function in Max?

Do I have to build them as separate objects so you don’t have these undercuts in a single object?




That’s certainly a difficult shape to frag since it’s done with planes and they will cut through the holes and get capped.

One way to deal with it is to have each depth layer as a separate solid object. Like so: