RayFire Tool


Anyone having problems with static objects not being static with Rayfire 1.63 on Max 2012? I’ve got version 2.84 of the PhysX SDK installed and 2.70.1028.1400 of the PhysX plugin installed. The same versions as I used to use with Rayfire 1.58 I think.

I can’t upgrade to a newer PhysX plugin because installing it makes max files incompatible with any other users, even when PhysX isn’t used.

It seems to be ok if I use Max 2014, but we’re still on 2012 at work for now.

Is there an official Rayfire forum these days? I can’t find one, but there used to be one.



RF 1.64 Voronoi Modifier is very fast and promising… but I’m experiencing a lot of unexpected results.

Many fragments are invalid. Sometimes a fragment will overlap many other fragments and/or it will have missing polygons from sides. You can see these problems most when you give a Gap value in the scaling group of parameters.

Attached is an example.

Such invalid fragments seem to also increase the odds of larger than expected fragments getting deleted when using the Delete < # .


Hi, yeah, we already kno about this problem and will fix it in next release.
Sorry for troubles, this is first release of Voronoi modifier and even tho we tested it in some cases it still may fail.
If you or someone else get weird results or found some bugs, please email about this to me with attached objects or scenes, everything will be fixed.


@wallworm: Not sure whether you have the same problem but your attached file looks like the problem I have. Whenever I fragment an object before running a simulation I will get cracks and gaps at time 0. So there is no way for me to rewind my video and start it with my object fully intact. It will always be partially or sometimes even the total object damaged.

However, if I don’t fragment it and use the object’s mass and the kinetic energy from fall to break it I can rewind the video and start of with a normal object.

The problem is that I have to fragment it in order to use forces.

So to summ it up:

I take like a ball and move it on the z-Axis. I add it as an kinetic object as let’s say glass.
I add a plane as floor and make it the static object. Then I fragment it and hit “bake”.
It’s going to fall apart. After the simulation is over so time = 100 I take the time slider and
pull it back to 0 but I don’t end up there with my ball but with an already cracked sphere where you can see all the cracks and gaps and parts are already falling. It’s like the simulation started somewhere on a negative Timeline.


The latest update Mir loaded fixed the problem I was having.


Oh, really ?

I didn’t get a message that an update was out ? Do I have to check that somewhere in Max ?
I thought I’d get a notification. Well okay then I’ll probably have to update it to solve the problem, but still was that the same problem you had ?


Yeah, news of the update was shared on the RF Twitter Feed . Also, you can usually get news of an update inside RF itself by clicking About > Check for updates .

Regarding your case… it is possible it is related programmatically to the problem I had (but I could not answer that). The problem I was experiencing didn’t even involve simulations… it was simply errors in the RF Voronoi Modifier if the object was larger than some dimension in the scene . And that error is fixed now.


Okay thank you. So it might be something else.
Mhm perhaps I could try to set the simulation further to the future, maybe that helps.
I will try that out.


Whats it take to get the software I paid for?

I have tried contacting RayFire Studios repeatedly and get no response even though I purchased two days ago.

Anyone else having these problems?


Hey Mike join their facebook group, both Ansi and Mir moderate the group.



Thanks for the ideas John!

But I am not currently on Facebook and I don’t desire to join just to get them to respond. I have sent emails via this forum, the e-commerce site I purchased through, the contact form on the RayFire site (twice) and the email that came with purchase confirmation. Hopefully at some point they will pay attention to whether they’ve made a sale and get me the info I need to get my product.

Thanks again.


Hi Mike,
John pointed your posting out to me. I am sure Mir will get a hold of you shortly. How can I be of service?
After payment goes through you should get a login for the members area. if you want you can send a proof of payment to me to anselm at incendii dot com and I can send the latest installers your way.

Sorry for the inconvenience,



Thanks for your assistance. This has been a frustrating process. I immediately received purchase confirmation emails after purchase, but have never received emails with license or login or download instructions. (And no, they haven’t been missed by Spam filters).

Initially, when I went to purchase via PayPal from the RayFireStudios site… it was Russian PayPal and I couldn’t read it. So I then chose the Plimus choice which was in English but I had to register just to use it… which I did. The next morning, I was contacted by my credit card company and I told them the purchase was not fraud. As I have tried every avenue to get Mir to respond and send me the needed info, today I discovered on the RayFireStudios site the page listing resellers and found the US reseller and went to their site to ask for their assistance in contacting Mir (and discovered I could have bought the plugin for $60.00 cheaper than via the RayFireStudios site!!). They were very kind and forwarded my purchase info to RayFireStudios but were basically using one of the many email addresses that I have already used to try and get in contact and I still have not had a response.

I can send you the purchase info but since I haven’t receive my license info I don’t think it will do me any good at this point.

Thanks again.


Mir was able to get hold of me last night (via the email sent from this forum) with my login and license info (Thanks Mir).

Sigh… But now I’m having a hard time downloading the install file from the RayFireStudios site. I don’t normally have problems downloading files but every time I try to download it gets to about 30mb to 45mb then the download dies. And this happens with or without a download manager and the download won’t resume when using the manager.

The filename has ’ ’ in the name such as ‘filename.zip’. Don’t know if that is a problem or not. Not sure why downloading should be such a problem.



Thanks to Mir and Anselm (and John), I now have RayFire downloaded, installed and functioning.

Thanks again!


I started using RF Cache feature recently and noticed an issue. The cache works fine with flat fragmented objects but when used rounded fragmented objects like a sphere it come out lumpy. Here is an example:

The top row is a sphere and a box fragmented. The bottom row has been RF Cached. As you can see the box looks fine but the sphere looks like something is wrong with the smoothing. I have tried to add smoothing modifiers to it and also tried the RayFire Cracks modifier to no avail. Anybody else have this issue? Does anybody have a solution? Thanks

Here is a closer look:


The issue is that the individual pieces (as objects or as elements) do not smooth between each other even when the same smoothing group is used. Smoothing groups only work between faces sharing an edge–so never work between elements or objects. I have a feeling that adding a Normal calculation into RF would be possible but slower to build the fragments.

I think it’s kind of a non-issue, though.

You should think of rendering the largest non-destructed set when possible. So use the original, non-fragmented ball in your render (and hide the fragments) until it collides and fragments–then hide the original and unhide the fragments. At that point, the lack of smoothing is really a non-issue because the fragments will go do their thing and they eye won’t see any adjacent faces with odd smoothing.

Another thing is that some motion blur can also hide the smoothing oddities in many situations.


Dear all,

I’ve been using Rayfire for a couple years for simulations, but have just used the Image Trace feature for the first time. I’m using it to create a custom shape for an island (shaped like a human) and I’m adding terrain features procedurally.

The Trace object works as promised, but Max keeps crashing. The projects take tens of minutes to open (with almost nothing in them), and it keeps getting hung up. I’ve been banging my head on this particular wall all day.

Any thoughts or recommendations? Thanks!

Rayfire 1.65 on Max 2015.


The issue has been FIXED in the new version(1.66) of Rayfire. Thanks Mir.

Well Rayfire had/has “Custom Vertex Normals, no smoothing artifacts at sliced edges.” The top row of my image the objects are fragmented and look smooth. The bottom row is the RF Cache. It is one object and that is why I tried smoothing groups. No need to hide or use the original object. Rayfire will smooth fragments in regular fragmented object and now in RF Cache.


Duplicate. Please delete.