Ragdolls and Havok....


#1

sorry all, as you can tell im really really new at this and my english is not so good, but i need help creating a human Character that uses this reactor called Ragdoll. thanks!


#2

I know very little about 3D, but there is a maxscript for applying ragdoll to a character, as long as its a biped I believe. MAXScript > Run Script > rctRagdollScript (its in scripts folder)

If you want to see it in action, make a character studio biped and run the script. It will highlight Bip01 (default name for biped) and all you have to do is click “constrain humanoid” at the bottom.

Go to reactor > preview animation and press P to play it. It will be easier to see the effect if you make a box under the biped, and add it to a rigid body collection. That way, the biped wont fall into infinite space when you preview the animation.

Im sorry if I didnt answer your question, I am a huge noob :slight_smile:


#3

also, there is a video-tut at discreet:
http://www4.discreet.com/3dsmax/3dsmax.php?id=399

(the last one at the bottom)


#4

Ah, thanks ernest. I totally forgot about that tutorial even though I’ve viewed it several times.


#5

I hope I don’t have to dissapoint you. But you will run into problems.
The preview in the havok window will look perfectly cool, but when you try bake
it into keyframes, for game cinematics or rendering, it behaves totaly weird.
That happends because bip01 is not a part of the simulation.
I never managed to solve that problem :banghead: but I wish you good luck.
Maybe you could pm me if you were succesfull.

cheers
flo


#6

I had the same problem but to fix it you create a point to point constraint, parent (I had mine as biped01 pelvis) dunno if works on others, havent tried it, child = biped and i was able to get the ragdoll effect fine :slight_smile:


#7

hey dARCKLOWN
Thanks a lot for that

I will try. Have you managed to get the same result as the viewport promises?


#8

florian - try this patched version of the ragdoll script.

from the comments on the script -

The rctRagdollScript.ms that comes with Max6 did not function correctly with Character Studio Bipeds.
Simulations would seem correct but once the animation was baked, CS’s structure would block The pelvis from
animating correctly.
An extra check button option has been added that runs a correction to this problem.

once i setup with this i had no problems with discrepancies between the havok window and the baked ketframes.


#9

WoW! Thats cool pudgerboy
Thanks for the info :thumbsup:

I just wonder why it needs a extra check button if its the only solution that works. :smiley:


#10

i know, its not like you’d use anything but a cs biped for it anyway :thumbsup:


#11

is this patch supposed to be renamed to rctRagdollScript_Xpanded.ms, or simply placed in the folder with rctRagdollScript.ms?

it doesn’t want to work if i rename it… that is for certain.

…i suppose i’ve just answered my own question :stuck_out_tongue:


#12

I tried it.
You just have to use it instead the “standard” ragdoll script.
It works fine for me. The only thing that looks a bit problematic is the constantly hip collision. I’m sure it’s a matter of the right settings.

Does pudgerboy has any experience with it?


#13

Awsome playing with that new script now, saves alot of fiddling.

One problem that im having thats really pissing me off is that when I start the simulation, my rig jumps, think of it as him being electricuted the second the sim starts then he goes into ragdoll mode, anyone know anything about this?

Also with that script, it dosent add the feet?, not hard to do it yourself just more for convenience.


#14

i haven’t had any problems with it - as for not adding thefeet , there’s a checkbox to add the hands and the feet so im not sure what you’re doing? it worked okay for me. only bug i found was it wouldnt work if your biped had a space in its name ie “character bip01” wouldn’t work but “characterbip01” would.


#15

Just as I said…There’s a constant collision going on.
:shrug:

The simulation looks nearly excactly like the one played in the havok viewport. But if you have more action for example, a ragdoll falling down thousends of stairs, it will make him land somewhere else.

Well…still a lot better than nothing.
Thanks a lot pudgerboy :applause:


#16

the thing that ive always thought about reactor is it’s ‘fleshing’ out the motion for you - not replacing it. You’d always have to clean up motion capture and reactor is no diifferent. i always sim to the point that i like the general motion, and then keyframe by hand to bring in a more ‘animated’ feel.

Florian - after your sim you can use the reduce keyframes utility on the reactor rollout and that might cure your problem. if it doesnt, you’ll have a handful of keys on the bip so that you can locate the problem without any trouble.

hope this helps!


#17

this is what the script returns me…
http://www.iart.ca/files/rctRagdollScript_Xpanded.jpg


#18

Your whole script file looks xxxxed up. Normally it should look as if it makes sense.
Try to download it again.
Put it in your scripts folder and use “run script”

Should be that simple. If it don’t work…no idea what has happened. :shrug:


#19

Yeah that expanded script really is nice, dont get the ‘eletricution’ any more but still, even with the add feet check box ticked it still dosent add it. Added the hinge contraints and added them manually but still ahh well all is good :smiley:


#20

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.