R21 Prorender VDB volume issues


I’ve been testing out R21 Prorender’s new ability to render Open VDB volumes, but have come across an issue. As you can see in the image below, the bounding box of the VDB volume is visible. It appears that light emitted from the VDB volume itself has no effect inside the bounding box. In other situations the bounding box seems to darken objects that are behind it. So far no tweaking of the Volume material has eliminated the issue. I’ve seen this problem with VDB files exported from XParticles as well as one downloaded from the Open VDB website. I’m wondering of this is a bug or if I just have a setting wrong somewhere. I’ve done a fair amount of volume rendering using Cycles 4D and Arnold so I am familiar with the concepts.


Have you try Detect Value Range :thinking:


Yes; unfortunately that didn’t help. Is anyone else seeing this behavior?


Increase the Ray depth of refractions. A Volume counts as 2 bounces so the default of 3 in the Preview rendering doesn’t leave much left for the rest.


Hmm, I tried setting it to 100 and I’m still seeing the problem. I also tried setting everything under the “max ray depth” setting to 100 which didn’t help either. Strange…


Do you feel comfortable sharing the .c4d file so others could try it?


Absolutely, here’s a version of the file with a single frame of the VDB sequence to save space. I should have also mentioned that I’m on a Mac in case that ends up making a difference.

Pro Render volume test


There are two issues here: As Fritz mentioned, the max ray depth needs to be at least 4, and the refraction depth needs to be at least 3, for this to work. The other one seems to be a current limitation with Prorender: the geometry on which the light is cast cannot be within the bounding box of the vdb. So, dragging the disc down in the y axis allows it to work. Of course, this wont work in all circumstances. Hopefully this gets addressed soon.


Thanks for verifying this. I will issue a bug report now that it seems to not be unique to my system.


I’ve also encountered several crashes while testing this file. It seems that VDB volumes aren’t quite sorted in R21 yet. It’s too bad since the render speed is impressively fast. I have yet to achieve results as realistic/ convincing as Cycles 4D or Arnold for fire and smoke, but that could also improve with more testing.


I also had a couple of crashes viewing this file (also on Mac) and have yet to try @NWoolridge’s settings, but I saw the same issue when rendering.


Hi, I’m new to this forum and i’m not an expert in c4d, i’m also french so sorry if i explain bad.

I think i have the same problem, i tried the parameters that NWoolridge mentionned, but it still don’t work, is it a problem that can’t be solved for now?



Maxon replied to my initial bug report saying that they thought this looked like a bug, but unfortunately it has not been addressed yet.


thanks, i did’nt understood that it was a bug, i guess we may have to wait until r22 ^^


This looks more like another limitation of Prorender: you can have multiple volumes in a scene, but they cannot overlap. Prorender does not support nested or overlapping volumes…