R21 Mixamo Control Rig - 'adjust' not working


#1

Hi, been following the tutorials on applying a Mixamo control rig to a mixamo imported animation.
Once the character rig has been set up, it should be a case of moving to the next tab: adjust and the new mixamo character rig will snap onto the fbx rig. However this snapping to fit does not work.
I have the fbx rig set to the ‘reset bind pose’ but still no snapping takes place.

Anybody else having problems with this workflow?

Thanks

Mark


#2

It works fine here.


#3

I can get it to work if the imported FBX is similar in size to the default C4d Character Builder Mixamo Rig. I’ve attached a file where there is a size difference between the two - and the ‘adjust’ tab no longer snaps the Character Builder Mixamo Rig into place.

Could you see if the adjust works on your machine with this file?

Many thanks


#4

Mixamo_Adjust_01.c4d.zip (2.2 MB)


#5

Add a “mixamorig:” prefix to your bones (eg Hips becomes mixamorig:Hips) and it should work.

I think mixamo might have changed slighlty their naming convention if this was an older model.

(Edit : use the naming tool to do it quickly)


#6

Hi Eric, thanks for your reply - I followed your tips and it is almost there (I had to delete some takes from the fbx rig that were preventing me from adding the weighting to the geo from the new character builder rig)

Just one glitch remains - the upper leg joint isn’t following the fbx target rig - despite having all the joints linked up correctly. See the screen grab and attached file if you have time to look. It makes the legs push out backwards instead of forwards.

Female Walk_Mixamo_CTRL_Rig_02.c4d.zip (2.1 MB)


#7

This can be usually fixed by adjusting a bit the knees in the adjustment phase to bend slightly the right way. However in your scene the inverse happens, the knees need to be adjusted to bend the wrong way.

It might have to do with how the joints are all oriented in world space in that character, it seems to cause the rig’s joints to be oriented “backwards”.

Mixamo_Adjust_01_mixamo_0001.c4d.zip (2.1 MB)


#8

Have you tried to re-rig the model in mixamo?

Since it takes a few seconds to upload the model, autorig and download, it might actually save you some trouble.


#9

Hello,

So this is me shooting in the dark, as I havent looked at the file as it would be a while until I can. But someone informed me a bit about the file.

From what ive read and been told, it sounds like all of the joints are world aligned in the mixamo t pose yeah? Usually that wont work. Mixamo when it first started, used this world alignment, but down the road they switched to a Y down the bone alignment. But there are still some animations and or characters without this new alignment. The 21 mixamo rig will not properly retarget those that are world aligned.

As someone else mentioned, you should delete everything but the model and re rig it through mixamo and apply anims there. That should probably generate something for you with the proper alignment.

Like Orestis saidd if the knees bend backwards its probably just because of how mixamo chose to place the joints. Sometimes because of the model it can make it so the knee joint is ever so slightly behind the thigh or ankle. When this happens, the knees will bend the same way. So jump back to adjust mode and after they snap back, just hold the move without child key to drag the knees a little bit forward so they are in front of both the thigh and ankle.

Also if you choose to not have the mixamorig: namespace, a lot of the helpful automatic features will not work for you. The auto adjusting, retargetting buttons and weight transfer stuff might not work automatically, but you can still manually do each step(ie turn on axis locking to snap during adjust, manually dragging and dropping the necessary joints into their corresponding retarget slot etc).

Hope this helps
-Bret


#10

To add to the discussion, some older mixamo characters and animations won’t work with the R21 rig if you download them straight from the website.

Even if they have the same bone hierarchy and size, because of the legacy bone orientation, your joints will flip horribly in C4D, and because the C4D retarget tag is useless, it won’t work.

If you import a recent/custom character into mixamo and apply the faulty animation, mixamo will however retarget the motion properly, and then you’ll be able to use it in C4D.

If the motion is not from mixamo you’ll have to retarget it outside of C4D (I use Ikinema Webanimate for that), or painstakingly add offsets in the layer system, but I would love to have a working retargeting system in C4D, now that it actually makes sense to edit mocap with the new rig.


#11

Hello, thanks all for the detailed responses,

Just to be clear on the origin of the character - this was a stock character and a stock female walk cycle directly from the mixiamo site.

Have I understood this right then - that mixamo has old and new rigs attached to their stock characters? And only the newer rigs work with in the new r21 workflow? Older rigs need the bit of tweaking prior to the ‘adjust’ stage.

thanks

Mark


#12

Basically, yes, that’s my experience.

My advice : don’t bother tweaking in C4D get rid of the bones and re-upload the model to mixamo to get a fresh new rig.

That’s what I did for a DAZ character in this example:
https://vimeo.com/359858369