R21 First Impressions


Redshift only works with older MacOS versions that support nVidia Web driver installation CUDA etc. Apple closed the door on nVidia driver installation citing ‘security’. Apple and nVidia have been embroiled in a long standing dispute, neither get on and the poor saps who continue to use Macs for professional work are caught in the middle of a corporate powerplay.

It has been said that Redshift will support native Metal compute later this year after the new Mac Pro is released. They may have every intention but I don’t believe a word coming from the Redshift developers regarding release time frames. There have been many promises made and everyone to my knowledge has never been kept.

There may well be a Metal compatible version of Redshift available later this year but, based on past experience, there’s every chance it’ll be a very undercooked feature incomplete Alpha build and it’ll be more like 6 months to a year later that it’ll enter perpetual beta.

More and more users are getting upset that long promised features like random walk SSS are seemingly months and months away. Redshift SSS is dreadful, it’s blotchy or slow and noisy depending on which mode you use, skin renders look like wax-works and random walk SSS is seen as the silver bullet to get acceptable skin renders finally. There are countless other features that have been spoken about at several nVidia presentations that have yet to materialise.

I did not renew our Redshift maintenance because of broken promises and since the Maxon acquisition almost zero communication of what’s coming when and how. The Redshift devs were always very open about plans before being Maxoned.

Say what you like about Autodesk, Arnold urinates from a great height on Redshift in terms of features and quality of image. If you’re a professional and you’ve got a renderfarm or use the cloud Arnold makes much more sense.


I won’t buy another renderer right now. I just want to try that out. Thx regarding your hint on the weak GPU (I saw that comin ;-)), but man, no need to lower the language on this thread too.


I mentioned that I’ve removed Karibiner. whilst it’s a really handy extension for me, I can live without it. Once removed, I did notice that R21 began to recognise the alt+RMB (Ctrl+Click), but as I mention above, it’s not working as expected. That command should scale/zoom the camera, but what’s actually happening for me is that the camera is rotating around its own axis. I’m sure there is a keyboard command for this in C4D, though I don’t know exactly what it is. I’m guessing that, for whatever reason, these commands are being confused for some reason unknown to me.

Yesterday I put R21 on another couple of Macs in the studio and I got the same camera behaviour. These weren’t Macs that I’ve ever worked on, so are not ‘infected’, if you like, by any of my own personal prefs, apps or extensions. Probably also worth mentioning that one of them was Mojave and the other was High Sierra… I emailed a quick screen recording to one of your guys last night to demonstrate this change of behaviour between R20 and R21.

Would you consider Wacom driver to be a kernel extension?


Any driver (e.g. graphics driver or 3rd party audio driver) is by definition. However as we use Wacom tablets too and couldn’t reproduce your Wacom issue, we’ve to dig deeper in a session to figure out what’s set different on your installation.

Best regards,



OK, let me know if there’s anything more I can provide you with relating to my system/s setup.

I should mentioned that once or twice the camera did actually scale/zoom as expected, but I’m talking about 0.01% of the time.



Just tried the R21 with Octane all seems to be working well. There seems to be a few graphical glitches with the interface, sliders get a dark bar cutting through them and input fields are temporarily unresponsive sometimes. Preferences takes an age to open.


That’s a typo, multipass increases quality slightly.


My Space Navigator finally works perfectly with C4D on a mac.
/ Alex


So anyway, I just decided to try an R21 install on an old cheese-grater Mac Pro and I’m afraid it’s the same thing, Alt+RMB doesn’t scale/zoom the camera, it rotates the camera around its own axis…

I decided to make a Quicktime screen recording, but weirdly once I started the recording Alt+RMB actually started to work occasionally. What I noticed was that, being an old Mac Pro, the system slowed down considerably when Quicktime began recording, so I’m guessing the slowdown facilitated C4D recognising the Alt+RMB in some strange way. Explain that. It was sporadic, however.


Perhaps im mis-reading the video, but it seems a a lot of the time you are holding down 2 extra keys simultaneously, alt + control.


Yes, Alt+Ctrl+Click, which is equivalent to Alt+RMB.


Can you sell your Redshift license?


Just a thought, you’re not using a wireless keyboard + wired mouse are you? Your mouse clicks might register instantaneously, whilst the lag of the wireless keyboard causes the modifier key signal to be sent just after the mouseclick.


I’m using a wireless keyboard with wired Wacom, but I’ve also tested with a wired keyboard and different Wacom/driver combination.

  1. GUI seems quicker, snappier, more responsive. Really like the new dark theme.

  2. Navigation using 1,2,3 seems… changed, if not broken. I’ve found myself moving items rather than the camera countless times over the last couple of days. Not noticed the same behaviour in R18-20.

  3. Redshift seems more responsive in R21 than previous versions too


I’ve only tried the demo, but 1,2,3 navigation seems to work fine as expected here. I’m using a Wacom tablet though.


As always, twitter seems to be the best place to see hints of new R21 stuff!


Well, i miss builtin help system :sob: :face_with_head_bandage:


Yeah there are some Maxon decisions that make me think well if they think anything about.

In less worse news here is the Field Force tip

unfortunately it seems things are just haphazardly glued too complex in terminology/language for discovery propose. most of things in that tutorial are obscure, non discoverable… “opacity??”

There is no system in place but particular rules.