R17.053 TRS and upcoming R18


#1

after installing the R17.053 update i really hoped to see some of the bigger issues in TRS having been addressed…

it appears none of the production type issues have, duplicate frames still are being assigned, the TR nodes will still all go offline in TRS if more then 20 nodes are active when a big job is started (seems some timeout thing in TRS)

the only fixes i notice are that the web interface of TRS has the cosmetic scaling/scrolling thing fixed - although with longer jobs i can still get safari to not have scroll bars on the clients side so i can’t see all the render nodes

and the TRS web interface does seem a bit peppier in response

really had hoped that whatever R18 fixes in TRS were pushed back to the R17.053 update - but sadly those main issues still exist so i don’t have much for hopes as to these issue being fixed in R18 at this point either

was surprised to not see any thread on R17.053 even being released (or did i miss that? i looked back quite a few pages and did not see one) and not anything on any of the bug fixes or new issues from it either…

has everyone just given up on R17 and waiting patiently for R18 to hopeful solve all issues or bugs?

oh, one unexpected surprise seems somehow R17.053 also breaks the X Particles ability to render with a saved internal cache… not sure about external caches yet or if it is more in how the cache is saved in the file - just a note though for those users of X-Particles and the new R17.053 update


#2

oh and the fact that the TRS web interface still does not show the frame range of any JOB unless the job is RUNNING! STILL exists… this is one of the biggest annoyances to me… ugh.


#3

Unexpected by us, too :frowning:

It’s killed external caching, as well as internal. It has nothing to do with file saving, it’s down to the loss of a critical function in the API due to a bug fix MAXON implemented. We have a solution in testing right now. Sadly, MAXON are unable to fix the problem they’ve introduced.


#4

Thank you for saving me the trouble of creating a thread to ask if TR/TRS was up to snuff and if I should upgrade. I shall finally pass on MSA and sit back and live with r14 and mostly working NET Render. (I say mostly only because at the end of a render job, instead of allocating frames to available nodes, it starts to double them up until the very last frame, which exponentially adds to the render time. But, hey, it renders all the frames as expected)

Funny that I called Maxon today to see if they could provide reasons why I should keep my MSA having not use R15, R16 or R17 due to the TR issues and they tell me they are unaware of any of the issues I mentioned other than TR/TRS is better than it was in R15.

I feel like every 6-7 years of 3D software investment, there comes a day where I’m stuck in the middle and it would cost a fortune to upgrade and be current with marginally more functional software than I was using.

sigh…r14 for the win! Sorry to be so negative, but I was really hoping for the day of a suitable, dependable replacement for NET so I CAN be current and use all of the fun new features.

I’m happy to note that X-particles 3.5 works great with r14 NET, so I at least have that going for me into the future…


#5

i was kinda hoping someone would post some fixes in 17.053 that i’ve not noticed… so far in TRS the ones that are production issues seems to still be there as noted, but maybe someone noticed something that “is” fixed?

the GUI html changes really shouldn’t have taken anymore then an hour or so would think - it was pretty minor stuff that seems fixed - so not sure what maxon was saying the fixes were in the read me for 17.053

just really dashes hopes that R18 was going to be as solid as NET was… but i still have a glimmer of hope in that ever optimistic side of me (the one getting stomped to death at nearly every turn lately it seems)

anyone else install 17.053 and see something fixed or improved?


#6

Eeek! Glad I saw this before updating all my machines. I have a project about to go into production that will rely heavily on xParticle cache data. I would have been hosed. Fortunately it still works fine in 17.048

On a side note, I have a couple render nodes that are still at 17.032 and i want to get them to 17.048. I cannot find a way to download the now-legacy installer. Any suggestions?


#7

hmm well that’s odd maxon does not have older updates available…

but 5 seconds of looking at the link and change the two numbers and here you go

http://http.maxon.net/pub/r17/updates/c4d17048upd.c4dupdate.zip

better grab it while you can - and to run this you use the manual install option on the app etc

dann


#8

Right on! Thank you Dan!


#9

I’ve been pushing the engineers to update to .053 from .048 with hopes that it would fix most of the current annoyances but I see it’s better to wait for R18 instead. What a nightmare.
Last night I queued 12 renders before going home. This morning just four of them were finished, the rest were stopped. But nobody had stopped them. Zero reliability.

And the X-Particles thing.

I wonder how different can R18 TRS be from R17.053. My guess at this point is they are the same thing.


#10

I got burnt by that XP/R17.053 bug too
Right in the middle of a project.

The joys of 3d animation. :slight_smile:
Its never a boring job.


#11

I don’t see any improvements. But reading the update details I was not expecting much either.
I have the Impression, that maxon concerns TRS to be final now. I don’t think that we will see much improvement on it for a long time. I didn’t see much in the R18 announcements about TRS, too.
That is sad. Not only is TRS less reliable then NET but it also has no features (besides DR) that would make NET look old. There is plenty of room to improve. Lot of features that could make TRS superiour to NET.

On the other Hand concerning the license that comes with TRS, Maxon most probably is not up to develop TRS to a netrender workhorse. They just what the netrender feature in their List and hope that people stop complaining about it over the time.


#12

One nice little addition—the start job button stays grayed out until the c4d file is uploaded and ready to go. No more premature starts leading to a fail.


#13

Yes, but again even this little feature is implemented with a bug. Sometimes TRS doesn’t realize that a project is already uploaded and the start button stays grayed out till you click on the project. Then it gets updated and TRS realizes that it is good to go.


#14

Can only hope it gets better…

Because Maxon’s Cinema 4D’s Team Render is such a pleasure to work with.

I setup 2 machines yesterday to do a background render (only 2 because it’s kinda warm at the moment with 24-28C in the room), wait for the final part of the render to start, check team render machines which it tells me everything is ok, take a good look at the picture viewer, 2 orange boxes and 2 green boxes seem to progress nicely and I go happily to bed.

Eight hours later I get out and anticipate a finished or near finished render as everything was working last night, right?

Well the 2 braun boxes are happily trucking away, the green ones however though are right where I left them 8 hours ago! Nothing indicates anywhere that the second machine stalled, everything seems to working just fine.

http://i.imgur.com/v5FSIbd.jpg

So I save the part that got rendered, shut down C4D, reboot because I need to check something in bootcamp, reboot back in OS X, log in to the other computer (the one from the frozen green boxes) and try to quit the team nightmare render there.

“Are you sure,” it says, with an Jarvis (iron man) like voice, “are you sure, as I’m currently in the progress of rendering something for your boss.” And then refuses to quit when I quit it so I need to command-alt-escape it.

When will this nightmare end? /o\


#15

For the record I tried the X-Particles workaround that someone suggested in another thread and it didn’t work for me. I changed the cache mode from Sync to Playback as told but it didn’t render in .053 anyway. Maybe some of you guys could give it a try too.

But aside from a broken plugin, the fact is that we were using more reliable render farm software 15 years ago.

A complete re-write is in order, IMHO.


#16

Theres been a lot of talk about using the xp cache playback mode to get caching to work.
Tried it here and rendering on the farm, but no partcles. :frowning: Is there a trick to get this working? Does it need to be external caching rather than internal?


#17

FWIW
xp playback cache seems to work as long as you dont save file with assets from c4d directly to TRS (my usual workflow)

Copying your job folder with cached c4d file inside seems to work. phew.