r16 and libmmd.dll missing


#1

Hi,

i’m having a strange problem after making the c4d r16 update.
Every time I try to open C4d r16 after a computer shut down, I get the error “cinema 4d.exe - system error // The program can’t start because libmmd.dll is missing…”.

I have installed it 3 times already (3rd day happening). Have this happened to anyone else (i’m in Win 8.1)?

Thanks
Daniel


#2

libmmd.dll is from the Intel XE 2013 Redistributable library. You should use Update 5 (2013.5.198) but unfortunately the link on the intel site to directly download the library is broken.

When you install C4D, are you seeing an error that says something like “Key not valid for use in the specified state”? Apparently a recent Windows hotfix is causing issues with the installation of these redistributables. You should be able to install them by removing that hotfix as described in the link, or by deleting your Crypto folder (in C:\Users<username>\AppData\Roaming\Microsoft) and allowing Windows to re-create it. Since the Intel redistributable can’t be downloaded directly, just try re-installing C4D again after deleting the Crypto folder.


#3

Hi Rick,
thanks for the help.
I didn’t get the “Key not valid for use in the specified state” error. But deleting the Crypto folder seems to solve the problem.
Restarted the machine 2 times, and r16 is opening normally without the missing dll error.

Many thanks for the quick reply.
Daniel


#4

Great! Glad that worked.


#5

I’ll note that I had the same exact issue with the same DLL on Windows 8.0, and a reinstall fixed it for me.


#6

I was having the exact same problem Dangomes was having and doing the above procedure fixed the issue for me.


#7

being my Windows7 don’t have that DLL

ok so apparently the only one place on the entire internet that you can find that ONE file Intel XE 2013 Redistributable library Update 5 is at intel and they broke the link to it

so after circles trying to report it on intel’s site i started looking for that installer somewhere… found the same file but as an SP1

installed it and TR16 launches fine - but the second the online updater pops up it crashes TR16 now… cripes… this is the shit that literally drives me insane.

can’t maxon just put a link to update 5 somewhere? or have a phone number to someone at intel that can tell Jennifer J her link is broken… sooo stupid. it is 2014 nearly 2015 and this is like internet 1980’s action

so i uninstalled SP1 and installed the Update 4 and the TR16 launches the same but again crashes when the online updater pops up. i’d just turn that feature off but i’m more concerned that on this test machine it will create instability that may affect stability of TR (would i even notice ; ) not sure)

but this is nutty. do i have to install from the DVD on every node just to get that missing DLL? or can i just grab the ONE DLL it reports and use that? (i feel that the whole Intel XE 2013 Redistributable library would be probably safer to have all the corresponding components)

just so stupid to have to go through this.

dann


#8

ok i’ve apparently resolved my missing DLL issue

but my TR16 with all my plugins was still crashing upon that first appearance of the auto-update pop up

so i pulled all plugins out etc and now it launches fine and the auto-update appeared with no crash

just FYI, maybe i can find out what did it or not, but just wanted to update

dann

EDIT - ok with VRAY 1.9 it launches fine, but when i tossed all other 39 plugins in (well 38 not counting VRAY) it again crashes upon launching the online updater

will try to find the plugin causing it and post back. or just turn off the auto-updater if my patience gives out


#9

Hey Dan,
On page 18 of R16 Installation Guide EN.pdf (a PDF file found in the install folder after mounting the install .iso) it says…

Tip: A new installation of Team Render Client is not required on each
individual computer that will be used as a client. Simply manually copy the
existing “CINEMA 4D Team Render Client R16“ installation directory in its
entirety onto each computer you want to use as a client.
Note: The additional libraries required for Windows operating systems
(vcredist_x64_2005.exe, vcredist_x64_2010.exe, vcredist_x64_2012.exe,
w_ccompxe_redist_intel64_2013.5.198.msi) are not included and must be
installed separately on the other computers!

I tried this method to install our many rack servers, sadly it didnt work for me, but, re-running “The additional libraries required for Windows operating systems” noted above solved my missing DLL issue.

These file are found after mounting the install ISO

Hope this helps!


#10

thanks gary, yup all set with the DLL issue… now the plugin issue. yay!


#11

TurbulenceFD_C4D_v1-0_1365

with this plugin installed if the auto-update pops up on it’s own or if i manually try it the online update it will crash

dann


#12

ok more weirdness… on another client (this one installed with ISO) i CAN check the online update with TFD installed and no crash

but when i quit TR 16 Client i get the OS pop up error

Cinema 4D Team Render Client has stopped working (and options to close the program etc)

if i remove TFD when i quit this TR16 client it closes with no error

and the other one that crashes when the online updater is tried, that one closes with no error at all.

but still TFD 1.0 1365 is the common plugin that if i take it out the issues on both render clients goes away

dann


#13

aaannnnnnnnddddd… there is an update to TFD 1.0 1367 that fixes the two different but similar issue on both clients

sheesh… the insanity of plugins. i should know to just go and manually check every 45+ plugins i have at every single developer web site every day for bug fixes/updates/announcements to avoid these issues… :surprised

if only, only there was something easy like sending a message to the customers of your projects to let them know of a bug fix… maybe some day someone will invent something like that. :rolleyes:

so, sorry for wasting your time and mine with this issue.

dann


#14

hi dann,

thanks for your 1000 test runs
i had these annoying things too the last 4 days
totally annoying. i can´t get it installed as there´s no dvd drive on the servernodes and copying don´t work as for this dll problem. i tried to create an iso image within bootcamp and copy that image to the server node, but even the image can´t be opened. do you know if there is an installer for windows which one can download? no reply to this question from the maxon support until now.

best regards
jens


#15

email me at dann@darkskydigital.com

i will try to help

dann


#16

You can grab the installers for all the redistributables from within the Installation Disc (or ISO) - it’s in /bin/data/redist

I’m not sure if we can post it anywhere for download, but as long as you can open this disc on any windows machine, you should be able to pull out the file you need.


#17

Hi Rick, thanks Dann I could find those files! I made all files visible on the mac finder and copied them to the windows slave. that worked now! Thanks! :slight_smile:


#18

useful thread, removing hotfix KB2918614 fixed this issue immediately, no re-install required


#19

Yup, useful thread! Thanks,

installing the files from: iso at “bin\data\redist” got it running!

cheers,