Question about roulette animation.


#1

Dear all,

Recently I restarted 3ds max again, I used 3ds Max trial version 2018 trying to make a roulette spinning animation like this one: https://youtu.be/q0wJ9-2IVGQ
I’ve set up the ball and the wheel’s rigid body: ball: Dynamic, Wheel: kinematic, key frame the wheel spinning for 100 frames,
when I active the massfx, the ball is falling to the wheel and just stay in the contact place, it doesn’t spin with the wheel, I was wondering if I should set up them constraint?
I was google for tutorial but couldn’t find the info I need.
Please if anyone can help will be amazing.
Cheers.

Limi


#2

Hi all,

After few tests, I found the wheel’s rigid body shape can’t not fit the model properly (I’ve try different concave setting) cause the ball floating above,


and I found my model’s Friction may not be right setting, now the ball does spin a little, but not the result I want.
If anyone can point me some direction will be appreciate. Thanks.
( and 'm going to try using path animate and set the ball as kinematic. maybe will be another way?)
Cheers.

Limi


#3

you have to use Original

Not Concave
Not Custom


#4

Hi Vusta,
I did try to change to original,
but even when I change it, the ball still floating…
and, if I change it to static, the ball doesn’t effect by the wheel spinning ( I saw an article mention about the dynamic object just effect by kinematic but not static object??)


#5

the complexed roulette spinwheel should be Original, Static, Regenerate (if you make mods as you go, must Regenerate to get the ‘hull’ updated)

for the ball, shape should be Sphere. It should be kinematic. So say you keyframed the ball
moving (being thrown) from frame 0 to 5, set Until to 4.


#6

actually, i think the spinwheel should be kinematic…throughout the entire sim…ie. you’ve keyframed it’s rotation…

sorry, it’s been awhile since i last used massFX.


#7

hi Vusta,

I’ve try both and the animation still not right, and when I set them both as kinematic, the ball stop the position in frame 5 and didn’t simulate rest of frame,
just found when I set up the ball as dynamic and the wheel as kinematic, it does works but the ball seems start been effect after few small bumping,
still trying to figure out if it’s setting problem or rigid body problem.
cheers.

Limi


#8

oh i see now…if the object is Static, then you can set to Original…but if it’s Kinematic…the Original option is gone !!! Bummer.

I’ll have a closer look.


#9

righto, here’s a working roulette wheel…

https://1drv.ms/u/s!AvgNse7E8aaygxPa-iAV4m8wlR2E

  1. any object you’ve keyframed…they have to be Kinematic
  2. if an object is Kinematic, Original (ie. the original mesh shape) is not available…so you have to use Concave. Then you have to Generate in Physical Mesh Params (not the Generate Selected Physical Shapes). Play around with Mesh Details…you’d think setting it to 100% is the best
    but…not necessarily so…in my example…I’ve got mine at 95% for the spinwheel
  3. the ‘ridges’ you see I’ve setup as Kinematic and since their shapes are simple boxes…I could get away with using simply Box
  4. The ball is Kinematic, keyframed from 0 to 3, therefore, set Until to 2…so at frame 3, MassFx takes over the sim.
  5. normally you’d throw the ball onto the rim and let it roll down…but I got a ‘nice’ sim throwing to the centre…so I left it as is…
  6. the outside walls are not moving so they are Static.

I don’t know if you can make yours work cos your spinwheel is one mesh…it might be too complicated for massFX to handle, you might have to fake
the ridges with boxes like I have.

ps: I fking hate gambling and casinos…they’re just a bunch of a*holes, those scums should be wiped off the face of the earth.


#10

nicer version here:

https://1drv.ms/u/s!AvgNse7E8aaygxVGDnNLbv5QsSI7

//youtu.be/Bovd6apYGds


#11

Hi Vusta,
Wow that’s cool, I might try to change the setting and the models again and try ur way see id they’re working,
so I guess maybe I need some invisible rigid instead the real wheel for helping the ball sim its movement.
Thank you so much!
Will update if it’s working with my model.

P.s, I do not like scum too, and all those shit things are because ppl have no self control and greedy. I don’t mind if ppl play for fun.
(and the good thing is u’re in Aus, even though there has lots of casinos, but also u have plenty of natures all around u, what a amazing country :slight_smile:


#12

Hi Vusta,
I 've seen ur model (big help, truly thank you!)
Seems like I have to separate the wheel’s each part as different objects for correcting the physical material,
rebuild the model now, will see if it’s working after all separately. update later.
Cheer.

Limi


#13

Hi Vusta and all, me again,

I tried to use ur setting in my model but it’s said the model has a plugin.

Cause my max doesn’t have any plugin, so I was wondering if possible use default system to build it?
I’ve change my model and use separate poly to make physical material but it becomes more funny sim. oops.
so, if u want to help me have a look the model?
https://drive.google.com/open?id=1QUmZHGF_Zr6S7LV7wABXdtP3T73RB6_k
Anyway still trying to figure it out.
Cheers.

Limi


#14

nah…it’s just a spurious message re massFX…I did the file from scratch…no 3rd party plugins…
i think it’s because you haven’t got update 3 (2018) applied…but it should still just work…


#15

Hi Vusta,

Yes it 's working, I 've try to put the setting to my model but somehow the result looks still wrong in my model, that’s why I thought it has plugin.
I’m trying the setting in different model now.
hopefully it’s working.
Really thank you a lot.


#16

i’ll look at your mesh tomorrow…could be because yours is spinning TOO fast…have you enabled Use High Velocities ?


#17

I was set the high Velocities active but I don’t know why it’s not working,
and strange thing is I couldn’t constraint my new wheel’s part to the point helper, (I tried open a new file and just use simple box but still the same…)
Will be appreciate if u have time tmr :slight_smile:


#18

hmm…looking at your scene now…the problem is you have Use Ground Collisions on…that is an invisible ground plane hence the ball is floating…disable it on the 1st tab


#19

here’s the fixed version, I used the earlier file.

https://1drv.ms/u/s!AvgNse7E8aaygxeggiqj3AeYoJB1

There is no need to have massFX on the numbers/Text so I’ve turned it off.

I also upped the angle on the outer rim cos it was too flat and the ball might not roll down…but it’s up to you with mods, also I raised it a bit as might get stuck on the middle ridge. Disable my Edit Poly to see. Remember, any mods you make, must Generate again in Physical Mesh Params


#20

Hi Vusta,

I see the model, thank you so much for fix it, I’m trying to build a new one and follow ur rules.
Can I ask you about the Ground Collisions? not about the model, but I want to understand,
so, for example, if the model don’t need a ground in the scenes, usually can set it as don’t use is that right?
Thank you again for helping me solve the problem.
Cheers

Limi