Problem with fluid sim


#1

Im very very new to fluids and im trying to do some rising smoke but I am facing a couple problems…

I get the feeling that the fluid is not reacting correctly to the texturing im applying. Another thing is that i get a few wisps on the sides that dont look good and shouldnt be there. Finally, the fluid only renders correctly with the fluid’s built in lighting, when i try to use a directional light with raytraycing on and enable “real lights” it gets washed out.

See attached scene to better understand…

Thanks

Alex


#2

Hi Alex,

I believe that a lot of it has to do with the fact that you are simming a somewhat low res fluid container, while relying mainly on texture for detail. Unfortunately, I am afraid that for a fluid of that proximity to camera; you may want to consider simming it at a much higher resolution. Those little “whispys” are a result of the texture noise “eating” away at your density in less dense areas. I try to sim at a higher scale to res ratio and avoid textures if possible.

Hope that helps,

~Ilan


#3

Yep, thats caused by Texture Opacity, you shouldn’t use texture with big scale, it will allways eat your fluid. Upress you fuild and remove the texture (wich will also decrease render times).


#4

gotcha! thank you both… I increased from 100 to 250 (base rez) and its looking better… I’ll leave a render overnight at 400 and that should help. Thanks!

Alex


#5

Whats wrong with the lighting though…? why cant i use real lights?

Alex


#6

For real lights you must enable raytraced shadows on the light to get self shadowing of the fluid( in mental ray… maya sw will self shadow without that being on).

Duncan


#7

That’s why it is so strange and frustrating… I did enable raytraced shadows on the light attrs, enabled raytracing in the MR render globals and the rendered result just looks wrong… I even tried a new light to see if the one i was using was broken or something, still no luck. Would you mind taking a look at the scene? Thanks for your help!

Alex


#8

Ok sure. Where is your file? Also I assume you only have the 1 directional light in the scene? The direction should match the direction of the internal light for it to match( the light direction will of course have a significant effect on shading).

Duncan


#9

Try segmented shadows.


#10

Here it is! Thanks for taking the time to look at it

Alex


#11

Yup… One of the first things i do when working with fluids.

Alex


#12

I think you want to make the ambient brightness zero. At any rate the ambient diffusion does not work well with autoResize(a bug), so it is good to either make ambient or ambientDiffusion zero. However it is not that high, and the renders I’m getting from your scene do not look too washed out, although perhaps this is what was bothering you.

Duncan


#13

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.