Problem with FCurves and Timewarp


#1

Im just trying to reverse an animation using the FCurves and Timewarp, but for some reason it does not work. And it seems only a few curves show up, when i select the entire set of effectors and hit Apply. What am i missing?

See short video below. And hope someone can answer this question.

//youtu.be/thsGVlHvPAk


#2

It seems in MoBu2016 (maybe earlier too), once i have all effectors selected, i need to click the individual axises which has the (1/xx) in front, that will select all of the curves.


#3

well, that was almost correct. the above approach works if i select the skeleton nodes, but not when i do the same with effectors of the rig. Am i missing something?


#4

i see you posting some pretty thorough questions here…

personally i don’t use Motionbuilder enough to give you the answers your looking for, but it’s nice to see someone working through these issues.

thanks!


#5

Maybe you should put the animation on a story track and timewarp it there? :slight_smile:

That should be way easier.


#6

Huh, how can i timewarp in Story? I only found the scale tool to do something similar, but since i have to break up sections and scale them individually i tried to see what i could do with timewarp for the FCurves. Also if i only want to timewarp say a Hand, is that possible with Story?


#7

I agree that Story is the way to go, you can break up sections using the razor and then scale de parts as you want. You can also add a track to body parts like the hands, just read about the story in the help and you’ll see what you are able to do there, it’s an amazing tool.


#8

Hi,

If you’re using Timewarp in the FCurves window you must select all the objects and all the Transformation channels on those objects you want to apply the Timewarp to.

So in your case:
Left-Click in an empty area of the Character Controls window to select all the FK and IK controls
Left-Click Select the Translation and Rotation channels in the FCurves window
Enable Timewarp Display
Create a Timewarp
Apply the Timewarp to the selected channels
Edit as you have been doing

As other have suggested, you can also use the Story tool to reverse the animation:

Turn on Story: Turn on Story mode in either the Transport Controls or the Story Window.
Create a Character Animation Track: In the Story window Right-Click in the Action Timeline and select Insert>Character Animation Track from the pop-up menu.
Assign the Character to the Story Track In the Character Animation Track, select the character’s name from the
Character drop-down menu.
Insert Current Take: In the Action Timeline of the Character Track, Right-Click and select Insert Current Take from the pop-up menu. This adds the animation in the current take to the Story tool.
Frame Clip: Select the clip and press “f” to frame it in the Action Timeline.
Reverse: Select the clip containing the animation you want to reverse. In Properties>Timewarp make sure Enable Timewarp is active and click Reverse.

I also have a tutorial explaining more about the Story Tool here:

http://mocappys.com/using-motionbuilder-story-tool/

Good luck,


#9

Thanks for your reply Mo,

It’s been a while since i played with this issue, but i’ll be sure to review it again once i get back to mocap cleaning, hopefully sooner than later. Right now im stuck with some other stuff. Anyway what i recall from my issue was that when clicking in an empty area in the Character Control didn’t work if i wanted to use the FCurves (so i mean not the Story approach). Even when selecting all the individual Curves, they didn’t show up in the curve window, as they do when i just select the skeleton nodes with the same curve data. I hope i make sense, otherwise i’ll post a video showing the issue more clearly.