Problem with ALL my 3D apps


#1

I’m having some major problems with every single 3D design app on my comp (including MAX 6). They all crash on startup… It’s very perplexing indeed, and i’ve had no luck with Google and various knowledge bases. They were all working fine forever, never had any problems and then a few days ago they all schized out on me and ceased to function. it’s ONLY with 3D design apps. All my 2D apps (ie: Photoshop etc) and 3D games (HL, UT2k4, etc) run flawlessly.

I reformatted my HD yesterday and reinstalled everything from scratch (Windows, all apps etc.) and they still crash on startup. I’ve tried every Nvidia driver in their archives that supports my vid card. I got all the Windows updates, etc, and still no dice. Ran MEMTEST and my ram is fine. I’ve troubleshot each app to no avail.

Apps i’m using that won’t start:
Valve Hammer Editor 3.5b (aka Worldcraft
3DS MAX 6.0
Softimage XSI EXP for HL2
Milkshape 3D 1.66a and 1.71

Just to check i also downloaded Wings3D and even it wouldn’t run. I’ve been using these apps for a while with zero stability problems until the last few days.

My specs:
XP Pro (running SP2 atm, but tried SP1 only after reinstall, then tried to see if SP2 would fix it)
AMD Athlon XP 2000+
768 Mb PC2700
FX-5700 Ultra (Drivers: 56.72, but I tried the 67.xx’s too)
Extra junk: All the latest stupid Runtimeslike VB, DotNET, etc… Latest AGP driver, updated BIOS, ran DXdiag to check for problems

Anyone ran into a problem like this and have any possible solutions?? My computer is half useless like this because all i use it for are 3D design, and 3D gaming. And my old comp is too crappy to run 3D apps, it can barely run Photoshop (Athlon 550 Mhz, 256 Mb PC100, TNT2…)


#2

you should call the support. sounds very strange, especially if they worked before.

but we cant help you if you just say “crash”. do they freeze, or do they dont even open, or do they disappear after being started? and make sure you check out the logfiles. i dont know max or xsi, but im sure they log somewhere.


#3

Check your Opengl, revert to older drivers


#4

I checked the support for both, 3DS Max 6 support was good but couldn’t solve it. And re: Crashing, they ALL crash on startup. 3DS begins to initialize than just crashes out and gives the old “Send Error Report” report. In the Event View it says it caused an exception in KERNEL32.DLL. Ditto for XSI basically, it opens and initializes, but at the end of the initialize crashes out. Same KERNEL32.DLL error. Milkshape 3D won’t even initialize (although it did once magically but crashed when i tried to open a file), but the event viewer says no specific errors, just says MS3D.exe crashed.

I took these “pearls” of wisdom the the MS-knowledgebase which was useless. It just verified that XXXXXX program crashed cuz something messed up and said i should send an error report but had nothing to help fix the problem.

I figured it was a WinXP issue (since KERNEL32.DLL is a Win file im pretty sure) and hoped a full format/reinstall would get rid of it.

Possibly, first off tho. TOpenGL drivers are in my forceware already. I have an Nvidia FX 5700 Ultra AGP, and i’m running the 56.72’s (i tried almost every driver set in the Nvidia archives that supports the FX 5700 series, from teh 5X.xx’s to the 67.11’s). So i basically am running on older more proven drivers ATM. I’m 90% positive they include OpenGL 1.5, is that the latest OGL version??? Sorry to sound n00bish but where might i find earlier OpenGL drivers, or different OpenGL drivers period. I’ve never really had to bother putting them in separately they’ve just been packed in with Vid Card’s driver set.


#5

im new to 3ds max 6 and i have the same problem as you… my 3ds max 6 worked for about one day now i get the send error thing. iv updated everything from windows xp and 3dsmax. i also have newest drivers. my specs are.

windows xp sp1
geforce fx 5200 ultra
512 ddr
athlon xp 2600+


#6

i saw this on a site but didnt work for me. run max with the “-h” command. didnt work for me but… eg. C:\3dsmax6\3dsmax.exe -h


#7

okay i worked out something… when i delete the plugins folder it works??? is the plugin folder neccecary?? also wat if i put in recycle bin then open max then restore while in max.


#8

i found out something new… i dont think it had anything to do with the opengl software or direct 3d 8.1 or 9 because i tried all these and they all worked but ONLY when i deleted these files it works. they are all found in the plugins folder.
rct_constraints.dlo
rct_dashpots.dlo
rct_motor.dlo
rct_plane.dlo
rct_spring.dlo
rct_utility.dlo
rct_fmvdefmesh.dlo

i did this by seeing which ones it got stuck on while loading. i put them all in a seperate folder and if i try adding any of them it crashes…


#9

That fixed my MAX 6 for now. All the others are still inexplicably bugged but oh well, at least i can model now =)


#10

I have the exact damn error too!!!
Moving all rct_? file to another directory does half trick, max starts but it doesn’t work properly!

Anyone has resolved this??


#11

Just a thought, but since it used to work just fine, and it still did it after a fresh reformat, hardware is not necisarily out of the picture here…

Maybe something went bad? Bad PSU video card… ram? maybe you should check :stuck_out_tongue:


#12

hello the guy I have the same problem and I think that I have the beginning of the solution. I desinstallé 3ds after I reboot my PC and I reinstallé, I executé 3ds then the studio max demarré without problem, but when I’v reboot the PC I had the problem of RCT _…, then I took the following steps I removed a valeure in the base of register in hkey_local_MACHINE that of blackbuner which shows the way of plugin of 3ds and I installed stuido max in the second partion (D) after I did not have a problem, but exactly I do not know the solution of this problem
? maybe you should check :P[/QUOTE]


#13

As it checks through plugins at startup.

Could this be a change introduced by an update to your antivirus software?


#14

This may not be the solution, but it may be worth looking into. I had a problem where nothing 3D would work, but all my 2D stuff worked just fine. I would get crashes and sometimes even the system would lock up or reboot. It was driving me nuts. Then I realized when the problem started. I had been inside the case and I must have touched the video card somehow. It was not perfectly seated in the AGP slot. It looked like it was, but it was able to wiggle just a little. So, after shutting down the PC, I removed the video card, made sure the slot and card were dust free and re-installed. Since then the computer worked perfectly fine in all 3D apps.


#15

When you say you reinstalled windows. Did you just install over the top or did you wipe the drive first? installing over the top is likely to keep newer (faulty?) drivers.

Heres a test you can do. Download the c4d demo and run it. While loading the app, hold down the shift key, this will turn off the graphics card opengl.

Assuming its all working at this point, go to the general prefs and select the viewport option now change software shading to opengl and see what happens. At least this will determine whether it is the 3d card which is killing it.

If it turns out to kill it, then uninstall your nvidia drivers, download NVcleaner and run it in safe mode (press F8 while booting) then install the latest official nvidia drivers.

Good luck.


#16

A bit late. I was having the same error just now and was reading though. I checked the system logs and seems something was trying to change system files about the same time max started screwing up with the rct_* files. Did a virus scan (win32.parite.b) and that guy was all over the place. Repaired all the files and max started working fine again.


#17

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.