PowerPreview: High-Quality Nitrous Preview Tool


#41

Hoping someone can shed some light on the problems that I am having trying to get PowerPreview to work.
I am trying to try to capture a Nirtous viewport animation using the defaults settings. No matter what resoultion I set in the settings of PowerPreview the video comes out at 720 x 480. I have checked the general render settings for max thinking that there may be a conflict, but there is none. Regardless of the incorrect resolutions the video that actually renders doesn’t have any different quality to the normal max animated sequence grab. The shadows are speckled etc like ach frame isn’t being solved or however you would describe the process.

Edit: I should say that I have tried with 2012 and 2013, and the same problem persists.

Thanks.


#42

I’m not sure if this helps, but what format are you using to create the video? Some formats like Quicktime DV Pal will have the resolution locked.

Are you using the Power preview ‘Make Preview (RGBA)’ option to make your video? If so, set the visual quality you wish in Power Preview, then when the ‘Make Preview’ window pops up, choose ‘custom file’ from the bottom of the window and render to PNG images. The quality of the image sequence should be as good as you can get it, and will have an alpha channel if you need it!


#43

Thank you Michael for the response.

I wasn’t using the MakePreview option for my renders no, doing so has solved the resolution issue that I was having, which is good. Unfortunately the quality is still isn’t representative of what is in the viewport, which I am assuming is the idea. Using PNG format, shadows are still speckled for instance and everything just looks a bit fuzzy, the quality is no better than the standard max create animated sequence method.

I have tried upping the time allowed per frame thinking time wasn’t being given for it to solve the scene but it hasn’t helped.


#44

What Version of PowerPreview are you using ?
Does PowerPreview actually take it’s whole time per frame you set ? And do you see the viewport picture getting improved during that period ?
Another thing you might try is disabling the “Iteration Limit” button below the time slider, just in case you have that enabled. Maybe your scene causes an unusual ammount of redraw iterations, which could be a cause for a low quality when the limit is enabled.

Finally it might help posting a screenshot of your PowerPreview settings ( with Nitrous and Output options rollout expanded), best with the whole viewport+ it’s content visible…

BTW: does progressive refinement/display work at all in your scene and is it enabled when you start your preview ( should auto-enable but one never knows …) ?

EDIT:
and before i forget - due to the nature of Nitrous, you are not able to switch to a different application during preview creation, because that would cause Max stop refining it’s picture, PowerPreview would simply wait for the set period but Max would have not improved the picture quality. Thus Max has to be the foreground app during preview creation all the time. ( It’s in the readme and is a 3ds Max limitation)
Max 2014 has a maxscript command to toggle on Nitrous background rendering, but it’s currently not implemented in PowerPreview ( as far i remember :slight_smile: )…
see my post here
http://forums.cgsociety.org/showpost.php?p=7581791&postcount=23


#45

Hi spacefrog,

  So I am working in Max 2012, using version                      0.70b - Beta 8. I have set the time to a variety of values and find that the time taken per frame is always around the 1 second mark, perhaps less. I have tried the render with the iteration checked and unchecked and not found any difference so far.
  
  When you say does progressive refinement work in my scene, are you asking whether for example when I move the camera does the viewport re-evaluate the scene and settle into a higher quality? When I open the PowerPreview script, neither iteration or progressive display buttons are blue by default, which I am guessing is the on state?
  
  When I am making the preview, I do not click on another app, so I am assuming that max is running as the foregorund application? Or do you mean, you cannot have anything else open?
  
  Here are a couple of images, hopefully they are what you are wanting. I have just posted a small section of the viewport, I was worried about getting in trouble to be honest, hopefully that area shows what I mean.
  
  Struggling to get the forums picture tool to work, just results in broken image thumbnail for some reason, so just provided links. 

Left is viewport, right is capture.
http://www.flickr.com/photos/66411533@N03/9084622794/

Settings
http://www.flickr.com/photos/66411533@N03/9082403597/

  [img]http://flic.kr/p/eQM4Ru[/img]
  [img]http://flic.kr/p/eQzGat[/img]

#46

Simple:
You have are using the Max internal make preview with a quality setting of “1”. ( The slider in the “Make Preview” render options. Quality “1” is the lowest quality, increase it at least to 16 or higher ( but that takes longer of course ). The Timebudgetslider is irrelevant in that mode…

Ahhhh - wait:

I remember, Max 2012 is not able to improve the quality of the internal make Preview ( which you are using in the screenshot ). This is a Max 2012 limitation, Max 2013 and upwards allows you the increase the quality level using the slider, hence it is disabled in Max 2012

Conclusion: in Max 2012 you are only able to get refined Preview using PowerPreview’s own “Grab Viewport” method. There was no other way at all to render out progressively refined Viewport quality in Max 2012

And i would recommend updating to the latest PowerPreview version, this still is compatible with Max 2012…


#47

I noticed the bar when I first tried using the script, unfortunately it is not selectable for me, I thought that was intentional to be honest. It is locked in it’s position. How do you use the slider?


#48

Read my post again :
it’s disabled when PowerPreview is running in Max 2012 by purpose, because Max 2012 does’nt allow to change the internal preview quality. Eitehr use the other method PowerPreview provides ( “Grab Viewport” ) which allows higher quality, or change to Max 2013 or higher


#49

Apologies, I don’t know if you edited your previous post whilst I was replying, but the second half of your post wasn’t there when I first replied, making it redundent. I am getting some decent results rendering to PNG at the moment using the Grab Viewport method, although not touching another app whilst it’s running is a mighty task :slight_smile: . Im sure before today I had access to Mpeg4 and xvid codec when choosing avi as output, which seems to have disappeared now, but nevermind looks like Ill be doing some after effecting :slight_smile:

Thanks for the help.


#50

Good luck with your project! hope you post an update later on. Liked the style from what I saw in your screengrab :slight_smile:


#51

Iteration Limit is not working for me. Whatever value I set, it always advances to the next frame by the time limit. I don’t want to use the time limit since my scene takes a while to generate at each frame.

When I switch to Make Preview, it does use the Quality slider. But I want to use the Grab Viewport method.


#52

PowerPreview always advances when one of the two limits is reached first, be it the Iteration limit or the time limit. So if you want be sure to hit the iteration limit, drag your timeslider to the longest timespan possible. This is 90 seconds currently

If you Viewport iterations do not reach their limit within this timespan, it seems i underestimated people’s scenes complexity :slight_smile:
Another thing is that Nitrous does not refine forever, it has some hard iteration limit internally, but i do not know the exact number. I guess it’s somewhere in the thousands, so my 8192 upper limit is a rough guess of that…


#53

Then it would be great to have an unlimited option for time (or at least about 10-15 mins) as sometimes generating some objects can take time. I am talking about objects with several million polys :wink:

Or at least give a choice, either time or quality limit (or both).

That is the only thing for me that keeps me from using it as it’s better than the build-in previewer :slight_smile:


#54

Curious: are you using it for stills or for animation previews ?
I can imagine the highest timelimit being hit to early for large stills in complex situations so i think rasing the max timelimit would be the best. Or better allowing to enter a manual entry in the textfield with a far higher limit, otherwise the timeslider would become useless in quick preview situations…

In the meantime you can use the following command via Maxscript Listener ( PowerPreview has to be open for this to work…)

powerpreview.currentproject.stepdelay=<delay in ms>

so the following would set powerpreview to use 180 secs per step

powerpreview.currentproject.stepdelay=180000

This MXS interface is still only in it’s early stage so please don’t expect other things to work
But setting the time works already, as i have tested just before posting this…


#55

For animations. The long time intervals is for development reasons and not a real scenario.

The script interface might be enough, I’ll try.

I just don’t understand the Iteration Limit button. Does it take the Iteration Limit into consideration only when active so in an off state, only the time limit is active?

How about using codecs as now it saves lossless without codec I assume?


#56

Yes - if off, only the time limit is used. Mainly because the iterations are in reallity only counted viewport redraws. If there’s something causing massive viewport redraws, it might trigger the iteration limit far too early, hence you can disable it completely

You can use any AVI codec 3ds Max provides in the file output->setup dialog. Problem being that Max has a totally bugged AVI file interface, so your codec selection is limited and not showing all 64 bit codecs you got installed. This is a general Max problem ( same when rendering out to an AVI directly)
You can select quicktime output too, this provides a larger codec selection, as it simply interfaces with the quicktime runtime…


#57

I can’t believe I’ve only just discovered how to get dynamic reflections in the viewport…

I have no idea why this isn’t on by default!!


#58

They are pretty buggy, at least on my rig. It’s some cubic reflection calculated internally and when it breaks, only one side of the cube gets calculated and mapped (again, might be my rig which is still DX10 only).
Only repeated toggling of some Nitrous features repairs them after that happened…


#59

Josef,

Is it possible to get Power Preview to render every Nth frame rather than just the frame range?

Thanks for this great tool!


#60

Check your PM