polyAverageVertex nodes and odd crashes


#1

Hello all,

I ran into the craziest bug at work. I wasn’t able to fix the issue, but it got me wondering about node stuff.

Long story short: I had a polygon mesh imported into Maya as an OBJ file, then converted to SubD. I did a lot of smoothing using the Average Vertex on the mesh before converting, and did not delete the history. After conversion I went to save. Maya crashed and a “Fatal Error” prevented the save file that usually gets written to a temp directory from being written.

The file that I originally was trying to save looked fine at load, but the vertices (while present in the .ma file) and UV coords were gone – I was able to go into vertex or UV component mode, but no points were drawn on the mesh and no vertices were selectable. I tried to save what I’d done but my lack of familiarity with the .ma format prevented me, and in the end I simply redid all my point averaging adjustments and saved a new copy.

Now for my question: is it possible in MEL to open up a polyAverageVertex node and get at the points that were selected when the average was applied? I assume there must be some array inside the node of the original selection, which is then applied and is outputted as a mesh to the next node down the sequence. Also, what’s the best way to go about finding out what’s really inside these nodes for the times when you want to re-apply their settings to another object with an identical point count, through MEL?

Sorry if these are really rudimentary things, but all my MEL scripting knowledge is in UI design and animation. ^_^; Thanks for reading.


#2

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.