Pitch & Bank, screwy


When I create a simple prop for a character, I model it in another 3D app, export it as an FBX file and import it into Motion Builder–no problems.

Using constraints and what not, I animate the prop to the character rig. Once it’s done, I select the prop, plot the animation to it then save the selected (as FBX).

When I pull that animated prop into at least two other 3D apps (Modo, Lightwave 8.5) the prop has it’s pitch and bank 90 degrees off (it does this in both apps). That works okay with characters since they have no animation on them (only on the bones)–so I can rotate them and it’s all fixed. But correcting the props looks impossible. The props animation is on the mesh itself, so if I fix the rotation problems, I’m only fixing it for one frame (rather than the whole animation).

Any thoughts on fixing this?
Lightwave 8.5 and Modo don’t offer any corrective options on the import of the FBX–so I can re-adjust it there.

The odd thing is…
… that I just animated a prop a few scenes ago that was the exception to this problem (for some reason). It came into MoBu correctly and after the animation was plotted to it, it imported into Lightwave correctly (no rotation problems). As far as I can tell, I treated these two props exactly the same–same method of creation, export, import into MoBu, animation, plotting and saving.
What’s up?


Just guessing but first thought would be, at some point the axes got inadvertently turned, maybe the props were parented differently at some point or something was different when you applied the constraint.

From your post it sounds like your exporting the characters and the props separately or are they exported together and then go screwy in the destination app?


I haven’t used props yet in MB, but I have just started to use MB and LW9.6. After merging the FBX back into LW with my character, the character always ends up 90 degrees off in pitch AND bank. Always. I just zero them out on the mesh at frame zero and the animation continues normally. I don’t know why it would be any different on props, and I don’t know if/when I will begin to use any props. Perhaps (in LW) create a null which you can parent the prop to?


Thanks you, Sammer & Megalodon,

Sammer: I am using a multi-referential constraint. I’m not sure how to use it properly if it is the cause of the axes mess-up.

Megalodon: Yes, it easy to fix a character but a prop has the animation on the mesh, not on bones (maybe I should go that route). I’ve tried the parenting to a null, but in this case that’s not working either.

It almost seems like a gimbal lock issue, though I’ve tried the gimbal killer when I plot the animation to the prop with no luck.


Hmmm… seems to work now.
I tried two things and one of them seem to work. I just don’t know which one.

First, I moved the prop mesh to be exactly centered with it’s pivot point at it’s very center. Originally, I had the prop offset to be in the position of the character’s hand when I created it.

Secondly, I used a parent/child constraint instead of a multi-referential constraint.

Dunno which solved the issue, but I’ll have to go back with this new pivot-centered prop and try it again with the multi-referencial.

Thanks for the help!

[color=White]Shoot! I typed too soon. Looks like it isn’t working. Sorry!


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.