Particles rendering


#1

Got two questions on Cloud rendered particles.

  1. Threshold. Does this actually do anything on Cloud? It doesn’t seem to really do anything as far as I can tell (rendered one at 1 and one at 10 and I could tell no difference).

  2. Can particles be rendered with motion blur? When I turn on motion blur, it doesn’t really seem to do anything! I’m trying to make a sand/dust effect at the moment and the particles aren’t exactly moving quickly, which could be part of the problem with that but I still just want to ask.

In addition, does anyone know a good method to get the stringy, wispy look of blowing sand? Specifically with software particles as opposed to hardware, because doing it with hardware would be a snap! Thanks.


#2

threshold works, from memory i think it has to do with the distance threshold. So with clouds they should react similary to blooby’s, as they with bunch together.

i think motion blur and multi pass in hardware work hand in hand. this is just from memory.

:slight_smile:


#3

Well I’m speaking specifically about 3D software rendered motion blur. Any thoughts on that?


#4

Nope, neither Maya Software or Mental Ray can render motion blur on particles.

And yes, before you ask, that is the dumbest thing in the universe!

:surprised


#5

Dumb. Annoying. Ridiculous. Take your pick! Lol. Just another stumbling block to getting nice looking particle renders in Maya. I gotta get my hands on AfterBurn and/or start learning Houdini more so I can see the differences people talk about.


#6

jeez jozvex, comes out firing with both barrels!! :shame:

you could try drawing particles. :stuck_out_tongue: whatya say to that Buffy!


#7

Hehe, but seriously, particles are exactly the kind of thing you’d need 3D motion blur for!

Sure, the hardware particles have it, but why should they get all the fun!


#8

there is a very filthy workaround to get motion blur on 3d particles…

btw: threshold does not do anything for cloud particles… at least i was never able getting any effect out that i would have expected.

back to the motion blur:

  • take your cloud particle system.

  • give it a particle instancer and make spheres (best with the same size as the cloud particles have.)

  • software render the instanced spheres with motion blur and the checkbox in the renderglobals “keep motion vectors” (you will have to render in maya .IFF files).

  • render your regular cloud particles without motion blur as .IFF format.

  • now take the command line tool “blur2d.exe” in the maya bin directory and execute it on the 2 images.

  • use the (non documented) flags -v and -c to get the motion blur from the instanced render to the cloud render
    (-v = file with vector infor
    -c = file with color info)

the motion blured color file will be the result.

nice side-effect: you can tweak the motion blur rather well and fast then…

but as i said: filthy

good luck

cheers

alexx

p.s.: to get the streaky look you can also take your regular rendered images (hard or software) to e.g. shake with an average node and blur the result which looks very streaky as well and does not need the motion blur render.


#9

Yowsa! Thanks a bunch, I’ll be sure to try that stuff out as soon as I get a chance.


#10

example:

here is the clouds without MB:

the spheres:

the (very hard … length = 20) blurred clouds:

cheers

alexx


#11

That’s an extremely excellent effect. I’m gonna tuck this one away in my lexicon of cool tricks :beer:


#12

naja… more of a cool workaround than a trick…

if the maya renderer would finally render motion blur for particles this would be obsolete…

if alias (and i mentioned that lack at version 2.5 already to them) would implement those two switches for -v and -c in the help for blur2d.exe it would be even easier :confused:

cheers

alexx


#13

That’s great! Thanks for explaining that!

In my understanding, the threshold value only affects Cloud particles that have some amount of Surface Shading turned on. That makes them sort of a hybrid between Cloud and Blobby particles and it’s the Blobby part that the threshold affects.

Here’s an example image:

Those particles have the Surface Shading set to 0.2. Setting the threshold above 1 seem to make a lot less of a difference too.

:thumbsup:


#14

Oh ok! The help file reveals this:

Surface Shading

Sets how sharply the Clouds are displayed. Enter a value between 0 and 1. A value of 1 displays the Clouds more distinctly; a value of 0 creates a cloudier effect.

Threshold

Controls surface blending between the Clouds. A value of 0 creates no blending; a value of 1 creates maximum blending.

Increasing the Threshold displays the Clouds smaller, so you might need to increase the Radius as you increase Threshold.


#15

How does one assign a surface shader to cloud particles by the way? Every time I render a scene with cloud particles and surface shading turned on, it tells me that they “need a surface shader. i.e. Lambert”. I have tried to assign a shader of some sort to them but it didn’t work for me.


#16

If you open the Attribute Editor to the properties of the Cloud Shader, press the Upstream button (I hope you know what I mean) to get to the Shading Group node.

On the SG node there are three slots, Surface Shader, Volume Shader and Displacement Shader. You just need to add your Lambert or whatever into the the Surface Shader slot.

:wink:

P.S. I haven’t got Maya open so I’m not sure if that was 100% right, hehe.


#17

Mmmm, displacement shader on particles… LOL. I dunno if it even recognizes displacement for particles but that would be a great way to get yourself year-long rendertimes. Heh. I will check out the upstream connection deal in the morn when my render is done. Thanks.


#18

Originally posted by Jozvex
[B]That’s great! Thanks for explaining that!

In my understanding, the threshold value only affects Cloud particles that have some amount of Surface Shading turned on. That makes them sort of a hybrid between Cloud and Blobby particles and it’s the Blobby part that the threshold affects.

Those particles have the Surface Shading set to 0.2. Setting the threshold above 1 seem to make a lot less of a difference too.

:thumbsup: [/B]

i must admit i completely forgot about that surface feature…
must be because i never use it :slight_smile:

thanx

alexx


#19

Originally posted by alexx
[B]there is a very filthy workaround to get motion blur on 3d particles…

btw: threshold does not do anything for cloud particles… at least i was never able getting any effect out that i would have expected.

back to the motion blur:

  • take your cloud particle system.

  • give it a particle instancer and make spheres (best with the same size as the cloud particles have.)

  • software render the instanced spheres with motion blur and the checkbox in the renderglobals “keep motion vectors” (you will have to render in maya .IFF files).

  • render your regular cloud particles without motion blur as .IFF format.

  • now take the command line tool “blur2d.exe” in the maya bin directory and execute it on the 2 images.

  • use the (non documented) flags -v and -c to get the motion blur from the instanced render to the cloud render
    (-v = file with vector infor
    -c = file with color info)

the motion blured color file will be the result.

nice side-effect: you can tweak the motion blur rather well and fast then…

but as i said: filthy

good luck

cheers

alexx

p.s.: to get the streaky look you can also take your regular rendered images (hard or software) to e.g. shake with an average node and blur the result which looks very streaky as well and does not need the motion blur render. [/B]

Alright… time to resurrect this thread a moment. I’m trying to use this technique now but I cannot get the blur2d.exe to run correct. I am typing:
blur2d.exe -v blurredOne.iff -c colorOne.iff -l 2

blurredOne and colorOne are my two rendered file obviously. What the program returns is:
blurredOne.iff + colorOne.iff ==> ./colorOne_blur.iff
Cannot read colorOne.iff - file doesn’t exist or is of unknown format.

What’s up with this? Do I need the full path? I tried to do that but the command line won’t let me type long enough to enter the full path for both files. Any help would be super appreciated. Thanks.


#20

OK, so I figured out the command line thing, got it in the right directory using chdir, i’m not too familiar with the command line in windows obviously. But now it’s saying “error in reading motion vector”! Is there something I’ve got to remember to do so that I can use the motion vector data? I’ve gone into the render globals, turned on motion blur 2d and turned on “keep motion vectors”, I then turn the particle object to points type so that they don’t render and only the spheres render. Something I’m missing or doing wrong? Thanks for any help.