Particle's are not deflecting right. some do but most dont


Hi everyone. I’m fairly new with particle flow and i’ve done a few tuts off from the internet too. my project is that im trying to animate my blood(particles) inside a cylindrical object (editable poly with flip faces) hit the vein walls (Udeflector). My setup is good and everything collides well and is fairly smooth. the problem exist when i try to animate the vein walls. I’m deforming the vein wall with an animated ffd box(6x6x6). So while the walls are deforming some particles just pass right through the walls while some are deflecting the right way. I’ve experimented with every possible values in the udeflector but it still doesn’t work. right now i have my bounce set to .5 and my speed in the pflow system is only 150. i hope someone can shed some light to this newbie question. i know i’m missing something here. and i’ve looked all over allan mckay’s tuts and other forums but none has the same problem as i have. and my project requires me deform the vein walls so i cant disregard it’s animation.

here’s a screenshot


This is a known limitation of UDeflector (see for example here:

PFTools:Box#3 has a possible work-around where you can detect if a particle inside/outside of a mesh volume, and then snap it back if it leaves the mesh volume.

Oleg B.


thanks for the reply oleg. i guess i have to redo my animation some other way. i think i’ll go back to using PArray with pathfollow bound to it. Is there a way in pflow to have it follow a path too? my emitter shouldn’t be moving but its particles should follow a spline. hmm… i can’t afford box#3 for now. crossing his fingers maybe next year.


Is there a way in pflow to have it follow a path too?

There is Speed By Icon operator but it is limited to stationary splines.

Oleg B.


I think you could also try to animate it with speed by surface, and then change to spedd continuosly and along surface. the particles will not bounce inside the cylinder, but you could get nice results i think.


Have you tried adding a “find target” operator then setting your target to a spline/follow path constraint? Try starting your target path in front of the emmitter. Match the particle speed to the percent path so the particles never actually catch up to the target. You’ll need a series of emmitters and targets to fill your flow but it should work. Put a spline IK Controll modifier on your spline and link the controllers to your vein walls.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.