Particle Flow Discussion


There is no bug free software, but one thing to keep in mind when using Collision operators and Deflectors is that the order of operators matters. Depending on where in the event or in the flow the Collision is processed relatively to the Spawn operator, some particles might just pass through. In the simplest case of a single Event, Spawn and Collision, if the Spawn operator is placed after the Collision, the Collision will process the new particles in the next integration step, and at that point they might have already passed through the Deflector. If the Spawn is before the Collision, the new particles should hit the Deflector. If they still pass through, reducing the Integration Step duration might help (esp. with complex mesh-based deflectors).
In the more complex case of sending out the trail particles to a new Event, obviously both Events need the Collision to happen after the Spawn, or putting the Collision in the Global Event to it processes the collisions after all Speeds have been assigned, but before the new Positions have been calculated.

If you would post a simple test scene showing the leaking particles, someone on this forum might take a look and see if there is anything obvious you could do…


Thank you for your reply… Here’s my very simple 350kb test scene…

Just some particles coming out of the surface of a sphere, dripping on the sphere and below (I’ve tried with lock/bond too, at this point I’m using Speed By Surface). With the Spawn test disabled all 10 particles collide with the Deflector, when I enable it I can see five of them leaking…

Also, exactly how can I pass the parent particles along with their children as a pack to another event? I’ve tried moving the Collision test to the “Spawning002” Event before the Delete operator but I still see some leaking…


Not quite sure to understand what you need, perhaps I’ve to re-read your post, but your scene seems to work just fine.
Your deflector is set on Continue, so particle don’t bounce. In the event you wired to the collision there’s a gravity which makes particles moving even faster.
If that’s what you want then it’s working, and if you want to keep the particle spawning after the collision you may just want to add another spawn operator in the event with the gravity and you’re done.


As I suggested in my previous post, changing the Integration Step to 1/8 Frame solves the problem. At larger steps, you get 5,3 or 2 particles leaking. You should change both integration steps (viewport and render) in the Source.


Thank you very much, I hadn’t even noticed that setting, noone had messed with that in any of the tutorials I had gone through.


i need produce from 1 particle point cloud with random position around it. How can i make it?


Is there ability in Data Operator to find closest point of geometry in arbitrary direction, kinda RayCast node in Softimage ICE?


Sure, use the point position function. See attached example:


New reel. PFlow in there of cause :slight_smile:


Nice, getting a big list of sweet projects there Ansi! :keenly:


Wanted to share with you a solution for a crashing Max2017 using Pflow.

I ran a PF simulation of approx 50k particles and the Max crashed constantly every time I tried to scroll the timebar. So if you’re using Data operators on PFlow on Win 10 - make sure you Run compatibility as Windows 7.


Ok, here is the deal.

I’ve made this PF system:


And I wanted particles to travel on character.
So I used lock/bond, very simple setup:


Well, it’s kind-a cool, but still particles not moving as the first video. They rush towards the head, and then particles becomes “confused”.
I know it’s probably mesh issue, and perhaps, maybe I am expecting too much from the lock/bond.

Is there any way, to really force lock/bond to just ignore everything, and simply place a particles on the surface? Or any other idea?

Here is lock/bond screenshot:


Hi, is there a way to display range of the Keep apart operator in the viewport?


I figured this question could go here with a lot of knowledge like Bobo here, but I have a weird thing happening. So about 6 months ago I made some scenes using particle flow in Max 2016 to make leaves and grass clumps and stuff and rendered it on our farm everything is ok. There have been a couple Max service pack updates and as far as I know we are all up to date now. However now that I go back to the scenes using particle flow, it appears that the leaves and grasses are in different positions (although no one messed with them), looks like it’s a different seed, but they are still using the default seed 12345. Has anyone else experienced their particles changing positions recently in scenes? This is making it very frustrating to go back and rerender certain areas in our animation.


HiI am making some light trails in Pflow. Following the tutorial below. What I would like to do is use an animated image sequence to drive the shape of the light trail to get more variation in the shape.
My question is…Howcan I make an image sequencestop playing as the particle is created? When a particle has createdthe image that is assignedto thatparticleon that frame locks to that particleand the sequence stops playing. Almost like an echo effect.




Hi Mills

Why not just use a still and rotate your source for the particle system, that way it will leave behind rotated particles.
I don’t have time right now, but if I remember I’ll try setup a system to demonstrate shortly.



Thanks for looking into this. I don’thave the file with me now… will have to take a look tomorrow. I am using a shape facing operator so it does not take into account therotation as far as I can remember.*



Yeah, wont work with facing particles.

But here is a test I did, see if it could work for you



Very nice :applause:


Where did everyone go?