Paint Effects Flicker


#1

I’ve got a tree that I rendered out that is paint fx and the color of it is flickering like swarming bugs. I’ve read through the previous threads in regards to this problem and did as Duncan suggested and turned on the Oversample and Oversample Post Filter options in the paint Effects Rendering Options in the Render Globals. There are no fake shadow options on the strokes and they are set to cast and receive d-map shadows. I’m sort of at a loss here and would greatly appreciate any help anyone could offer. Thank you,

Bill


#2

hmm… this may sound “stupid”, but did you try to use another paintfx tree, to see if the prblem persists?!Because sometimes is just a “bug” with the paintFX. I remember that there was a FAQs page in the highend3d website, they were talking about some paint fx problems and how to solve this problems and they mention something about paint fx “bugs”.:shrug:


#3

you mean self shadows? cause pfx has problems with auto d map shadows. Im using a hidden plane to recieve some shadow, and the shadow map problem is gone. The other way is to conver to polygon and render raytrace shadow.


#4

You can always double res your render. Works for me. :slight_smile:


#5

It’s happeneing on all the trees in my scene, I have several dynamic ones that are reacting to an object and several background trees, they are all suffering from this issue. None of them have the auto shadow or fake shadow options turned on, just one light in the scene casting d-map shadows. Convering to polygons won’t work as my texture I’m using for it does not follow over well enough to look convinving and I’m not about to lay out the uv’s on 20+ trees heh.


#6

Are you sure that shadow is the problem? make a render without shadows


#7

That’s what I"m about to try next, I’ll give that a shot and see if that’s the culprit.


#8

You could also try deleting any lightFog in the scene as well as any
particle simulations as a test(lightFog currenty has problems with paint
effects).

I had a rather subtle problem once with animated self shadowing trees
and flickering. It turned out to be more a problem with a lack both of global illumination and motion blurred shadows… in real life the multiple scattering from leaf to leaf softens the cast shadows as does the effect of motion blur on the shadows. Without this the rapidly shimmering leaves can make it look as if the light is fluttering. I converted paint effects to poly and had the same problem. If you have disable the animation on the trees and still have flicker then it is not this problem.

However I’ve seen another shadow related problem where the tubes suddenly glow at
random frames. It was hard to reproduce and may have been fixed in a past release, so it would be useful to know if you are encountering this problem.

If nothing works you could try converting paint effects to poly( if you can handle the poly count… the pfx->mesh quality window can help get the poly level down ).

Duncan


#9

Thanks for the tips and suggestions everyone. The culprit appears to be the dmap shadows from the light in the scene. Turning it off fixed the problem, cranking it up to 4096 didn’t help very much and pushing it past that is going to be pretty nasty on my render times. I’ll fiddle around with it some more and see how bad it’s going to be. Thanks again all.


#10

After some more tweaking I’m still getting this issue. I decided to turn off all the shadows completely and see what happened, still getting that buzzing in the tree. I’ve tried it with just Oversampling on, and with Oversample Post Filter on as well, it seems to be “better” with the Oversample Post Filter activated, but it’s still very bad, bad enough not to be usable.


#11

Something else I just noticed is that when I render from a still camera (not animated) the PaintFX are perfect. However when I render from my tracked animated camera, the problem rears it’s ugly head.


#12

Well I think I’ve solved the issue. Under Flow Animation for the brush attributes of the tree I found that Texture Flow was checked on. I unchecked that and now it renders out perfectly. 2 days later and about 100 strands of less hair later, I think it’s fixed…


#13

Ahh… you are doing a growth animation then… We really need to go through all the plant type presets and set textureFlow off. One never wants this when using flowspeed and timeclip to get plant growth.

Duncan

#14

well im making a season change clip too !!! but i keyframe varius atributes.


#15

I’m not really sure why it will render perfectly from a still camera but the color swarms all over if the camera is animated? This shot was handed off to me to render as a group project (I just did the lighting on the cg elements and matched that to the background plates) and so I’m not too familiar with Paint FX. I’ll be happy to send someone the tree that I’m having the problem with if they want to take a look at it. I’m trying to get this wrapped up before I leave for SIGGRAPH on Saturday.


#16

[color=white]from Highend [/color]
[b]Plant Growth

Q: The texture on my tree trunk flows up the tree as it grows( in an unnatural fashion ).

[/b]
[ul][b]A: Select the affected strokes and type

freezeBrushTexture

This creates an expression that counteracts the flow effect on the texture. This should always be done when attempting to simulate growth using flowSpeed and timeClip( as opposed to simulating something like fireworks ).[/b]
[/ul]
[ul]link here
[/ul]
[ul]http://www.highend3d.com/maya/tutorials/paintfxqa/m.3d
[/ul]


#17

I’m not simulating growth, but thanks anyway. I’ve read through that FAQ as well several times. I don’t have time to mess with it any more right now and the person who did the trees has been in contact with Alias in regards to it. Just going to have to wait and see at this point. Thanks again for everyones help and suggestions, I appreciate it very much.


#18

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.