nParticles with instancer and random scale


#1

I have a scene where I have a cup that i’m trying to fill with 4 different kinds of berries.
I have the cup filling and the berries are running through the instancer just fine, problem i have iw that i cant randomize the scale of the berries.
if i randomize the scale then the collision radii dont sync up, and if I randomize the the radius, then the geometry collides with gaps between them.

I have tried a few different ways, but somewhere i seem to be missing something.
anyone have more ideas on what I could attempt


#2

Hi,

what Maya version are you using? This was a bug once upon a time :wink: that was fixed and only the collision thickness display was wrong. But since 2017 this should also be fixed.

Cheers


#3

working in Maya 2018


#4

In what way are you randomizing the radii? Are you using the internal radius ramp?


#5

I dont think so, it doesnt seem to be hooked up anywhere.

i was just trying to use a “=rand (.4, 1);”


#6

something isnt wired up properly, if i use the radius ramp it does nothing


#7

Is the internalRadiusRamp connected to the radiusPP attribute? It should connect automatically if radiusPP is not used within an expression and you change settings on the radius ramp.


#8

it did create the link when i set the ramp to normalised age, but it still isnt changing the size


#9

ok, so i can get the particle shape to randomize, but if i turn on spheres (under shading so i can see the collision particles) my mesh objects from the instancer always seem to be smaller than the collision sphere


#10

You should be able to simply scale your objects until they match the particle radius.


#11

well, the scale is random, so if i change the scale of the objects, I will still have the same issue where some will be bigger and others smaller than the collision radius


#12

setting it to scale using the age makes the particles/objects change through the whole animation, i need it to randomize scale on creation only


#13

The reason your instances don’t sync up with particle radius is because those attribute aren’t connected by default. Instance size is controlled by a scale attribute on the Instancer (Geometry Replacement) section. You can connect radiusPP to the scale of the instanced geo. Should solve your issue.