nParticle rgbPP resetting to 1,1,1


I’m importing Lidar data as nParticles. I’m able to create the particles and apply the rgbPP color to the particles, however, the color doesn’t seem to save. I have multiple files, one for each timestep, they are each brought in as an object keying visibility on the frame in which it will be displayed. If I scroll through the time slider, the color gets reset to white for each object. If I nCache the object, the color stays on the time slider, but when I re-open the scene, the colors are gone. The cache is there, but the rgbPP attribute isn’t listed in the component editor.

Anyone know what is going on and have any ideas on how to resolve?


What version of Maya are you using? Not sure, but this can often make a huge difference.


This is occurring in both 2017 and 2018, so I’m hoping that there is just some setting that I’m missing somewhere. I’ve already made sure that Save Startup Cache is marked in the preferences.

I should also mention that I have to disable nucleus1 because if any effects are applied to the particles (not just keying visibility) then the rgbPP resets as well.


I finally figured it out… it was the initial state causing me problems. When I set the initial state after applying the rgbPP, it kept the color without having to cache. However, when I opened the file back up it was all black. Using the Autodesk help page, 'Understanding Initial State Attributes’, I figured out that when I was importing, I also needed to set the value for rgbPP0 as well as the value for rgbPP. Because rgbPP0 defaults to values of 0,0,0.

It now works, and I can save the scene, reopen it, and still see the color information without caching. I’m not sure how it will affect my import time though.