node in error


Newbie here… trying out to do z-depth composit in Shake.

Me (editor) and my co-worker (3DsMax modeler) are testing Z-depth composit using Shake.

After severl research, I had 3D guy to render frames as rpf and OpenEXR for me to test in Shake.

Somehow, the z-depth is inverted. (3dsMax shows white as being closer, but in shake, it shows black as being closer).

I used color-invert node to invert everything (rgbaz), then re-invert again except z (rgba).
Somehow this works.

After I figured this out, I “filein” another frame set into Shake.

It will show in node view as the file is imported, but the context help says “node in error”
and the path is in red.

I checked the linking path and re-link it and it wouldn’t change anything…
Nothing will show in viewer…

(I tried exr file and it showed this problem, so I tried rpf file, but was the same thing).

I checked if there were any missing frames in between… but they were all there.

Can anyone guess what’s wrong or what step i’m missing so that Shake can actually see the frames for me to play with the file to composit??


Is the current frame of the sequence missing or incomplete? That would give you an error.

Also you don’t need 2 inverts, just enter “z” in the channels parameter and it will ignore the color channels.


Thanks, pgraham,
Invert once with just Z worked… !! thanks.

For the second issue…
the 3D guys rendered 100 frames, and I don’t think the current frame of the sequence is missing…
and what do you mean by “imcomplete”?

I can open first frame of exr and see it’s rendered correctly…


Can you open shake through a terminal? When the error happens, shake will output a more detailed message to the terminal window. Post that message here and we’ll have a better chance of helping.


I think I’ve had trouble loading images with more than 4 channels into Shake before. Z depth images are better at 32-bit (floating point) anyway so I would just render out an 8bpp or maybe 16bpp RGBA sequence and a separate 32bpp depth sequence (just a single channel image). I tend to just use TIFFs as they are easy to open in a wide variety of programs. It should be fairly easy to get multi-pass output from 3DS Max.


pgraham : sorry, it took me a while to get back to here… had a vacation in the middle.
I don’t know how to open Shake through terminal…

I will look into that and find the detail of the error.

osxrules : thanks for the reply… the main reason for us to use rpf is using z-depth. we want to see if we can figure out how to do z-depth compositing cleanly using shake so we can use it for our future projects…
I don’t think tiff supports z information…does it?


It depends what system you’re on. If it’s OS X, it’s /Applications/Utilities/terminal and just type in shake and hit return, Linux will be similar. For Windows, use start menu > run > cmd hit run and I guess type shake too.

Ah, I render out depth passes as 32bpp tiffs by using a renderman output variable. I like being able to preview the depth passes in other software. Also, I tried using the zfile output from renderman before and it didn’t work in Shake either. I will try and output a .rpf from Maya and see if I can get it to work in Shake.


This is what I get in the terminal window.

error: /Users/VST/Desktop/Composite Testing/Gyroscopic Test/OuterRing01/Outerring0001.exr: Could not open file. Cannot read image file “/Users/VST/Desktop/Composite Testing/Gyroscopic Test/OuterRing01/Outerring0001.exr”. No such file or directory.


Here’s some info about the OpenEXR format:

If you are using a version of Shake less than 4, you will need a plugin. Maybe remove the spaces from your file path too (e.g rename Composite Testing to CompositeTesting). AFAIK, Shake works fine with spaces but it may depend on your version and filesystem.

Actually try moving the exr file to your root directory so it opens as just /Outerring0001.exr. If it gives the same error, it’s likely a format problem.


Thanks for your reply…

my version of Shake is 4.1
and EXR is created from 3Ds Max.


This is kind of off from the main topic, but I have problem make shake’s filen get to my network server…

I can navigate through to my network, but it won’t open the network folder…
I mean… the network folder will be in the list of the filein node, but double click or nothing can go even further from there…

I hope this make anysense…

Therefore, my 3D guy saved the exr or rpf file for me to do the test in shaake, I always have to saved those file over to my local drive so that I can reach to the file from Shake…


Would you be able to post a test exr and rpf that fail for you? Try if you don’t have hosting.

Do you mount the network drive on your desktop first? If so, you can try going through the Volumes folder on a Mac and I think Linux. It will be in your root directory.

Your console will probably give you information about what is happening when you try to connect. It’s in /Applications/Utilities/Console.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.